Results 1 to 10 of 10

Thread: Cannot install tasksel

  1. #1
    Join Date
    Jan 2013
    Beans
    4

    Cannot install tasksel

    I am trying to install tasksel using the command

    Code:
    sudo apt-get install tasksel
    but I get the following error....

    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     initramfs-tools : Breaks: console-setup (< 1.72) but 1.34ubuntu15 is to be installed
     initscripts : Breaks: console-setup (< 1.74) but 1.34ubuntu15 is to be installed
     libglib2.0-0 : Breaks: gvfs (< 1.8) but 1.6.4-0ubuntu1 is to be installed
    E: Broken packages
    Before running the install, I added the souce 'deb http://ftp.de.debian.org/debian sid main' as mentioned in http://packages.debian.org/sid/all/tasksel/download

    What am I doing wrong?

  2. #2
    Join Date
    Apr 2012
    Beans
    5,128

    Re: Cannot install tasksel

    Hello and welcome

    If you really need tasksel it should be in the standard repository - why do you think you need to add a Debian repository?

    Alternatively there may be easier / better ways to install the components you want (ssh server? LAMP?) directly

  3. #3
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: Cannot install tasksel

    Quote Originally Posted by cuebiz View Post
    Before running the install, I added the souce 'deb http://ftp.de.debian.org/debian sid main' as mentioned in http://packages.debian.org/sid/all/tasksel/download
    That's what you've done wrong.

    You've added a Debian source to your Ubuntu machine. This will break everything in your installation pretty quickly. What made you think you had to add it? The standard Ubuntu repositories already contain tasksel.

    Remove the line you've added to your sources.list then just do...
    Code:
    sudo apt-get update
    sudo apt-get install tasksel
    Cheesemill

  4. #4
    Join Date
    Jan 2013
    Beans
    4

    Re: Cannot install tasksel

    Thank you Cheesemill and steeldriver. I am not able to find tasksel in Synaptic Package Manager

    This is what I get if I run the install without this source added

    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Package tasksel is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    E: Package 'tasksel' has no installation candidate

  5. #5
    Join Date
    Apr 2012
    Beans
    5,128

    Re: Cannot install tasksel

    what version of Ubuntu are you running?

  6. #6
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: Cannot install tasksel

    It's definitely in the main Ubuntu repository...
    http://packages.ubuntu.com/search?ke...ll&section=all

    Did you run...
    Code:
    sudo apt-get update
    first?

    If you still don't have any luck can you post the output of...
    Code:
    cat -n /etc/apt/sources.list
    Cheesemill

  7. #7
    Join Date
    Jan 2013
    Beans
    4

    Re: Cannot install tasksel

    I am using 10.10

    yes, I did run update. It gave few 404 errors. Would that be a problem?

    I am attaching my source.lst
    Attached Files Attached Files

  8. #8
    Join Date
    Oct 2005
    Location
    INDY
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Cannot install tasksel

    10.10 has passed End of Life

    https://help.ubuntu.com/community/EOLUpgrades
    those repositories do not exist you will need to upgrade to a supported release or reinstall.
    Castles Made of Sand,
    Fall in the Sea,
    Eventually!

  9. #9
    Join Date
    Feb 2009
    Location
    Dallas
    Beans
    1,303
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Cannot install tasksel

    Quote Originally Posted by arpanaut View Post
    10.10 has passed End of Life

    https://help.ubuntu.com/community/EOLUpgrades
    those repositories do not exist you will need to upgrade to a supported release or reinstall.
    To the original poster, if you need an install to be supported for an extended period of time use an LTS release like 12.04 LTS (supported until April of 2017).

  10. #10
    Join Date
    Jan 2013
    Beans
    4

    Re: Cannot install tasksel

    Thank you all. Let me upgrade and let you know the result

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •