Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Few issues with Ubuntu especially with 5.1 system

  1. #11
    Join Date
    Jan 2013
    Location
    Another Dimension
    Beans
    164
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: Few issues with Ubuntu especially with 5.1 system

    Just a quick note.
    Earlier in the thread you mention your sound max chip but as I understand it you are using a vm.

    You need to check the vm sound emulator (there are normally a couple of choices) and make sure that the driver you have installed is the emulated one and NOT the host one.

    Also the chosen emulated sound card has to be of course 5.1 compatible

    Should also say that I have found that the intel 'HD' sound driver can be a pain. Every time I have to rebuild something with Intel sound I go weak at the knees. HDMI out through nVidia by far easier and always seems to just work.

    In general I find the live cds very good at finding device drivers. In fact with servers ubuntu is easier to use than windows so keep persevering.
    Last edited by furything; January 25th, 2013 at 01:36 PM. Reason: extra info

  2. #12
    Join Date
    Aug 2009
    Beans
    11

    Re: Few issues with Ubuntu especially with 5.1 system

    Quote Originally Posted by furything View Post
    Just a quick note.
    Earlier in the thread you mention your sound max chip but as I understand it you are using a vm.

    You need to check the vm sound emulator (there are normally a couple of choices) and make sure that the driver you have installed is the emulated one and NOT the host one.

    Also the chosen emulated sound card has to be of course 5.1 compatible

    Should also say that I have found that the intel 'HD' sound driver can be a pain. Every time I have to rebuild something with Intel sound I go weak at the knees. HDMI out through nVidia by far easier and always seems to just work.

    In general I find the live cds very good at finding device drivers. In fact with servers ubuntu is easier to use than windows so keep persevering.
    I'm actually running Ubuntu on a second HDD, the sound is the only thing which is keeping me from using it on a daily basis. Why has the Ubuntu sound stack not been fixed/made to work properly on my sound card. Is there something wrong with Ubuntu or is it just some kind of bug that will be fixed in the next release?

  3. #13
    Join Date
    Jun 2007
    Beans
    11,011

    Re: Few issues with Ubuntu especially with 5.1 system

    Quote Originally Posted by Yowan View Post
    Why has the Ubuntu sound stack not been fixed/made to work properly on my sound card? Is there something wrong with Ubuntu or is it just some kind of bug that will be fixed in the next release?
    The bug has 0% chance of being fixed if you (or someone with your laptop) don't report it. You can't just assume that a very hardware-specific bug like that will be reported and fixed. BTW, what is your laptop model?

  4. #14
    Join Date
    Jan 2013
    Location
    Another Dimension
    Beans
    164
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: Few issues with Ubuntu especially with 5.1 system

    looks like there was a bug report and work being done to fix it.
    https://bugs.launchpad.net/ubuntu/+s...er/+bug/213206
    Have not read this to see if fixed or if there is a description of a process to get surround sound to work now. I will leave that to you to read

  5. #15
    Join Date
    Jun 2007
    Beans
    11,011

    Re: Few issues with Ubuntu especially with 5.1 system

    Quote Originally Posted by furything View Post
    Have not read this to see if fixed or if there is a description of a process to get surround sound to work now. I will leave that to you to read
    Maybe you should read it ( ) since the bug is about the digital output and not missing center/subwoofer on analog 5.1

  6. #16
    Join Date
    Jan 2013
    Location
    Another Dimension
    Beans
    164
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: Few issues with Ubuntu especially with 5.1 system

    Sorry Temüjin yes I probably should.

    This will teach me to take time and read threads rather than GLANCE.

    Installing win 2008 r2 on a sunfire
    box which is far more frustrating than running ubuntu server 12:10 on one.

  7. #17
    Join Date
    Aug 2009
    Beans
    11

    Re: Few issues with Ubuntu especially with 5.1 system

    Quote Originally Posted by Temüjin View Post
    The bug has 0% chance of being fixed if you (or someone with your laptop) don't report it. You can't just assume that a very hardware-specific bug like that will be reported and fixed. BTW, what is your laptop model?
    I'll look into it, where exactly should I report hardware-specific problems? I'm using a PC btw, the sound card is an Asus Supreme FXII which is not completely a standalone card as it is plugged in the audio riser slot of my board). On Windows it required a driver which automatically adjusted the speaker setup. I couldn't find the Linux version of that thing on Asus's website. It seems that they never provided any linux drivers.

  8. #18
    Join Date
    Jan 2008
    Location
    Ireland
    Beans
    67

    Re: Few issues with Ubuntu especially with 5.1 system

    Really I'd like to try to fix something there if you could post as much as you can and anyone else that has the same hardware. Link the info to launchpad and we'll try to get this thing up to speed.

    I was looking to do some sound hardware hacking so give us a hand there with the post above:
    https://bugs.launchpad.net/ubuntu/+s...er/+bug/213206

    Or not 505 error there... so close.
    Please post in new bug report:
    https://bugs.launchpad.net/ubuntu/+s...r/+bug/1120853

    Could someone give me a more verbose output of the above driver for development purposes?

    https://wiki.ubuntu.com/DebuggingSoundProblems

    wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
    It will run automatically and then file it in my new bug report:

    Thanks.
    Last edited by Hugh Mulqueen; February 10th, 2013 at 06:15 AM.
    bertie

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •