Results 1 to 7 of 7

Thread: Setting up multiseat with Nvida + Intel

  1. #1
    Join Date
    Jan 2013
    Location
    Riga, Latvia
    Beans
    90
    Distro
    Ubuntu Development Release

    Setting up multiseat with Nvida + Intel

    I have PC with connected 4 monitors. 1 to intel, 3 to nvidia card. Lightdm is configured for two seats.

    Currently I have two problems:
    1) Sometimes xorg doesn't detect intel. To get both seats working i need to restart one or multiple times pc. Probably, stopping and starting lightdm service is enough. Is there anything I can do to fix it?
    2) I cannot get pulseaudio to work on both seats. Can someone help me?

    I have installed all updates and newest nvidia driver - 313.09.

    Sorry about my English!
    Last edited by albertsmuktupavels; January 9th, 2013 at 01:14 AM.

  2. #2
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Setting up multiseat with Nvida + Intel

    maybe you can switch lightdm by gdm, to see if its better. But as the question is complex, you'd better ask directly to skilled devs on askubuntu.

    to reconfigure lightdm & select gdm as default:

    sudo dpkg-reconfigure lightdm-gtk-greeter

    http://askubuntu.com/questions/ask
    Last edited by dino99; January 9th, 2013 at 03:57 PM.

  3. #3
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,855
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Setting up multiseat with Nvida + Intel

    Quote Originally Posted by dino99 View Post
    maybe you can switch lightdm by gdm, to see if its better. But as the question is complex, you'd better ask directly to skilled devs on askubuntu.

    to reconfigure lightdm & select gdm as default:

    sudo dpkg-reconfigure lightdm-gtk-greeter

    http://askubuntu.com/questions/ask
    Code:
    sudo dpkg-reconfigure lightdm
    I think that greeter is not installed by default...
    @ albertsmuktupavels: There are ways of switching that does not include reconfigure... If You need them, just ask... But, I admit this is kind of faster...

  4. #4
    Join Date
    Jan 2013
    Location
    Riga, Latvia
    Beans
    90
    Distro
    Ubuntu Development Release

    Re: Setting up multiseat with Nvida + Intel

    Quote Originally Posted by dino99 View Post
    maybe you can switch lightdm by gdm, to see if its better. But as the question is complex, you'd better ask directly to skilled devs on askubuntu.

    to reconfigure lightdm & select gdm as default:

    sudo dpkg-reconfigure lightdm-gtk-greeter

    http://askubuntu.com/questions/ask
    Why switching lightdm to gdm would help?

    Currently problems are:
    1) Sometimes intel is not detected when lightdm starts, or it is detected too late, because when i stop lightdm and start again from console (ctrl + alt + f1) everything is working. I can login in both seats.
    2) Sound works only in one seat. I guess it is pulseaudio problem not lightdm.

    Ok, I will ask on askubuntu. Thanks!

  5. #5
    Join Date
    Mar 2011
    Beans
    5

    Re: Setting up multiseat with Nvida + Intel

    Quote Originally Posted by albertsmuktupavels View Post
    Why switching lightdm to gdm would help?

    Currently problems are:
    1) Sometimes intel is not detected when lightdm starts, or it is detected too late, because when i stop lightdm and start again from console (ctrl + alt + f1) everything is working. I can login in both seats.
    2) Sound works only in one seat. I guess it is pulseaudio problem not lightdm.

    Ok, I will ask on askubuntu. Thanks!
    2) You need to start Pulseaudio in System Wide Mode
    don't know about raring but in quantal you have to edit this file /etc/init/pulseaudio.conf (instructions are on the file)

    with system wide mode all the seats will share the sound

    1) really i don't know, i have an amd/nvidia multiseat but with kdm never tried lightdm, one thing i can say is that you can't enable different openGL libraries implementations at the same time, you have to choose between mesa/nvidia/amd/intel


    finally why are you using raring? is still alpha

  6. #6
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    6,753
    Distro
    Ubuntu Development Release

    Re: Setting up multiseat with Nvida + Intel

    Please remember that I have little idea about what you are talking about. That means I have no idea about what I am talking about.

    I think that to speed up the loading of Ubuntu some parts are still being activated while we are at the login screen. You have four xservers to activate. Perhaps you are getting to the login screen too fast. Yes. I know that it is a silly idea but today is my day for silly ideas.

    Regards.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  7. #7
    Join Date
    Jan 2013
    Location
    Riga, Latvia
    Beans
    90
    Distro
    Ubuntu Development Release

    Re: Setting up multiseat with Nvida + Intel

    Quote Originally Posted by kamiloxnumetal View Post
    2) You need to start Pulseaudio in System Wide Mode
    don't know about raring but in quantal you have to edit this file /etc/init/pulseaudio.conf (instructions are on the file)

    with system wide mode all the seats will share the sound

    1) really i don't know, i have an amd/nvidia multiseat but with kdm never tried lightdm, one thing i can say is that you can't enable different openGL libraries implementations at the same time, you have to choose between mesa/nvidia/amd/intel


    finally why are you using raring? is still alpha
    2) Uncommented 'start on' line in /etc/init/pulseaudio.conf. Added both seat users and lightdm to pulse-access group. And now in sound settings I have only 'Dummy Output' device in both seats.

    1) Why I can not? I already done that. At least I think so...
    Attached Images Attached Images

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •