Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Cant connect wifi (Centrino Wireless-1000)

  1. #11
    Join Date
    Jan 2013
    Beans
    6

    Re: Cant connect wifi (Centrino Wireless-1000)

    Quote Originally Posted by chili555 View Post
    I suggest you remove the USB and then try these commands:
    Code:
    sudo modprobe -r rt2800usb
    sudo modprobe -r iwlwifi
    sudo modprobe iwlwifi 11n_disable=1 bt_coex_active=N
    Then tell us if you are able to connect with the internal device only.
    Woow, it works now!. Now I can connect without USB.

    Is this is required every reboot?
    What are the CONSEQUENCES of disabling 11n?

  2. #12
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,877
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Cant connect wifi (Centrino Wireless-1000)

    The consequence is that you won't be able to get N speeds. Hopefully, you are not streaming Blu-Ray over your network to a laptop.

    It will not be required on every boot if you write one file:
    Code:
    gksudo gedit /etc/modprobe.d/iwlwifi.conf
    A new empty file will open. Type in one line:
    Code:
    options 11n_disable=1 bt_coex_active=N
    Proofread, save and close gedit.

    Please use thread tools to mark Solved.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #13
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    5,219
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Cant connect wifi (Centrino Wireless-1000)

    Now you can make it permanent:
    Code:
    echo "options iwlwifi 11n_disable=1 bt_coex_active=N" | sudo tee /etc/modprobe.d/iwlwifi.conf
    Edit: Seconds too slow

  4. #14
    Join Date
    Jan 2013
    Beans
    6

    Re: Cant connect wifi (Centrino Wireless-1000)

    Quote Originally Posted by chili555 View Post
    The consequence is that you won't be able to get N speeds. Hopefully, you are not streaming Blu-Ray over your network to a laptop.

    It will not be required on every boot if you write one file:
    Code:
    gksudo gedit /etc/modprobe.d/iwlwifi.conf
    A new empty file will open. Type in one line:
    Code:
    options 11n_disable=1 bt_coex_active=N
    Proofread, save and close gedit.

    Please use thread tools to mark Solved.
    Quote Originally Posted by praseodym View Post
    Now you can make it permanent:
    Code:
    echo "options iwlwifi 11n_disable=1 bt_coex_active=N" | sudo tee /etc/modprobe.d/iwlwifi.conf
    Edit: Seconds too slow
    Thank you guys, i really apreciate your help.
    Solved!

  5. #15
    Join Date
    Feb 2013
    Beans
    5

    Re: Cant connect wifi (Centrino Wireless-1000)

    Quote Originally Posted by Us3r Unfriendly View Post
    You have 2 drivers running at the same time...might be conflicting with eachother possibly. Looks like you need the "iwlwifi" module. Have you tried removing the other?

    sudo modprobe -r rt2800usb

    Then removing the other and inserting it back in?

    sudo modprobe -r iwlwifi

    sudo modprobe iwlwifi

    then try again to connect using network manager
    Thank you very much, this fixed my Toshiba P855 I just purchased, had to adapt which driver I removed but worked. THANKS

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •