Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: "Prefix not set"-error when a disk has GPT

  1. #1
    Join Date
    Jun 2012
    Location
    Sweden
    Beans
    324
    Distro
    Ubuntu 12.04 Precise Pangolin

    "Prefix not set"-error when a disk has GPT

    Hi!
    A friend of me wanted to try Linux, and I recommended him to try Ubuntu. I gave him my CD of Ubuntu 12.04 (x64). Yesterday, he said that Ubuntu didn't work at all, so went to his house to see with my own eyes what was wrong.

    When he booted his computer from the CD a message "error: prefix not set" flashed by, followed by a GRUB menu. The options "Try Ubuntu", "Install Ubuntu" and "Check the disk for errors" was there, but if you tried to choose one of the options, the messages " error: couldn't load file" and "error: need to load kernel first" showed up. I went home and checked the disc. No problem at all. I also, re-downloaded the .iso and reburned it, but without success. So we tried the classic method, disconnect the hardware, part by part. We found out that his HDD was the problem (he has one SSD and two HDDs). It has a 4 TB partition and as GPT-table instead of MBR. Without the HDD, GRUB successfully booted Ubuntu from the live-CD.
    So, why doesn't GRUB like GPT? Is the GPT-table the problem, or it is the huge partition that is the problem? Any idea how to solve it?
    Last edited by Bufeu; January 7th, 2013 at 06:01 PM.

  2. #2
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: "Prefix not set"-error when a disk has GPT

    Gpt is not the issue. I have been using gpt since 10.04 but on smaller drives. I have it on my 160GB drive, my SSD & my flash drive I use for installs using grub to directly boot isos. And I have two other drives with MBR.

    And we have seen users with very large RAID configurations which of course had to be gpt.

    First is BIOS/UEFI set for AHCI? That should be set for SSD anyway. Not sure if any other BIOS settings may make a difference.

    These are all BIOS issues that users have reported, of course most will not apply.

    Some issues on booting install:
    fixed the problem by adding rootdelay to grub.cfg this allows time for the usb drive to load.
    Though my drive was appearing in the bios and working for install it was actually "disabled"!
    BIOS settings need USB mouse & keyboard
    BIOS in not updated to latest revision
    BIOS not set to boot CD or USB first
    BIOS shows floppy or firewire and you do not have those
    changing newer BIOS SATA 6 Gbit/s from 6 Gbs to a SATA II - 3Gbs
    BIOS & disable "Boot Sector Virus Protection"
    Other BIOS settings - Security or locked down Boot sector, Bitlocker
    Old BIOS, new drive 137GB max boot size or very large / partition over 100GB
    https://help.ubuntu.com/community/BootPartition
    https://help.ubuntu.com/community/Cr...onAfterInstall
    NTFS partition needs chkdsk, gparted will not see drive if chkdsk flag set, flag is set on resize
    Raid meta data on drive - even if one drive (Vendor happend to set it on)
    Old gpt data on drive that is now MBR
    Disable Quickboot in BIOS
    turning off UDMA in the BIOS my problem has gone away.(old system & may make system slower)
    BIOS setting, Keyboard response in grub really slow
    Fast Boot setting prevents keyboard from working & other issues
    Bios not loading no key works - disconnected power for about 10-15 minutes and the bios reset itself.
    After update, It had reset to the BIOS defaults, setting the video to ONBOARD and switching off the dynamic video memory allocation (manually allocating 32Mb instead of leaving it as AUTO).
    The mode for the disc was set to AUTO. Changed it to LBA. Then it worked.
    Sometimes specific issues by motherboard like this:
    [Natty] Marvell 88SE9120 IDE-Part not working
    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/777325
    External drive needed separate power supply
    Asus m4a87td core unlocker feature on usb3 was causing the problem
    Asus - Security> I / O interface Security> "New interface card" or so. SET IT TO LOCKED!!!
    In the Asus BIOS I selected Advanced Mode>Advanced>SATA Configuration.
    Changed IDE Mode to AHCI Mode
    Then,when the SATA3G_1 selection appears in the drive list below,select the Enabled option.
    set pci=nomsi or other boot paramter
    So to people with an Asrock Z77 Extreme4 motherboard: if you install Ubuntu, make sure the drives you are installing from and to are not connected to the Asmedia SATA ports!
    lib64 folder missing??
    http://ubuntuforums.org/showthread.php?t=2069764
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.




  3. #3
    Join Date
    Jun 2012
    Location
    Sweden
    Beans
    324
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: "Prefix not set"-error when a disk has GPT

    Quote Originally Posted by oldfred View Post
    Gpt is not the issue. I have been using gpt since 10.04 but on smaller drives. I have it on my 160GB drive, my SSD & my flash drive I use for installs using grub to directly boot isos. And I have two other drives with MBR.

    And we have seen users with very large RAID configurations which of course had to be gpt.

    First is BIOS/UEFI set for AHCI? That should be set for SSD anyway. Not sure if any other BIOS settings may make a difference.

    These are all BIOS issues that users have reported, of course most will not apply.

    Some issues on booting install:
    fixed the problem by adding rootdelay to grub.cfg this allows time for the usb drive to load.
    Though my drive was appearing in the bios and working for install it was actually "disabled"!
    BIOS settings need USB mouse & keyboard
    BIOS in not updated to latest revision
    BIOS not set to boot CD or USB first
    BIOS shows floppy or firewire and you do not have those
    changing newer BIOS SATA 6 Gbit/s from 6 Gbs to a SATA II - 3Gbs
    BIOS & disable "Boot Sector Virus Protection"
    Other BIOS settings - Security or locked down Boot sector, Bitlocker
    Old BIOS, new drive 137GB max boot size or very large / partition over 100GB
    https://help.ubuntu.com/community/BootPartition
    https://help.ubuntu.com/community/Cr...onAfterInstall
    NTFS partition needs chkdsk, gparted will not see drive if chkdsk flag set, flag is set on resize
    Raid meta data on drive - even if one drive (Vendor happend to set it on)
    Old gpt data on drive that is now MBR
    Disable Quickboot in BIOS
    turning off UDMA in the BIOS my problem has gone away.(old system & may make system slower)
    BIOS setting, Keyboard response in grub really slow
    Fast Boot setting prevents keyboard from working & other issues
    Bios not loading no key works - disconnected power for about 10-15 minutes and the bios reset itself.
    After update, It had reset to the BIOS defaults, setting the video to ONBOARD and switching off the dynamic video memory allocation (manually allocating 32Mb instead of leaving it as AUTO).
    The mode for the disc was set to AUTO. Changed it to LBA. Then it worked.
    Sometimes specific issues by motherboard like this:
    [Natty] Marvell 88SE9120 IDE-Part not working
    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/777325
    External drive needed separate power supply
    Asus m4a87td core unlocker feature on usb3 was causing the problem
    Asus - Security> I / O interface Security> "New interface card" or so. SET IT TO LOCKED!!!
    In the Asus BIOS I selected Advanced Mode>Advanced>SATA Configuration.
    Changed IDE Mode to AHCI Mode
    Then,when the SATA3G_1 selection appears in the drive list below,select the Enabled option.
    set pci=nomsi or other boot paramter
    So to people with an Asrock Z77 Extreme4 motherboard: if you install Ubuntu, make sure the drives you are installing from and to are not connected to the Asmedia SATA ports!
    lib64 folder missing??
    http://ubuntuforums.org/showthread.php?t=2069764
    Hmm..? But you never had a partition bigger than 2 TiB (the limit for MBR)?

    His configuration (to make it more clear):
    Drive 1 (SSD):
    120 GB NTFS-partition with MBR

    Drive 2 (HDD):
    1 TB NTFS-partition with MBR

    Drive 3 (HDD):
    4000 GB NTFS-parttion with GPT

    EDIT: Yes, AHCI is set in the BIOS. My friend just checked.
    Last edited by Bufeu; January 7th, 2013 at 06:41 PM.

  4. #4
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,660
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: "Prefix not set"-error when a disk has GPT

    Quote Originally Posted by Bufeu View Post
    Hmm..? But you never had a partition bigger than 2 TiB (the limit for MBR)?

    His configuration (to make it more clear):
    Drive 1 (SSD):
    120 GB NTFS-partition with MBR

    Drive 2 (HDD):
    1 TB NTFS-partition with MBR

    Drive 3 (HDD):
    4000 GB NTFS-parttion with GPT
    I wouldn't say the issue is the size of the gpt partition. Whether it's bigger or not than the msdos (mbr) limit is not important, that's why you use gpt because it's above the mbr limit. I can't see how the mbr limit would interfere on gpt disk.

    I don't have 4TB disk to test, but I do have two new 2 x 2TB disks in my home server with gpt tables, one small root partition and the rest one huge partition, which means almost 2TB minus 10-15GB for root (don't remember exactly right now).
    This is my home server so it has the server OS but it works excellently.
    And I booted it with the live cd when installing because I wanted to manually prepare the partitions first, and then I started the server cd install.
    So, the live cd had no problems booting the machine and preparing 2 x 2TB disks with gpt table and big 2TB partitions.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  5. #5
    Join Date
    Jun 2012
    Location
    Sweden
    Beans
    324
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: "Prefix not set"-error when a disk has GPT

    Quote Originally Posted by darkod View Post
    I wouldn't say the issue is the size of the gpt partition. Whether it's bigger or not than the msdos (mbr) limit is not important, that's why you use gpt because it's above the mbr limit. I can't see how the mbr limit would interfere on gpt disk.

    I don't have 4TB disk to test, but I do have two new 2 x 2TB disks in my home server with gpt tables, one small root partition and the rest one huge partition, which means almost 2TB minus 10-15GB for root (don't remember exactly right now).
    This is my home server so it has the server OS but it works excellently.
    And I booted it with the live cd when installing because I wanted to manually prepare the partitions first, and then I started the server cd install.
    So, the live cd had no problems booting the machine and preparing 2 x 2TB disks with gpt table and big 2TB partitions.
    So, what else would be the problem? It works fine without the 4 TB-drive.

    EDIT: Your partition wasn't bigger than 2 TiB, right?

  6. #6
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,660
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: "Prefix not set"-error when a disk has GPT

    Quote Originally Posted by Bufeu View Post
    So, what else would be the problem? It works fine without the 4 TB-drive.

    EDIT: Your partition wasn't bigger than 2 TiB, right?
    Right. The whole disk is 2TB which is less than 2TiB and that makes it impossible for any partition to be larger than 2TiB.

    Have tried changing places of the disks on the motherboard? Even better, can you try with only the 4TB disk connected? Regardless where you want to install, having only the 4TB disk can show if it maybe boots with it into live mode from the cd or not. Test it in various sata ports.

    I have no idea, honestly. But it would be very weird the GPT to be issue since that's what GPT started to get used for, large partitions.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  7. #7
    Join Date
    Jun 2012
    Location
    Sweden
    Beans
    324
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: "Prefix not set"-error when a disk has GPT

    Quote Originally Posted by darkod View Post
    Right. The whole disk is 2TB which is less than 2TiB and that makes it impossible for any partition to be larger than 2TiB.

    Have tried changing places of the disks on the motherboard? Even better, can you try with only the 4TB disk connected? Regardless where you want to install, having only the 4TB disk can show if it maybe boots with it into live mode from the cd or not. Test it in various sata ports.

    I have no idea, honestly. But it would be very weird the GPT to be issue since that's what GPT started to get used for, large partitions.
    Good ideas. I'll try that as fast as I can, maybe tomorrow. It's a very strange problem, though.

  8. #8
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: "Prefix not set"-error when a disk has GPT

    I have had gparted not show my XP drive even though XP booted. I then ran chkdsk on the XP partition and the drive then showed in gparted & XP booted a bit faster. But running chkdsk on a 4TB drive may take a long time.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.




  9. #9
    Join Date
    Jun 2012
    Location
    Sweden
    Beans
    324
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: "Prefix not set"-error when a disk has GPT

    Quote Originally Posted by darkod View Post
    Right. The whole disk is 2TB which is less than 2TiB and that makes it impossible for any partition to be larger than 2TiB.

    Have tried changing places of the disks on the motherboard? Even better, can you try with only the 4TB disk connected? Regardless where you want to install, having only the 4TB disk can show if it maybe boots with it into live mode from the cd or not. Test it in various sata ports.

    I have no idea, honestly. But it would be very weird the GPT to be issue since that's what GPT started to get used for, large partitions.
    Tried, but with the 4TB disk connected (only), Ubuntu (from live-CD) didn't boot either...
    If any of the other disks is connected, Ububtu boots. Therefore, my conclusion is that it has spmething with GRUB and the big partition to do. Any ideas?

  10. #10
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: "Prefix not set"-error when a disk has GPT

    Back with 10.04 I did have issues booting from gpt and trying to use MBR in XP. I had to explicitly add commands to tell it I was changing from gpt to MBR. Now partitions are labeled with hd0, gpt1 or hd1, msdos2.

    Grub used to have a drivelist file, but they did away with it and I think they just scan attached drives or look at BIOS list of drives. But if scanning and not able to read gpt perhaps that is an issue. I do not know if you can add both an insmod part_gpt and insmod part_msdos in the same boot stanza? With my mixed MBR & gpt system I only have one or the other depending on where I am booting from.

    Are you perhaps booting from gpt drive but install is in MBR drive?
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.




Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •