Results 1 to 9 of 9

Thread: Ubuntu 12.10 Boot problems(Boot Repair log)

  1. #1
    Join Date
    Jan 2013
    Beans
    6

    Ubuntu 12.10 Boot problems(Boot Repair log)

    Hi, first post, very new to Ubuntu(Linux as a whole really) But I have had Ubuntu 12.10(64bit) installed for a little over a week now and am experiencing problems on boot up. When my computer is started up, I am greeted with the grub 2 screen, with the following options: Ubuntu,advanced options for Ubuntu, and the 2 different memory test. I beleave all my problems started with the installation of acidrip, and devede(both from the repository). I have since removed both of them(again via the repository). Everything seemed to uninstall fine so I did not note what the terminal kicked out. I can usually get into Ubuntu after selecting "Ubuntu" from that grub2 screen a couple of times after restarting.

    I ran boot-repair per this https://help.ubuntu.com/community/Boot-Repair and ended with the following URl http://paste.ubuntu.com/1503119/.

    Im hoping this isn't hardware related but just in case

    Intel core 2 extreme cpu
    EVGA 790i ftw motherboard
    4gb mushkin ram
    EVGA GTX 260 grapthics card (not showing under All Settings then Details)
    Intel 120gb SSD

    (I may have missed something or other, will add if I remember)

  2. #2
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu 12.10 Boot problems(Boot Repair log)

    If you are consistently getting to grub menu, I do not think Boot-Repair will help. That is more for fixing grub issues. I might add a boot parameter if needed, but you did not need those before?

    I would look in the logs to see if it is reporting anything. I look at dmesg and look for long times between entries, out right errors, or a drive trying to load multiple times & then maybe failing or working. Use Log File View or look in /var/log/dmesg


    Did you enable trim on SSD? And AHCI in BIOS?
    Oldfred on vacation. Back Sept 9. Will not have much if any Internet access.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  3. #3
    Join Date
    Jan 2013
    Beans
    6

    Re: Ubuntu 12.10 Boot problems(Boot Repair log)

    No I did not enable trim on my ssd, or AHCI in my bios... Should I? I'm not quite sure what either of those are, but I will go and google them.

    *Update* I did some reading and enabled trim. This made the Ubuntu load smoother after I select Ubuntu from the GRUB screen. Unfortunately my motherboard only supports AHCI if I open the case and switch from NVIDIA on board controller to a Jmicron controller, and I've read that will slow my system down. I'll do it is thought to correct this issue, but I would rather not.
    Last edited by cognition88; January 6th, 2013 at 10:28 PM. Reason: Did some research

  4. #4
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu 12.10 Boot problems(Boot Repair log)

    Trim does not work without AHCI.

    I have used this command and I think this poster believes it is a better way than trim. I ran this command as I had not enable trim initially and got these results.
    fred@fred-Precise:~$ sudo fstrim -v /
    /: 23267893248 bytes were trimmed
    https://wiki.archlinux.org/index.php..._Cell_Clearing
    sudo hdparm -I /dev/sdX
    Alternate to discard, call fstrim via cron
    http://opensuse.14.n6.nabble.com/SSD...td3313048.html
    test if trim working using hdparm
    http://techgage.com/article/enabling..._under_linux/2


    https://wiki.archlinux.org/index.php/Solid_State_Drives

    With SSD or Flash drives, Use ext4 without journal:
    sudo tune2fs -O ^has_journal /dev/sda1
    sudo tune2fs -o discard /dev/sda1
    No swap or set swapiness or install 'Dynamic Swap Space Manager' from the Ubuntu Software Center
    After installing, change the fstab so that everything gets mounted with noatime.
    Make sure BIOS is in AHCI mode for trim to work.
    change to noop i/o scheduler
    Oldfred on vacation. Back Sept 9. Will not have much if any Internet access.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  5. #5
    Join Date
    Jan 2013
    Beans
    6

    Re: Ubuntu 12.10 Boot problems(Boot Repair log)

    Ok, thanks I'll try that when I get home(night shift)

    On a side note, would you call this a sloppy install? since this is only a week and some days old and I really don't have much on this system, could it be easier just to start over brand new and fresh?
    Last edited by cognition88; January 7th, 2013 at 10:13 PM. Reason: Changed mind?

  6. #6
    Join Date
    Jan 2013
    Beans
    6

    Re: Ubuntu 12.10 Boot problems(Boot Repair log)

    Ok I have done everything from your last post and still get the "gnu grub 2.00" screen on boot up

  7. #7
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu 12.10 Boot problems(Boot Repair log)

    With only one system, you normally should not be getting the grub menu. That then is saying something is wrong.

    Did you install the nVidia proprietary drivers from Ubuntu?

    If you have not made a lot of changes, reinstall is an option. Either backup or if nothing to save just reinstall.
    Oldfred on vacation. Back Sept 9. Will not have much if any Internet access.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  8. #8
    Join Date
    Jan 2013
    Beans
    6

    Re: Ubuntu 12.10 Boot problems(Boot Repair log)

    I haven't installed the nVidia drivers. But I think I'm just going to go with a fresh install and use the link you gave me to completely wipe my SSD. I had windows 7 prior to this but was having a lot of trouble with the activation key(returned for a refund). After that I'm not confident I did a proper wipe after reading the link from one of your post. So I'll try that, I greatly appreciate all the help you have provided. This is my first experience with Linux(unless you count Android) so I kind of expected a learning curve.

  9. #9
    Join Date
    Jan 2013
    Beans
    6

    Re: Ubuntu 12.10 Boot problems(Boot Repair log)

    So I did a clean wipe(https://wiki.archlinux.org/index.php..._Cell_Clearing) and install and everything seems to be running great, no grub menu and all. I suppose the problem was when I didn't properly wipe my SSD after removing windows and installing Ubuntu. I also opened my case and changed my SSD's connection to the correct SATA port to enable AHCI and thus trim. Thanks again for the help, I'll go ahead and call this solved
    Last edited by cognition88; January 9th, 2013 at 12:26 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •