Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: WiFi works only temporarily on Asus EEE

  1. #11
    Join Date
    May 2011
    Beans
    18

    Re: WiFi works only temporarily on Asus EEE

    Dear Cilli,

    thanks for your help so far. Just before I hit submit reply, I thought we finally have some progress. But now I am editing the post, as unfortunately wifi stopped working again.
    Here is what I have written before and I will add a small update at the end:

    I did remove the rt2860sta module as you have suggested. I did couple of reboots and removed any reference to rt28060sta I could find (via locate).

    WiFi still did not work, although connected.

    So I went inside my router and disabled wifi security - voila, wifi has been running now for about 20 minutes.

    Here's an output of iwconfig now (Invalid misc is now down to 3, whatever it is )
    Code:
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11bgn  ESSID:"MI6"  
              Mode:Managed  Frequency:2.412 GHz  Access Point: CC:5D:4E:B4:05:C8   
              Bit Rate=135 Mb/s   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=58/70  Signal level=-52 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:3   Missed beacon:0
    
    eth0      no wireless extensions.
    and here is output of sudo modinfo rt2800pci
    Code:
    filename:       /lib/modules/3.2.0-35-generic/kernel/drivers/net/wireless/rt2x00/rt2800pci.ko
    license:        GPL
    firmware:       rt2860.bin
    description:    Ralink RT2800 PCI & PCMCIA Wireless LAN driver.
    version:        2.3.0
    author:         http://rt2x00.serialmonkey.com
    srcversion:     B814F1B7538F8B99ECC7D4E
    alias:          pci:v00001814d0000539Fsv*sd*bc*sc*i*
    alias:          pci:v00001814d0000539Asv*sd*bc*sc*i*
    alias:          pci:v00001814d00005390sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003593sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003592sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003562sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003062sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003060sv*sd*bc*sc*i*
    alias:          pci:v00001432d00007722sv*sd*bc*sc*i*
    alias:          pci:v00001432d00007711sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003390sv*sd*bc*sc*i*
    alias:          pci:v00001A3Bd00001059sv*sd*bc*sc*i*
    alias:          pci:v00001462d0000891Asv*sd*bc*sc*i*
    alias:          pci:v00001432d00007768sv*sd*bc*sc*i*
    alias:          pci:v00001432d00007758sv*sd*bc*sc*i*
    alias:          pci:v00001432d00007748sv*sd*bc*sc*i*
    alias:          pci:v00001432d00007738sv*sd*bc*sc*i*
    alias:          pci:v00001432d00007728sv*sd*bc*sc*i*
    alias:          pci:v00001432d00007727sv*sd*bc*sc*i*
    alias:          pci:v00001432d00007708sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003092sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003091sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003090sv*sd*bc*sc*i*
    alias:          pci:v00001814d00000781sv*sd*bc*sc*i*
    alias:          pci:v00001814d00000701sv*sd*bc*sc*i*
    alias:          pci:v00001814d00000681sv*sd*bc*sc*i*
    alias:          pci:v00001814d00000601sv*sd*bc*sc*i*
    depends:        rt2x00lib,rt2800lib,rt2x00pci,eeprom_93cx6
    intree:         Y
    vermagic:       3.2.0-35-generic SMP mod_unload modversions 686 
    parm:           nohwcrypt:Disable hardware encryption. (bool)
    I would like to use WPA2/AES. Before I do any changes, I will wait for any suggestions you may have.

    After wifi stopped working:
    While I was writing the post, I noticed that I have ping running in the terminal, constantly pinging the gateway. I stopped it to get output of the commands above. By the time I finished the post, the problem reappeared (retrying ping did not help, as I cannot ping gateway anymore).
    Just for your info, on the same laptop I can boot also into Win XP. There, I have no problem with the wifi - this is just to rule out the hw or router problem.

    Thanks again.
    Cheers,
    B.

  2. #12
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,875
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: WiFi works only temporarily on Asus EEE

    My suggestion is at post #3.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #13
    Join Date
    May 2011
    Beans
    18

    Re: WiFi works only temporarily on Asus EEE

    Quote Originally Posted by chili555 View Post
    My suggestion is at post #3.
    I tried that again but it did not help.
    At that moment I thought that it just may be easier to save us some time trying to troubleshoot this, so I went ahead and made a fresh install of xubuntu (including formating the partition where system resides - so no upgrade or anything like that).

    But to my great disappointment, that did not resolve the problem! So now I am pulling my hair out. I did try again the suggested two commands from post #3 - no change.

    Well, I just may go and get a good sleep on this first, as it is close to 1:30 am here. If you come up with any idea of what I could try next, I will be grateful. Tomorrow I will post the output of the commands as I did before, so that you can see what has changed (if anything) after the clean set-up.

    Thanks for the help so far.
    Good night
    B.

  4. #14
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,875
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: WiFi works only temporarily on Asus EEE

    Good evening. We'll attack it again after a nights rest.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #15
    Join Date
    May 2011
    Beans
    18

    Re: WiFi works only temporarily on Asus EEE

    Hello,

    show must go on and so does the puzzlement...
    Believe it or not, I have been enjoying wifi connection now for about 3 hours without any problem. But I am at work now... when I tried back home in the morning, the wifi still would not communicate.

    So next I checked the encryption settings we are running here at work. There is WPA2/WPA with TKIP. Back home I have pure WPA2 with AES. This could be an indication, but how come it did not work with wireless security set to none?!
    Why also enabling the nohwcrypt for the module did not help? It must be some strange combination of this eee, my router, setup, and everything together.

    So to sumarize:
    My home wifi setup (WPA2+AES) + this Asus EEE (it's 1000H model) + WinXP = no problem
    My home wifi setup (WPA2+AES) + this Asus EEE + Xubuntu 12.04 = not working
    My home wifi setup (no security) + this Asus EEE + Xubuntu 12.04 = not working
    Work wifi setup (WPA/WPA2+TKIP) + this Asus EEE + Xubuntu 12.04 = no problem

    Below is the output of selected commands (wifi is working at the moment, as I am connected to work wifi):
    Code:
    dmesg | grep -e ra0 -e rt2
    [   13.683709] rt2800pci 0000:01:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
    [   13.683734] rt2800pci 0000:01:00.0: setting latency timer to 64
    [   13.902727] Registered led device: rt2800pci-phy0::radio
    [   13.905595] Registered led device: rt2800pci-phy0::assoc
    [   13.905727] Registered led device: rt2800pci-phy0::quality
    [  895.478218] rt2800pci 0000:01:00.0: PCI INT A disabled
    [  896.377655] rt2800pci 0000:01:00.0: restoring config space at offset 0xf (was 0x1ff, writing 0x10b)
    [  896.377687] rt2800pci 0000:01:00.0: restoring config space at offset 0x4 (was 0x0, writing 0xfbef0000)
    [  896.377699] rt2800pci 0000:01:00.0: restoring config space at offset 0x3 (was 0x0, writing 0x8)
    [  896.377712] rt2800pci 0000:01:00.0: restoring config space at offset 0x1 (was 0x100000, writing 0x100007)
    [  896.379348] rt2800pci 0000:01:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
    [  900.244870] phy0 -> rt2800pci_mcu_status: Error - MCU request failed, no response from hardware
    Code:
    lsmod | grep rt2
    rt2800pci              18340  0 
    rt2800lib              53264  1 rt2800pci
    crc_ccitt              12595  1 rt2800lib
    rt2x00pci              14202  1 rt2800pci
    rt2x00lib              48805  3 rt2800pci,rt2800lib,rt2x00pci
    mac80211              436455  3 rt2800lib,rt2x00pci,rt2x00lib
    cfg80211              178679  2 rt2x00lib,mac80211
    eeprom_93cx6           12653  1 rt2800pci
    Code:
    modinfo rt2800pci
    filename:       /lib/modules/3.2.0-29-generic/kernel/drivers/net/wireless/rt2x00/rt2800pci.ko
    license:        GPL
    firmware:       rt2860.bin
    description:    Ralink RT2800 PCI & PCMCIA Wireless LAN driver.
    version:        2.3.0
    author:         http://rt2x00.serialmonkey.com
    srcversion:     819E0C83946C477B1C23972
    alias:          pci:v00001814d0000539Fsv*sd*bc*sc*i*
    alias:          pci:v00001814d0000539Asv*sd*bc*sc*i*
    alias:          pci:v00001814d00005390sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003593sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003592sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003562sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003062sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003060sv*sd*bc*sc*i*
    alias:          pci:v00001432d00007722sv*sd*bc*sc*i*
    alias:          pci:v00001432d00007711sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003390sv*sd*bc*sc*i*
    alias:          pci:v00001A3Bd00001059sv*sd*bc*sc*i*
    alias:          pci:v00001462d0000891Asv*sd*bc*sc*i*
    alias:          pci:v00001432d00007768sv*sd*bc*sc*i*
    alias:          pci:v00001432d00007758sv*sd*bc*sc*i*
    alias:          pci:v00001432d00007748sv*sd*bc*sc*i*
    alias:          pci:v00001432d00007738sv*sd*bc*sc*i*
    alias:          pci:v00001432d00007728sv*sd*bc*sc*i*
    alias:          pci:v00001432d00007727sv*sd*bc*sc*i*
    alias:          pci:v00001432d00007708sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003092sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003091sv*sd*bc*sc*i*
    alias:          pci:v00001814d00003090sv*sd*bc*sc*i*
    alias:          pci:v00001814d00000781sv*sd*bc*sc*i*
    alias:          pci:v00001814d00000701sv*sd*bc*sc*i*
    alias:          pci:v00001814d00000681sv*sd*bc*sc*i*
    alias:          pci:v00001814d00000601sv*sd*bc*sc*i*
    depends:        rt2x00lib,rt2800lib,rt2x00pci,eeprom_93cx6
    intree:         Y
    vermagic:       3.2.0-29-generic SMP mod_unload modversions 686 
    parm:           nohwcrypt:Disable hardware encryption. (bool)
    Code:
    iwconfig
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11bgn  ESSID:"zasadacka"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: 00:3A:99:AB:9C:61   
              Bit Rate=48 Mb/s   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:on
              Link Quality=40/70  Signal level=-70 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:6  Invalid misc:59   Missed beacon:0
    
    eth0      no wireless extensions.
    I will try later tonight to change settings at home to those here at work. Although I would not be entirely happy, it could solve the situation. But I am also up for the challenge for getting it to work no matter what the security set-up is.

    Cheers,
    B.

  6. #16
    Join Date
    Jul 2006
    Location
    Castrum, Germania Secunda
    Beans
    1,071

    Re: WiFi works only temporarily on Asus EEE

    I see in the iwconfig output that power management is still on for wlan0. Have you tried whether disabling power management for your wireless chipset helps, like I suggested previously?

    That particular tweak often solves problems like these, in my experience.
    Last edited by Pjotr123; January 7th, 2013 at 12:39 PM.
    Tips, tweaks and how-to's for Ubuntu and Mint:
    http://sites.google.com/site/easylinuxtipsproject
    In for a pleasant surprise? Give Xubuntu a try:
    http://sites.google.com/site/easylin...roject/xubuntu

  7. #17
    Join Date
    May 2011
    Beans
    18

    Re: WiFi works only temporarily on Asus EEE

    Quote Originally Posted by Pjotr123 View Post
    I see in the iwconfig output that power management is still on for wlan0. Have you tried whether disabling power management for your wireless chipset helps, like I suggested previously?

    That particular tweak often solves problems like these, in my experience.
    True. Thanks. That is because I did a fresh install of the system. So before it was disabled and now I have not changed it yet. I will try your solution and post results later on (despite that the wifi works with Power management on at work).

    Thanks again.
    Cheers,
    B.

  8. #18
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,875
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: WiFi works only temporarily on Asus EEE

    [ 900.244870] phy0 -> rt2800pci_mcu_status: Error - MCU request failed, no response from hardware
    Old Chili doesn't like this one bit. I have no clue how to fix it and I've seen it for years. Arrggh!

    There is an updated rt2800pci available.
    Code:
    sudo apt-get install linux-backports-modules-cw-3.4-precise-generic
    Reboot and let us have your report.

    Changing your home network to TKIP is certainly a valid experiment.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  9. #19
    Join Date
    May 2011
    Beans
    18

    Talking Re: WiFi works only temporarily on Asus EEE

    Quote Originally Posted by chili555 View Post
    There is an updated rt2800pci available.
    Code:
    sudo apt-get install linux-backports-modules-cw-3.4-precise-generic
    Reboot and let us have your report.
    YOU ARE A KING!
    Well, first things first...

    After I got home, I tried:
    1) Disabling power management -> reboot -> no joy
    2) Losen security on wifi to resemble the one at work -> no joy
    3) Disable firewall (just in case) -> no joy

    4) Updated rt2800pci driver as in quote above -> joy joy joy

    5) Returned to WPA2-PSK + AES setting on wifi -> joy continues

    It's been running like this for past half hour, so still a bit of caution. But based on previous experience I am certain this is solved. You can even see much quicker responses of wifi connecting or pages being loaded. So there was definitely something wrong with old driver.

    Chili, I know you've been told many times, but you are a true hero and expert. I was already feeling bad about wasting your time so much and wanted to give-in, but the enthusiasm and determination I could feel through the screen from you kept me going too!
    But I also want to thank Pjotr123 and Coldraven for their suggestions, which hopefully will help some other people too.

    I am marking this solved and hopefully will not need to return here (unless the 204 updates that are pending now will ruin something again ).

    Once again, thanks to all of you and +1 happy ubuntu user!
    Great community.

    Cheers,
    Brandon.

    PS: Where do I mark this solved? -> Got it.
    Last edited by BrandonSk; January 7th, 2013 at 08:53 PM.

  10. #20
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,875
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: WiFi works only temporarily on Asus EEE

    Awesome! Your experience will hep others that are troubled by rt2800pci. Thank you for your perseverance. I greatly enjoy what I do and I don't consider it a waste at all. Thanks for your kind comments.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •