Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: WiFi works only temporarily on Asus EEE

  1. #1
    Join Date
    May 2011
    Beans
    18

    WiFi works only temporarily on Asus EEE

    Dear all / Chili,

    I went through the procedure as described in this thread:
    http://ubuntuforums.org/showthread.php?p=12440411

    As Chili suggested, I am starting a new thread so that may hopefully be useful for other people as well.

    Here is of lspci -nn | grep 0280 :
    Code:
    lspci -nn | grep 0280
    01:00.0 Network controller [0280]: Ralink corp. RT2790 Wireless 802.11n 1T/2R PCIe [1814:0781]
    Thanks for help.
    Brandon.

  2. #2
    Join Date
    Jul 2006
    Location
    Castrum, Germania Secunda
    Beans
    1,071

    Re: WiFi works only temporarily on Asus EEE

    Try disabling power management for your wireless card:
    https://sites.google.com/site/easyli...-wireless-card
    (item 2.1, right column)

  3. #3
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,343
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: WiFi works only temporarily on Asus EEE

    Ralink corp. RT2790 Wireless 802.11n 1T/2R PCIe [1814:0781]
    I assume you are using the driver rt2800pci and haven't compiled or otherwise installed anything different; confirm:
    Code:
    lsmod | grep rt2
    If so, please try:
    Code:
    sudo modprobe -r rt2800pci
    sudo modprobe rt2800pci nohwcrypt=Y
    If it helps, we can make it persistent.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  4. #4
    Join Date
    Jan 2010
    Location
    Hyperborea
    Beans
    1,954
    Distro
    Ubuntu 15.10 Wily Werewolf

    Re: WiFi works only temporarily on Asus EEE

    I'm running Xubuntu 12.10 on my eee pc 900 with no problems, the wifi seems to work perfectly.
    I did update the BIOS which improved the battery life, the fan is running a lot less.
    I posted how to here:
    http://ubuntuforums.org/showpost.php...15&postcount=8

  5. #5
    Join Date
    May 2011
    Beans
    18

    Re: WiFi works only temporarily on Asus EEE

    @Chili
    I am using the driver you suggested. In fact, as mentioned before, I have followed the previous guide, so I have downloaded the same stuff. The version of the driver is 2.4.0 I believe.

    Code:
    lsmod | grep rt2
    rt2860sta             769209  0 
    rt2800pci              18340  0 
    rt2800lib              53298  1 rt2800pci
    crc_ccitt              12627  1 rt2800lib
    rt2x00pci              14202  1 rt2800pci
    rt2x00lib              48875  3 rt2800pci,rt2800lib,rt2x00pci
    mac80211              436493  3 rt2800lib,rt2x00pci,rt2x00lib
    cfg80211              178877  2 rt2x00lib,mac80211
    eeprom_93cx6           12687  1 rt2800pci
    sudo modprobe -r rt2800pci
    sudo modprobe rt2800pci nohwcrypt=Y
    The above returns nothing.
    Oh... I see, it first disconnected me and now has reconnected. I will unplug the cable and get back to you within few minutes. It does "go off" within 30 minutes.

    @Coldraven
    Thanks for the link. I will check that tutorial. If nothing else, battery life and fan sounds promising too.

    @Pjotr123
    Thank you for the suggestion. I think my powermanagement for wifi card is off. At least I remember seing it as output of one of the commands before (I mean the previous thread that I have followed).

    Thanks again to all.
    Cheers,
    Brandon.

    PS: Unplugging cable now. Fingers crossed.

  6. #6
    Join Date
    May 2011
    Beans
    18

    Re: WiFi works only temporarily on Asus EEE

    Well,

    I am sorry to disappoint, but this time it worked only for a minute or so. When I removed and reinserted the module with those two commands above, it again started working but again only for a very short time.
    On the third attempt it was not working immediately after the 2 commands were executed.


    B.

  7. #7
    Join Date
    May 2011
    Beans
    18

    Re: WiFi works only temporarily on Asus EEE

    So I did try the procedure from scratch.

    This time not just copy/paste but also looking at the steps and thinking, what is the aim and thus adjusting few commands. Particularly I was messing with the step #6 - the "mv" and revised "cp" commands.
    With the mv I have renamed the rt2860sta.ko into rt2860sta.ko.dist which resided in my .../net/wireless
    Looking at the revised cp and my directory structure, I first created a directory called "rt2860" in my .../staging/ and then copied the rt2860sta.ko into that newly created directory.

    The "..." is /lib/modules/3.2.0-35-generic/kernel/drivers/ and yes, the 3.2.0-35-generic is what uname -r returns.

    Result: still the same situation - wifi not working, although connected.

    For better orientation, I will now post output of several commands, maybe you can spot something.

    Code:
    dmesg | grep -e -ra0 -e rt2
    [   20.714703] rt2800pci 0000:01:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
    [   20.714730] rt2800pci 0000:01:00.0: setting latency timer to 64
    [   20.789605] Registered led device: rt2800pci-phy0::radio
    [   20.789963] Registered led device: rt2800pci-phy0::assoc
    [   20.790187] Registered led device: rt2800pci-phy0::quality
    Code:
    lsmod | grep rt2
    rt2800pci              18340  0 
    rt2800lib              53298  1 rt2800pci
    crc_ccitt              12627  1 rt2800lib
    rt2x00pci              14202  1 rt2800pci
    rt2x00lib              48875  3 rt2800pci,rt2800lib,rt2x00pci
    mac80211              436493  3 rt2800lib,rt2x00pci,rt2x00lib
    cfg80211              178877  2 rt2x00lib,mac80211
    eeprom_93cx6           12687  1 rt2800pci
    Code:
    iwconfig
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11bgn  ESSID:"MI6_guest"  
              Mode:Managed  Frequency:2.412 GHz  Access Point: CC:5D:4E:B4:05:C9   
              Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=54/70  Signal level=-56 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:10   Missed beacon:0
    
    eth0      no wireless extensions.
    What is this Invalid misc:10 ? Does it lead to anything?

    Code:
    locate rt2860sta
    /home/brano/2010_07_16_RT2860_Linux_STA_v2.4.0.0/rt2860sta.ko.dist
    /home/brano/2010_07_16_RT2860_Linux_STA_v2.4.0.0/os/linux/.rt2860sta.ko.cmd
    /home/brano/2010_07_16_RT2860_Linux_STA_v2.4.0.0/os/linux/.rt2860sta.mod.o.cmd
    /home/brano/2010_07_16_RT2860_Linux_STA_v2.4.0.0/os/linux/.rt2860sta.o.cmd
    /home/brano/2010_07_16_RT2860_Linux_STA_v2.4.0.0/os/linux/rt2860sta.ko
    /home/brano/2010_07_16_RT2860_Linux_STA_v2.4.0.0/os/linux/rt2860sta.mod.c
    /home/brano/2010_07_16_RT2860_Linux_STA_v2.4.0.0/os/linux/rt2860sta.mod.o
    /home/brano/2010_07_16_RT2860_Linux_STA_v2.4.0.0/os/linux/rt2860sta.o
    /home/brano/2010_07_16_RT2860_Linux_STA_v2.4.0.0/os/linux/.tmp_versions/rt2860sta.mod
    /lib/modules/2.6.38-10-generic/kernel/drivers/staging/rt2860/rt2860sta.ko
    /lib/modules/2.6.38-11-generic/kernel/drivers/staging/rt2860/rt2860sta.ko
    /lib/modules/2.6.38-8-generic/kernel/drivers/staging/rt2860/rt2860sta.ko
    /lib/modules/3.2.0-29-generic/kernel/drivers/net/wireless/rt2860sta.ko
    /lib/modules/3.2.0-35-generic/kernel/drivers/net/wireless/rt2860sta.ko.dist
    /lib/modules/3.2.0-35-generic/kernel/drivers/staging/rt2860sta.ko.dist
    /lib/modules/3.2.0-35-generic/kernel/drivers/staging/rt2860/rt2860sta.ko
    Code:
    modinfo rt2860sta
    ERROR: modinfo: could not open /lib/modules/3.2.0-35-generic/kernel/drivers/net/wireless/rt2860sta.ko: No such file or directory
    Code:
    modprobe rt2860sta
    FATAL: Could not read '/lib/modules/3.2.0-35-generic/kernel/drivers/net/wireless/rt2860sta.ko': No such file or directory
    I understand the last 2 errors, as I have renamed the module to have ".dist" at the end.
    What I do not understand is, how come the wifi gets connected, even when the module cannot be loaded?!

    Well, any help is still greatly appreciated.

    Cheers,
    Brandon.

  8. #8
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,343
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: WiFi works only temporarily on Asus EEE

    If it's connected using rt2800pci, why, oh why did you go to the effort to compile the genetically inferior rt2860sta? I must be confused...
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  9. #9
    Join Date
    May 2011
    Beans
    18

    Re: WiFi works only temporarily on Asus EEE

    Quote Originally Posted by chili555 View Post
    If it's connected using rt2800pci, why, oh why did you go to the effort to compile the genetically inferior rt2860sta? I must be confused...

    Ooops. Most likely because I have very limited knowledge of linux and its drivers
    The reason was that it suddenly stopped working out of nothing (it used work before but it must have been some update). So I started searching for solution.

    Is there a simple way to get rid of all the drivers and let the system install whatever it prefers? If not, I am quite ready to do reinstall.

    Thanks.B.

  10. #10
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,343
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: WiFi works only temporarily on Asus EEE

    Is there a simple way to get rid of all the drivers and let the system install whatever it prefers?
    Sure.
    Code:
    cd Desktop/RT2860folder  <--or wherever you extracted the files
    sudo make uninstall
    sudo modprobe -r rt2860sta
    Reboot and let us have your report. If there is anything not working, we'll address it, but older, inferior drivers won't help.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •