Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Emachines E525 Display Issues

  1. #1
    Join Date
    Dec 2011
    Beans
    10

    Post Emachines E525 Display Issues

    Hello everyone, I am using an Emachines E525 Laptop that I bricked Windows 7 on. I installed Ubuntu 11.10, but the backlight for the display would not work. I later installed 10.04 LTS and went to try to find a solution.

    Is there an easy way to fix this? A Terminal command?

    P.S. Backlight control doesn't work on 10.04 LTS apparently.

  2. #2
    Join Date
    Dec 2011
    Beans
    10

    Re: Emachines E525 Display Issues

    Bump!

  3. #3
    Join Date
    Dec 2011
    Beans
    10

    Re: Emachines E525 Display Issues

    Another bump?

  4. #4
    Join Date
    May 2007
    Beans
    12,495

    Re: Emachines E525 Display Issues

    First of all, quit bumping-- that will not get you a response sooner.

    Second, backlight is hardware. IF it's not working at all, there's nothing you can do in software to MAKE it work.
    Ubuntu 14.04, Mint 17; MS Win 8.1.
    Will not respond to PM requests for support -- use the forums.

  5. #5
    Join Date
    Feb 2008
    Location
    Atlantic Canada
    Beans
    13
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Emachines E525 Display Issues

    Quote Originally Posted by Mark Phelps View Post
    First of all, quit bumping-- that will not get you a response sooner.

    Second, backlight is hardware. IF it's not working at all, there's nothing you can do in software to MAKE it work.
    That is an ignorant reply first of all you couldn't lighten up could you buddy? Instead of rudely telling to stop bumping say it nicely, it makes the world a better place. How do you expect people want to use Ubuntu when they get responses like that.

    On top of that, your suggestion (telling) is wrong. I have the same exact problem, and obviously this persons backlight DOES work because it works for then in 10.04 . I had a solution to the problem bit it is a bug in Ubuntu which has been reported here. It is not a hardware issue.

    What I will say to Hubok,
    There was a solution posted on the forums I used once in Ubuntu 11.04 (when the problem started) and once I find it I will post it here for you.
    Last edited by jsebean; December 27th, 2011 at 01:51 PM.

  6. #6
    Join Date
    Feb 2008
    Location
    Atlantic Canada
    Beans
    13
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Emachines E525 Display Issues

    Unlike previous replies, this is a useful one that will solve the issue .
    The solution to this bug.

    Until this bug is fixed, here is how to fix the backlight issue that works for most users.

    First of all, one problem some have is when they boot the OS after installed there's no backlight, and sometimes there's no backlight in the installer either. To get the backlight to come on so you can install Ubuntu, do this:

    1. Insert your Ubuntu install disc (or usb drive) and reboot.
    2. When you boot the disc or usb drive and you see the "Purple Ubuntu screen" or Ubuntu splash, right away, hold the Fn button and dim your screen brightness then brighten it back up. If you forget to do this and the splash (or purple screen) is gone then the backlight probably wont work and you can't install Ubuntu.

    Once ubuntu is installed and you boot from the HDD, do the same when you boot Ubuntu. When you see the purple screen, right away Hold Fn button and dim the screen down and up. Most emachines, being made by acer, to do this, hold Fn button and then hit the left arrow key then the right arrow key.

    By doing this, Ubuntu will boot with the backlight. I don't know why, but it does.

    Now, that's a bit annoying to fix, and once Ubuntu is booted, you can't adjust your backlight. What we want to do is make ubuntu turn the backlight on automatically when you boot it and also, allow you to adjust your backlight once Ubuntu is booted. To do this:

    Open terminal.
    Type in:
    Code:
    gksudo gedit /etc/rc.local
    and hit enter.

    Find:
    Code:
    exit 0
    Above exit 0, put in:
    Code:
    setpci -s 00:02.0 F4.B=00
    Save the file, and exit Gedit. If you get a popup message the "untitled document" isn't save, ignore it and close without saving.

    This fix will automatically make the backlight turn on upon boot.

    Now to ensure you can adjust your backlight once Ubuntu has booted:
    In terminal, enter the command:
    Code:
    gksudo gedit /etc/default/grub
    In the file, find the line:
    Code:
    GRUB_CMDLINE_LINUX=""
    Change that line to:
    Code:
    GRUB_CMDLINE_LINUX="acpi_osi=Linux"
    Save the file. Exit gedit. If prompted to save untitled document, don't, choose close without saving.

    Now in terminal, type the command:
    Code:
    sudo update-grub
    Wait for the process to finish then exit terminal. Reboot your PC.

    Once rebooted, you will notice the purple screen, but you don't need to adjust your backlight this time. You'll notice once you pass the boot purple screen, the backlight will go out. Don't worry. Wait a few seconds, then the backlight will come on, and ubuntu will boot up and you'll hear the Ubuntu startup sound.

    You will also notice that now you can also use the Fn key and use the right and arrow keys to adjust the brightness. (Or whatever keys you use to adjust the brightness). YAY! It's fixed.


    A couple of things to consider:
    For some users, the backlight still won't automatically turn on. You can however use the brightness controls after Ubuntu is booted to turn the backlight on. If the backlight after doing these fixes still wont turn on, go back to this command and run it "gksudo gedit /etc/rc.local", find the line "setpci -s 00:02.0 F4.B=00" and change it to "setpci -s 00:02.0 F4.B=FF". (without quotes of course). Save and reboot.
    Also, you'll notice if you go into standby (and I think Hibernate as well), the backlight will probably be off. I'm not aware of a way to fix this but to get the backlight back on use the Fn key and adjust your backlight to get it back on.
    For some users, you may also notice that the backlight adjust keys are backwards. Mine aren't, but some users' are. I am not aware of a way to fix this but it's not that big of a bug. So adjust your backlight use the dim button to brighten the screen and the brighten button to dim the screen .

    If you have any questions, I'll try to remember to keep an eye on this topic so I can do any further assistance.

    It's a really annoying bug and a bug report is filed:
    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/765438

    Hope this helps
    -Jonah
    Last edited by jsebean; December 28th, 2011 at 01:32 AM.

  7. #7
    Join Date
    Dec 2011
    Beans
    10

    Re: Emachines E525 Display Issues

    Quote Originally Posted by jsebean View Post
    Unlike previous replies, this is a useful one that will solve the issue .
    The solution to this bug.

    Until this bug is fixed, here is how to fix the backlight issue that works for most users.

    First of all, one problem some have is when they boot the OS after installed there's no backlight, and sometimes there's no backlight in the installer either. To get the backlight to come on so you can install Ubuntu, do this:

    1. Insert your Ubuntu install disc (or usb drive) and reboot.
    2. When you boot the disc or usb drive and you see the "Purple Ubuntu screen" or Ubuntu splash, right away, hold the Fn button and dim your screen brightness then brighten it back up. If you forget to do this and the splash (or purple screen) is gone then the backlight probably wont work and you can't install Ubuntu.

    Once ubuntu is installed and you boot from the HDD, do the same when you boot Ubuntu. When you see the purple screen, right away Hold Fn button and dim the screen down and up. Most emachines, being made by acer, to do this, hold Fn button and then hit the left arrow key then the right arrow key.

    By doing this, Ubuntu will boot with the backlight. I don't know why, but it does.

    Now, that's a bit annoying to fix, and once Ubuntu is booted, you can't adjust your backlight. What we want to do is make ubuntu turn the backlight on automatically when you boot it and also, allow you to adjust your backlight once Ubuntu is booted. To do this:

    Open terminal.
    Type in:
    Code:
    gksudo gedit /etc/rc.local
    and hit enter.

    Find:
    Code:
    exit 0
    Above exit 0, put in:
    Code:
    setpci -s 00:02.0 F4.B=00
    Save the file, and exit Gedit. If you get a popup message the "untitled document" isn't save, ignore it and close without saving.

    This fix will automatically make the backlight turn on upon boot.

    Now to ensure you can adjust your backlight once Ubuntu has booted:
    In terminal, enter the command:
    Code:
    gksudo gedit /etc/default/grub
    In the file, find the line:
    Code:
    GRUB_CMDLINE_LINUX=""
    Change that line to:
    Code:
    GRUB_CMDLINE_LINUX="acpi_osi=Linux"
    Save the file. Exit gedit. If prompted to save untitled document, don't, choose close without saving.

    Now in terminal, type the command:
    Code:
    sudo update-grub
    Wait for the process to finish then exit terminal. Reboot your PC.

    Once rebooted, you will notice the purple screen, but you don't need to adjust your backlight this time. You'll notice once you pass the boot purple screen, the backlight will go out. Don't worry. Wait a few seconds, then the backlight will come on, and ubuntu will boot up and you'll hear the Ubuntu startup sound.

    You will also notice that now you can also use the Fn key and use the right and arrow keys to adjust the brightness. (Or whatever keys you use to adjust the brightness). YAY! It's fixed.


    A couple of things to consider:
    For some users, the backlight still won't automatically turn on. You can however use the brightness controls after Ubuntu is booted to turn the backlight on. If the backlight after doing these fixes still wont turn on, go back to this command and run it "gksudo gedit /etc/rc.local", find the line "setpci -s 00:02.0 F4.B=00" and change it to "setpci -s 00:02.0 F4.B=FF". (without quotes of course). Save and reboot.
    Also, you'll notice if you go into standby (and I think Hibernate as well), the backlight will probably be off. I'm not aware of a way to fix this but to get the backlight back on use the Fn key and adjust your backlight to get it back on.
    For some users, you may also notice that the backlight adjust keys are backwards. Mine aren't, but some users' are. I am not aware of a way to fix this but it's not that big of a bug. So adjust your backlight use the dim button to brighten the screen and the brighten button to dim the screen .

    If you have any questions, I'll try to remember to keep an eye on this topic so I can do any further assistance.

    It's a really annoying bug and a bug report is filed:
    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/765438

    Hope this helps
    -Jonah
    Thanks for telling me the fix, I'll try it tomorrow once I can start burning the new disc.

    (Can't wait!)

  8. #8
    anewguy is offline I Ubuntu, Therefore, I Am
    Join Date
    Jun 2007
    Location
    Sometimes I visit earth
    Beans
    5,440
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Emachines E525 Display Issues

    Please do note, however, that Mark is correct -> the forum rules say no bumping before 24 hours have elapsed. So please, in the future, wait 24 hours before bumping. You see, EVERYONE who posts with a problem here thinks their problem is the most important and must be fixed NOW. For people who demand that type of service there is paid support. This is a volunteer forum, and no one persons problem is of any higher importance than the next.

    So, if you're problem is solved, great. Just remember the forum rules - if you haven't read them, you'd be strongly advised to do so.
    Last edited by anewguy; December 29th, 2011 at 10:01 AM.

  9. #9
    Join Date
    Jan 2012
    Beans
    2

    Re: Emachines E525 Display Issues


    Ubuntu Blacklight fixes ACER FIXES



    Create an autostartup script for Debian and Ubuntu systems


    In Debian-based distributions (and here I’m also talking about the widely-spread Ubuntu), there is no rc.local file preinstalled. The good thing is that you can make one easily so you can have a place to put commands to be started up automatically at boot. Here’s what you have to do:

    sudo nano /etc/init.d/local.autostart

    You can name the new file whatever you want, but in this example we’ll use local.autostart. Paste
    ================================================== ================================================== =

    #!/bin/sh

    sudo setpci -s 00:02.0 F4.B=0


    ================================================== ==============================================

    CTRL+O TO WRITE FILE PRESS ENTER
    CTRL TO EXIT
    ================================================== =====

    on the first line of the file and your command(s) underneath, one after the other. Now save and close and make the file executable with

    sudo chmod +x /etc/init.d/local.autostart

    Make the file be recognized as an init script:

    sudo update-rc.d local.autostart defaults 80

    Now, every time you boot up your Debian-based distribution, the commands you set in /etc/init.d/local.autostart will “magically” autostart.
    Last edited by ajit.patell; January 4th, 2012 at 04:24 PM.

  10. #10
    Join Date
    Jul 2005
    Location
    Oldenburg, Germany
    Beans
    16
    Distro
    Kubuntu Breezy 5.10

    Re: Emachines E525 Display Issues

    Quote Originally Posted by anewguy View Post
    Please do note, however, that Mark is correct -> the forum rules say no bumping before 24 hours have elapsed.
    first bump by original poster was "2 weeks ago". second bump was "1 week ago" (both according to the text under the user's name in each post sidebar). i may be wrong, but i'm pretty sure the time between 2 weeks ago and 1 week ago is longer than 24 hours!



    regardless, thanks to jsebean for the info!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •