Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: anki package outdated

  1. #11
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: anki package outdated

    Quote Originally Posted by Dave_L View Post
    I voted too.

    But even if Anki 2 were in the repo, it would quickly become out of date, since Anki has been getting updated every week or so, with bug fixes or feature additions.

    What's needed is a volunteer, or volunteers, to keep the repo package updated on a continuing basis.
    That's never going to happen for the package in the official repositories. However people interested in doing that could very well set up (and maintain ) a PPA repository. Which is the exact things what the PPA's are for....

  2. #12
    Join Date
    Dec 2008
    Beans
    3

    Re: anki package outdated

    How much work/knowledge is needed to set up a PPA? Or what requirements are needed at all?

  3. #13
    Join Date
    Sep 2010
    Beans
    898

    Re: anki package outdated

    Quote Originally Posted by Mrokii View Post
    How much work/knowledge is needed to set up a PPA? Or what requirements are needed at all?
    https://help.launchpad.net/Packaging/PPA

    I think the bulk of the effort is assembling the package, and then keeping it up to date.

  4. #14
    Join Date
    Sep 2010
    Beans
    898

    Re: anki package outdated

    Quote Originally Posted by Dave_L View Post
    https://help.launchpad.net/Packaging/PPA

    I think the bulk of the effort is assembling the package, and then keeping it up to date.
    Actually, since Anki is already available as a downloadable .deb (at http://ankisrs.net/), I wonder if it's as simple as uploading the .deb to a PPA. I skimmed through the above launchpad.net article, but I didn't understand all the details.

    Creating a PPA is itself simple; it's an option in one's launchpad.net account.

  5. #15
    Join Date
    Dec 2010
    Location
    Fukuoka, Japan
    Beans
    1,062
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: anki package outdated

    Do you even need a ppa? Once Anki is installed, it automatically updates when you open the program.

  6. #16
    Join Date
    Sep 2010
    Beans
    898

    Re: anki package outdated

    Quote Originally Posted by whatthefunk View Post
    Do you even need a ppa? Once Anki is installed, it automatically updates when you open the program.
    Doesn't that feature merely download the .deb with your browser? That's different from using a PPA or repository within a package manager such as synaptic, which provides you with other capabilities.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •