Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: ubuntu 12.04 black screen after login

  1. #1
    Join Date
    Jul 2008
    Beans
    130

    ubuntu 12.04 black screen after login

    Hi,

    I installed ubuntu 12.04 lts on a lenovo desktop. We are presented with the login screen and everything looks fine. We login and the desktop goes black. All we have is a cursor.

    When the monitor when into suspend mode we were presented with a lockout screen/login. Entered password and then saw a message "System program problem detected screen showed after." afterwards. Cannot click cancel or send report button.

    here is the lspci information

    elizabeth@elizabeth-pc:~$ lspci
    00:00.0 RAM memory: NVIDIA Corporation C51 Host Bridge (rev a2)
    00:00.1 RAM memory: NVIDIA Corporation C51 Memory Controller 0 (rev a2)
    00:00.2 RAM memory: NVIDIA Corporation C51 Memory Controller 1 (rev a2)
    00:00.3 RAM memory: NVIDIA Corporation C51 Memory Controller 5 (rev a2)
    00:00.4 RAM memory: NVIDIA Corporation C51 Memory Controller 4 (rev a2)
    00:00.5 RAM memory: NVIDIA Corporation C51 Host Bridge (rev a2)
    00:00.6 RAM memory: NVIDIA Corporation C51 Memory Controller 3 (rev a2)
    00:00.7 RAM memory: NVIDIA Corporation C51 Memory Controller 2 (rev a2)
    00:02.0 PCI bridge: NVIDIA Corporation C51 PCI Express Bridge (rev a1)
    00:05.0 VGA compatible controller: NVIDIA Corporation C51G [GeForce 6100] (rev a2)
    00:09.0 RAM memory: NVIDIA Corporation MCP51 Host Bridge (rev a2)
    00:0a.0 ISA bridge: NVIDIA Corporation MCP51 LPC Bridge (rev a3)
    00:0a.1 SMBus: NVIDIA Corporation MCP51 SMBus (rev a3)
    00:0a.2 RAM memory: NVIDIA Corporation MCP51 Memory Controller 0 (rev a3)
    00:0b.0 USB controller: NVIDIA Corporation MCP51 USB Controller (rev a3)
    00:0b.1 USB controller: NVIDIA Corporation MCP51 USB Controller (rev a3)
    00:0d.0 IDE interface: NVIDIA Corporation MCP51 IDE (rev f1)
    00:0e.0 IDE interface: NVIDIA Corporation MCP51 Serial ATA Controller (rev f1)
    00:10.0 PCI bridge: NVIDIA Corporation MCP51 PCI Bridge (rev a2)
    00:10.1 Audio device: NVIDIA Corporation MCP51 High Definition Audio (rev a2)
    00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
    00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
    00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
    00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
    03:05.0 Communication controller: Conexant Systems, Inc. HSF 56k Data/Fax Modem
    03:08.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5788 Gigabit Ethernet (rev 03)

    I also tried to update nvidia and that didn't help either.

    sudo apt-get install nvidia-current-updates
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following extra packages will be installed:
    nvidia-settings-updates
    The following NEW packages will be installed:
    nvidia-current-updates nvidia-settings-updates
    0 upgraded, 2 newly installed, 0 to remove and 12 not upgraded.
    Need to get 34.4 MB of archives.
    After this operation, 100 MB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://us.archive.ubuntu.com/ubuntu/ precise/restricted nvidia-current-updates i386 295.40-0ubuntu1 [33.4 MB]
    Get:2 http://us.archive.ubuntu.com/ubuntu/ precise/restricted nvidia-settings-updates i386 295.33-0ubuntu1 [925 kB]
    Fetched 34.4 MB in 1min 35s (360 kB/s)
    Selecting previously unselected package nvidia-current-updates.
    (Reading database ... 142421 files and directories currently installed.)
    Unpacking nvidia-current-updates (from .../nvidia-current-updates_295.40-0ubuntu1_i386.deb) ...
    Selecting previously unselected package nvidia-settings-updates.
    Unpacking nvidia-settings-updates (from .../nvidia-settings-updates_295.33-0ubuntu1_i386.deb) ...
    Processing triggers for man-db ...
    Setting up nvidia-current-updates (295.40-0ubuntu1) ...
    INFO:Enable nvidia-current-updates
    DEBUGarsing /usr/share/nvidia-common/quirks/put_your_quirks_here
    DEBUGarsing /usr/share/nvidia-common/quirks/dell_latitude
    DEBUGarsing /usr/share/nvidia-common/quirks/lenovo_thinkpad
    DEBUGrocessing quirk Latitude E6530
    DEBUG:Failure to match LENOVO with Dell Inc.
    DEBUG:Quirk doesn't match
    DEBUGrocessing quirk ThinkPad T420s
    DEBUG:Failure to match ThinkCentre XXXX with ThinkPad T420s
    DEBUG:Quirk doesn't match
    Loading new nvidia-current-updates-295.40 DKMS files...
    First Installation: checking all kernels...
    Building only for 3.2.0-23-generic-pae
    Building for architecture i686
    Building initial module for 3.2.0-23-generic-pae
    Done.

    nvidia_current_updates:
    Running module version sanity check.
    - Original module
    - No original module exists within this kernel
    - Installation
    - Installing to /lib/modules/3.2.0-23-generic-pae/updates/dkms/

    depmod.......

    DKMS: install completed.
    Setting up nvidia-settings-updates (295.33-0ubuntu1) ...
    update-alternatives: using /usr/lib/nvidia-settings-updates/ld.so.conf to provide /etc/ld.so.conf.d/nvidia_settings.conf (nvidia_settings_conf) in auto mode.
    Processing triggers for bamfdaemon ...
    Rebuilding /usr/share/applications/bamf.index...



    Looking for help how to get the desktop Installation of course worked fine and just running via CD is fine.

    also via dmesg I see this error:

    [ 96.826209] compiz[1681]: segfault at a79bf800 ip b562f4c0 sp bfe47960 error 4 in libnvidia-glcore.so.295.40[b43de000+1bc0000]

  2. #2
    Join Date
    Jul 2008
    Beans
    130

    Re: ubuntu 12.04 black screen after login

    was able to login via selecting 2D at the login screen. There was still a compiz crash.

    anyone know how to disable this compiz or make the default login 2d? at least until a fix can be found?

  3. #3
    Join Date
    Sep 2010
    Location
    Beta Testing in Canada
    Beans
    5,423
    Distro
    Ubuntu Development Release

    Re: ubuntu 12.04 black screen after login

    Quote Originally Posted by HolyRoses View Post
    was able to login via selecting 2D at the login screen. There was still a compiz crash.

    anyone know how to disable this compiz or make the default login 2d? at least until a fix can be found?

    Do you have Precise Stable or are you running from an earlier release?

    Edit: btw .. did you install 64bit or 32 bit version?
    Last edited by ventrical; April 28th, 2012 at 07:07 PM.
    This is Rolling Release
    Warnings for New Beta Testers& Helpful Terminal Commands:
    Running Trusty /devel/@ 5.120GHz32bit/ Please put [ prefix] on New Threads!

  4. #4
    Join Date
    Jul 2008
    Beans
    130

    Re: ubuntu 12.04 black screen after login

    32 bit. I downloaded the ubuntu yesterday. So I assume its the latest revision.

  5. #5
    Join Date
    Sep 2010
    Location
    Beta Testing in Canada
    Beans
    5,423
    Distro
    Ubuntu Development Release

    Re: ubuntu 12.04 black screen after login

    I am just curious as to whether 'Additional Drivers' reports anything to you? Could you try to run that please?
    This is Rolling Release
    Warnings for New Beta Testers& Helpful Terminal Commands:
    Running Trusty /devel/@ 5.120GHz32bit/ Please put [ prefix] on New Threads!

  6. #6
    Join Date
    Jul 2008
    Beans
    130

    Re: ubuntu 12.04 black screen after login

    just the nvidia update I am the (post-release updates) (version current-updates).

  7. #7
    Join Date
    Sep 2010
    Location
    Beta Testing in Canada
    Beans
    5,423
    Distro
    Ubuntu Development Release

    Re: ubuntu 12.04 black screen after login

    Quote Originally Posted by HolyRoses View Post
    Hi,

    also via dmesg I see this error:

    [ 96.826209] compiz[1681]: segfault at a79bf800 ip b562f4c0 sp bfe47960 error 4 in libnvidia-glcore.so.295.40[b43de000+1bc0000]
    It may be more simpler than this but at one time I had to un-install and re-install compiz. I'm not sure it will help.

    My assumption is that there may be a BIOS setting that needs to be adjusted, but I am also assuming that you perhaps have had Ubutnu running really well with a earlier version ?
    This is Rolling Release
    Warnings for New Beta Testers& Helpful Terminal Commands:
    Running Trusty /devel/@ 5.120GHz32bit/ Please put [ prefix] on New Threads!

  8. #8
    Join Date
    Jul 2008
    Beans
    130

    Re: ubuntu 12.04 black screen after login

    never installed ubuntu on this desktop. its an older machine. came with vista. also had issues with graphics trying to install windows 7.

    on a good note it seems to default to 2d on your login if you previously selected that.
    Last edited by HolyRoses; April 28th, 2012 at 07:34 PM.

  9. #9
    Join Date
    Sep 2010
    Location
    Beta Testing in Canada
    Beans
    5,423
    Distro
    Ubuntu Development Release

    Re: ubuntu 12.04 black screen after login

    Quote Originally Posted by HolyRoses View Post
    never installed ubuntu on this desktop. its an older machine. came with vista. also had issues with graphics trying to install windows 7.

    Try from the terminal:

    sudo apt-get purge nvidia*

    then reboot

    after reboot get into GRUB by holding down your <Shift> key and choose <recovery-mode>. Let it go through it's cycle and then select <resume> . This may give you a standard generic driver that will give you a desktop at least.

    Edit:

    If this does not work then try to re-install the nvidia drivers.
    This is Rolling Release
    Warnings for New Beta Testers& Helpful Terminal Commands:
    Running Trusty /devel/@ 5.120GHz32bit/ Please put [ prefix] on New Threads!

  10. #10
    Join Date
    Sep 2010
    Location
    Beta Testing in Canada
    Beans
    5,423
    Distro
    Ubuntu Development Release

    Re: ubuntu 12.04 black screen after login

    Also here is somthing I found about your Nvidia card.

    From Cariboo907

    "March 30th, 2011, 10:57 PM
    The 6100-6150 chipsets have always been strange as far as I'm concerned, I've had 3 motherboards with them, and all of them needed either safe-mode or nomodeset enabled before I could boot to a desktop with the Live CD this is going back to 7.04. I haven't tried since Lucid, because I bought add-in cards specifically a 8400GS, a 9400GT and a GT210 so that I didn't have to deal with the weirdness any more.

    You shouldn't have to, but if you are having problems, install nvidia-current, then run nvidia-xconfig to see if that helps.

    I did a test install this afternoon on a system with a GT6600, Additional drivers gave me the choice of either nvidia-current or the experimental 3D open source driver, I chose the experimental drivers, and Unity started right up with having to do a reboot after the driver were installed."
    Last edited by ventrical; April 28th, 2012 at 07:49 PM.
    This is Rolling Release
    Warnings for New Beta Testers& Helpful Terminal Commands:
    Running Trusty /devel/@ 5.120GHz32bit/ Please put [ prefix] on New Threads!

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •