Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 32

Thread: Lubuntu does not use all of my RAM

  1. #21
    Join Date
    Nov 2009
    Beans
    14

    Re: Lubuntu does not use all of my RAM

    Same heer with toshiba tecra a8. Years ago read in tech forum that is bios problem. Yes bios say 4gb but nor Windows not Linux can oparate with all of them

  2. #22
    Join Date
    Aug 2006
    Location
    gypsy encampment
    Beans
    433
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Lubuntu does not use all of my RAM

    Speculation here, since I don't know any better:

    Code:
    head -n 150 /var/log/dmesg
    
    *snip*
    [    0.000000] New variable MTRRs
    [    0.000000] reg 0, base: 0GB, range: 4GB, type WB
    [    0.000000] reg 1, base: 3456MB, range: 128MB, type UC
    [    0.000000] reg 2, base: 3584MB, range: 512MB, type UC
    *snip*
    When variable MTRRs were remapped, doesn't it look like reg1 and reg2 were reserved for the video card? It looks like 4GB minus 636MB gets pretty close to your memory available, doesn't it?

    If anyone else has a better explanation, please correct me!
    System76 Serval Pro 7: Ubuntu 14.04; Dell Latitude D800: Lubuntu 14.04

    Ubuntu problems? http://www.googlubuntu.com/

  3. #23
    Join Date
    Mar 2009
    Beans
    1,329

    Re: Lubuntu does not use all of my RAM

    Quote Originally Posted by oldgraf View Post
    Same heer with toshiba tecra a8. Years ago read in tech forum that is bios problem. Yes bios say 4gb but nor Windows not Linux can oparate with all of them
    This is a hardware issue, not a Linux or Windows issue.

    I have 12g on my Ubuntu, and an external video card that has its own memory instead of robbing from the system RAM. My system doesn't show nearly that much missing, everything can be accounted for by the lspci memory trick.

  4. #24
    Join Date
    Aug 2010
    Beans
    17

    Re: Lubuntu does not use all of my RAM

    Quote Originally Posted by MoebusNet View Post
    Speculation here, since I don't know any better:

    Code:
    head -n 150 /var/log/dmesg
    
    *snip*
    [    0.000000] New variable MTRRs
    [    0.000000] reg 0, base: 0GB, range: 4GB, type WB
    [    0.000000] reg 1, base: 3456MB, range: 128MB, type UC
    [    0.000000] reg 2, base: 3584MB, range: 512MB, type UC
    *snip*
    When variable MTRRs were remapped, doesn't it look like reg1 and reg2 were reserved for the video card? It looks like 4GB minus 636MB gets pretty close to your memory available, doesn't it?

    If anyone else has a better explanation, please correct me!
    Thank you all for the explaination. I agree, and also with that this is probably related to mapping the memory.

    The thing I still don't understand is that the video card only uses 256MB of extra memory... (see the output of the lspci stuff) so still about 500MB is "missing". Well it get's mapped into someting... but is it clear that that is bios related and does this mean it is unusable?

    Another way to put it, the memory is mapped into reg0, reg1, reg2. Does this mean that is then automatically unavailable for as ram?

  5. #25
    Join Date
    Sep 2009
    Beans
    16

    Re: Lubuntu does not use all of my RAM

    had a similar issue with my Asus 1215N when I upgraded from 2 to 3 GB RAM - I had to do a BIOS update so the additional RAM would be recongnized at all. if it's not that, probably the "missing" RAM is indeed reserved for your onboard GPU, if you can't set it in the BIOS it will be the max amount the GPU can handle (like 512 or 768M for the usual Intel HD chipsets)

  6. #26
    Join Date
    Sep 2013
    Beans
    3

    Re: Lubuntu does not use all of my RAM

    I have the same problem.

    BIOS Detected 8 GB! Work, Nvidia Shared 256 MB


    8 GB,not recognizing Lubuntu 64 bit amd motherboard asrock N68-S3 FX

    two memory 4 GB(Corsair Vengeance 1x 4 Gb ddr3 1600)

    ------
    uname -a
    Linux kernel-desktop 3.8.0-30-generic #44-Ubuntu SMP Thu Aug 22 20:52:24 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
    NVIDIA Corporation C61 [GeForce 7025 / nForce 630a] (rev a2) (prog-if 00 [VGA controller]) Subsystem: ASRock Incorporation Device 03d6
    Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
    Memory at ee000000 (32-bit, non-prefetchable) [size=16M]
    Memory at d0000000 (64-bit, prefetchable) [size=256M]
    Memory at ed000000 (64-bit, non-prefetchable) [size=16M]
    [virtual] Expansion ROM at effc0000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: nvidia
    free -m total used free shared buffers cached
    Mem: 3701 3023 678 0 137 802
    -/+ buffers/cache: 2083 1618
    Swap: 3839 0 3839
    kernel@kernel-desktop:~$ free -mh
    total used free shared buffers cached
    Mem: 3,6G 3,0G 674M 0B 137M 805M
    -/+ buffers/cache: 2,0G 1,6G
    Swap: 3,7G 0B 3,7G

    sudo dmidecode -t 6# dmidecode 2.11
    SMBIOS 2.6 present.

    cat /proc/cpuinfo | grep paeflags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt nodeid_msr hw_pstate npt lbrv svm_lock nrip_save
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt nodeid_msr hw_pstate npt lbrv svm_lock nrip_save
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt nodeid_msr hw_pstate npt lbrv svm_lock nrip_save
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt nodeid_msr hw_pstate npt lbrv svm_lock nrip_save

    Not boot with 8 GB, black screen loading... not loaded full :/

    boot 4 GB more no detect 4 GB memory :/

    help :/

  7. #27
    Join Date
    Sep 2013
    Beans
    3

    Re: Lubuntu does not use all of my RAM

    is there any way to use Lubuntu 13 64-bit memory of 8 GB?

  8. #28
    Join Date
    Sep 2013
    Beans
    3

    Re: Lubuntu does not use all of my RAM

    Well, come to detail, something I should have done from the beginning.


    Motherboard asrock N68-S3-fx
    2 memories 1X 4GB DDR3 1600.


    Sata 160 gb HD.


    In bios I provides the total memory 8 GB shared 256
    with nvidia onboard.




    Systems tested Lubuntu 13:04 64 and 32 bits.




    The installation of both works only with 1 stick of memory connected.


    And in Sees Maximum 3 GB, both 64-bit and 32.


    When I add another comb memory, the boot screen is dark. Blank Screen.


    In 32-bit system the only kernel that worked with 2 sticks Memory was the generic 3.2.40 for ubuntu.


    But I only view 3 GB of memory.


    I installed kernel-pae, gave me black screen again, Blank Screen, it stop there.


    In the 64-bit, even compiling the kernel 3.2.40, still blank screen, the thing is when I put the other comb 4 GB, 8 GB total, is in blank Screen and not out there.


    The I modified grub also for possible problems blank screen, changing the grub splash quiet to modonoset.


    Only works with one memory of 4 GB, which displays only 3 Gb


    The OS was installed via USB stick.
    Yet this does not influence.


    Anyone can say what I can do for my Lubuntu use 8 GB?

  9. #29
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Xubuntu 14.10 Utopic Unicorn

    Re: Lubuntu does not use all of my RAM

    You'd be much better off starting a new thread for your questions.

  10. #30
    Join Date
    Aug 2013
    Beans
    2

    Re: Lubuntu does not use all of my RAM

    Quote Originally Posted by axel668 View Post
    had a similar issue with my Asus 1215N when I upgraded from 2 to 3 GB RAM - I had to do a BIOS update so the additional RAM would be recongnized at all. if it's not that, probably the "missing" RAM is indeed reserved for your onboard GPU, if you can't set it in the BIOS it will be the max amount the GPU can handle (like 512 or 768M for the usual Intel HD chipsets)
    I have literally the same issue as dirkdirk. Only 3.2GB RAM when I have 4GBs installed, despite having the x64 bit architecture. Since my Windows 7 partition utilizes all of my memory I'm going to guess it's not an BIOS issue and it's just memory the system reserves. If this is the case, is there anyway to tell my graphics card to use less memory for my Ubuntu partition only?

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •