Results 1 to 9 of 9

Thread: Disable one wifi interface?

  1. #1
    Join Date
    Nov 2009
    Beans
    37

    Disable one wifi interface?

    I've been without broadband over Christmas. }-(. The temporary fix is to stick a wifi dongle out of the window via a long USB cable and log onto my neighbour's wifi.

    UB doesn't seem to appreciate having multiple wireless cards though and always tries to connect via my laptop's built in device - any idea how I can disable the internal one so leaving it to use the usb dongle?

    I've just got a virgin install of Kubuntu 12.x.

    Thanks

  2. #2
    Join Date
    Apr 2012
    Beans
    5,412

    Re: Disable one wifi interface?

    What's worked for me in the past is to specify it as an 'unmanaged device' in the NetworkManager.conf file HOWEVER I know other people have been unsuccessful with that method

    The more brute force approach is to blacklist the driver - obviously that's only if the new dongle doesn't use the same driver as the old one

    Both methods described here

    http://ubuntuforums.org/showthread.p...anaged-devices

    FWIW I seem to remember the MAC address in the unmanaged-devices line being case sensitive

  3. #3
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,667
    Distro
    Ubuntu Development Release

    Re: Disable one wifi interface?

    Hi

    Look in the BIOS and see if there is an option to disable the internal wireless card.

    Most Bios's have that option.

    Kind regards
    Join us on irc at #ubuntuforums. For web chat see here

    If you believe everything you read, you better not read. ~ Japanese Proverb

    Do not read newspapers on an empty stomach ~ Russian Proverb ~ BrunoLotse

  4. #4
    Join Date
    Nov 2009
    Beans
    37

    Re: Disable one wifi interface?

    Quote Originally Posted by matt_symes View Post
    Hi

    Look in the BIOS and see if there is an option to disable the internal wireless card.
    Yeah but it disables all wifi devices

  5. #5
    Join Date
    Jun 2011
    Location
    The Shadow Gallery
    Beans
    6,803

    Re: Disable one wifi interface?

    Code:
    ifconfig <wlanx> down
    Where x is the 0 or 1 or whatever pertaining to the wifi you want to disable
    Feel Free to Bitcoin Tip: 135Rp4pwwYTHEJ4u8bxKaDQiC91N9LUoV2

    Backtrack - Giving machine guns to monkeys since 2006
    Kali-Linux - Adding a grenade launcher to the machine guns since 2013

  6. #6
    Join Date
    Nov 2009
    Beans
    37

    Re: Disable one wifi interface?

    Quote Originally Posted by steeldriver View Post
    What's worked for me in the past is to specify it as an 'unmanaged device' in the NetworkManager.conf file HOWEVER I know other people have been unsuccessful with that method
    Well I get a new dialog up whenever I try to connect the USB dongle - 'Secrets for [network name] - KDE Daemon' asking for a password. If this is the wifi key why doesn't it say so? and it keeps failing to connect..

  7. #7
    Join Date
    Nov 2009
    Beans
    37

    Re: Disable one wifi interface?

    Quote Originally Posted by haqking View Post
    Code:
    ifconfig <wlanx> down
    Where x is the 0 or 1 or whatever pertaining to the wifi you want to disable
    Simple Fails I get a connection alright but the built in browser (or ping) can't do a DNS lookup - is it trying to use the disabled network?
    Last edited by mr_si; December 30th, 2012 at 10:25 PM.

  8. #8
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,667
    Distro
    Ubuntu Development Release

    Re: Disable one wifi interface?

    Hi

    Disabling the internal network card in the BIOS should have no effect on any USB network adaptor.

    Haqking's suggestion would have also disabled the internal wireless card only, assuming you selected the correct interface.

    It seems to me your problem is not related to the internal wireless card but, maybe, to the USB wireless dongle.

    Open a terminal and type (with the dongle connected)

    Code:
    lspci
    Code:
    ifconfig
    Code:
    iwconfig
    Code:
    ping 8.8.8.8
    Code:
    nslookup www.google.com
    Please post the results of these commands back here.

    Kind regards
    Join us on irc at #ubuntuforums. For web chat see here

    If you believe everything you read, you better not read. ~ Japanese Proverb

    Do not read newspapers on an empty stomach ~ Russian Proverb ~ BrunoLotse

  9. #9
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Disable one wifi interface?

    Hi, you can also edit your wireless connections and
    uncheck connect automatically, then simply use what ever
    connection you want when the menu comes up that wireless
    connections have been found.
    @matt_symes, depending on how you disable wireless in bios it
    can kill any wireless ....atleast in a dell.
    one option disables any ability to use any wireless, the disable
    pci card,will kill just the internal card. The only option marked
    "Wireless" is the one that disables any form of wireless.
    Last edited by Hadaka; December 31st, 2012 at 03:06 PM.
    Craving anchovy, herring and squid pizza.....with clam sauce

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •