Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 29

Thread: Revo RL80 ubuntu 12.04 intel hd i915 htpc xbmc

  1. #11
    Join Date
    Mar 2007
    Beans
    7

    Re: Revo RL80 ubuntu 12.04 intel hd i915 htpc xbmc

    Last update: I have a full working setup, based on MythBuntu 11.10 without nomodeset for all clarity so I have the hardware acceleration. I presume stock Ubuntu 11.10 also works. After installation I installed XBMC.
    I did NOT install any updates as it breaks my system and I've seen enough of the screen flashing :/
    For the sound to work I had to do some extra config in 2 files. I can post them here if anyone would need them. The sound does not work through the digital connector, only through HDMI.

    I tried the xorg-edges and all that crack with the only result a flashing screen. If anyone could get it to work soon I'll pay him/her a pizza In the other case, I wait for Ubuntu 13.04 or I try some other distro.
    Last edited by fieus; January 22nd, 2013 at 02:36 PM.

  2. #12
    Join Date
    Jan 2013
    Beans
    3

    Re: Revo RL80 ubuntu 12.04 intel hd i915 htpc xbmc

    Would love to know if this will ever be resolved, the only reason I purchased the Revo was for xbmc duties.

    Using the older 11.10 Mythbuntu, does anyone know if XBMC Frodo is support with Hi-Def audio bitstreaming?

    I'd also throw in a Pizza for the resolver of this!

  3. #13
    Join Date
    Jan 2013
    Beans
    3

    Re: Revo RL80 ubuntu 12.04 intel hd i915 htpc xbmc

    Will test tonight and report back.

    Thanks for your assistance.

    Quote Originally Posted by purct View Post
    I am considering buying one of these revo RL80's, I already have the RL70 version and i think its great...but I am somewhat put off buying now!!

    Can somebody try this and let us know the results:

    Modify the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub to:

    GRUB_CMDLINE_LINUX_DEFAULT="video=i915:modeset=1 i915.i915_enable_rc6=1 i915.lvds_downclock=1 i915.i915_enable_fbc=1 pcie_aspm=force"


    Then run:

    sudo update-grub

    After running update-grub restart ubuntu!

    NOTE: You may wish to also try with i915.modeset=0

    Also it maybe worth trying the following:

    edit the file /etc/mkinicpio.conf and add:

    MODULES="intel_agp drm i915"

    I hope it helps!

  4. #14
    Join Date
    Jan 2013
    Beans
    3

    Re: Revo RL80 ubuntu 12.04 intel hd i915 htpc xbmc

    Hi,

    tried the GRUB_CMDLINE.... settings and still no go.

    I wasn't able to locate the mkinicpio file to edit so I've not been able to try that.

    Any other suggestions please?

    Cheers.

    Quote Originally Posted by purct View Post
    I am considering buying one of these revo RL80's, I already have the RL70 version and i think its great...but I am somewhat put off buying now!!

    Can somebody try this and let us know the results:

    Modify the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub to:

    GRUB_CMDLINE_LINUX_DEFAULT="video=i915:modeset=1 i915.i915_enable_rc6=1 i915.lvds_downclock=1 i915.i915_enable_fbc=1 pcie_aspm=force"


    Then run:

    sudo update-grub

    After running update-grub restart ubuntu!

    NOTE: You may wish to also try with i915.modeset=0

    Also it maybe worth trying the following:

    edit the file /etc/mkinicpio.conf and add:

    MODULES="intel_agp drm i915"

    I hope it helps!

  5. #15
    Join Date
    Aug 2008
    Beans
    6

    Re: Revo RL80 ubuntu 12.04 intel hd i915 htpc xbmc

    Quote Originally Posted by fieus View Post
    Last update: I have a full working setup, based on MythBuntu 11.10 without nomodeset for all clarity so I have the hardware acceleration. I presume stock Ubuntu 11.10 also works. After installation I installed XBMC.
    I did NOT install any updates as it breaks my system and I've seen enough of the screen flashing :/
    For the sound to work I had to do some extra config in 2 files. I can post them here if anyone would need them. The sound does not work through the digital connector, only through HDMI.

    I tried the xorg-edges and all that crack with the only result a flashing screen. If anyone could get it to work soon I'll pay him/her a pizza In the other case, I wait for Ubuntu 13.04 or I try some other distro.
    Could I get those config files please? Just about to try MythBuntu 11.10 for my Revo (L80).

  6. #16
    Join Date
    Oct 2011
    Beans
    34

    Re: Revo RL80 ubuntu 12.04 intel hd i915 htpc xbmc

    I appreciate that 11.10 appears to work but for me it isn't acceptable for me to install a release that will not be supported shortly.

    Is there any further news on this hardware working correctly with the Intel driver (without nomodeset etc.) in 12.04 or 12.10, or even if support is planned for 13.04?

  7. #17
    Join Date
    Mar 2013
    Beans
    1

    Re: Revo RL80 ubuntu 12.04 intel hd i915 htpc xbmc

    Quote Originally Posted by rodhull View Post
    I appreciate that 11.10 appears to work but for me it isn't acceptable for me to install a release that will not be supported shortly.

    Is there any further news on this hardware working correctly with the Intel driver (without nomodeset etc.) in 12.04 or 12.10, or even if support is planned for 13.04?
    I have the RL80 working with kernel mode setting.

    This involved patching a 3.9 kernel.
    I used this kernel:
    http://cgit.freedesktop.org/~danvet/...3-03-23.tar.gz

    I applied this patch:
    https://bugs.freedesktop.org/attachment.cgi?id=77018

    The result: I have a native i915 driver (not VESA) with kernel mode setting, I can use xrandr to set custom modes, *and* as a bonus, Intel HD Audio seems to work quite a bit better than it did with any other kernel I've tried.

    Dan Vetter and the Intel Graphics team turned this problem around for me in about 36 hours; I was really impressed. I have no idea how long it will take for this patch to get into mainstream Debibuntu distros.

  8. #18
    Join Date
    Mar 2013
    Beans
    3

    Re: Revo RL80 ubuntu 12.04 intel hd i915 htpc xbmc

    interesting...

    I have the same problem with my RL 80. Can I hope that the problem will be solved in older Kernel (3.2.39 in Ubuntu 12.04) ?
    Also i have seen a new Bios P11.A2L "Bios for Linux" for Revo 80. If i start the bios update, the screen shows “Error: File ROM ID incorrect"
    Acer in germany will not hepl with linux-os, if the device was shipped with windows 8.

  9. #19
    Join Date
    Mar 2013
    Beans
    2

    Re: Revo RL80 ubuntu 12.04 intel hd i915 htpc xbmc

    I compiled the kernel using the patch that mrdemeanor listed, starting from ubuntu 12.10, and it appears to have worked. I can boot without the i915.blacklist option, and I don't get the flashing rainbow colors.

    Video playback still isn't as fast as I had hoped; I played a youtube video in firefox and it was pretty sluggish. The mouse is also sluggish to react. I don't know if this is related, but I suspect it may also be related to the graphics because the compz process spikes up in cpu utilization when I move the mouse around.

    Edit: mouse lag seems to happen if I change my TV to a different video source and back. If I restart the RL80 the mouse lag goes away (until I change the TV again).
    Last edited by lasttoknow0; March 31st, 2013 at 08:39 PM.

  10. #20
    Join Date
    Oct 2011
    Beans
    34

    Re: Revo RL80 ubuntu 12.04 intel hd i915 htpc xbmc

    I presume that this is the bug?
    https://bugs.freedesktop.org/show_bug.cgi?id=60029

    Is there any way someone can provide a pre-compiled .deb of a working patched kernel? I can't remember the last time I had to compile a kernel from source and my skills are a little rusty!

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •