Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: poor performance of nvidia driver

  1. #11
    Join Date
    Nov 2012
    Location
    France
    Beans
    112
    Distro
    Xubuntu 14.10 Utopic Unicorn

    Re: poor performance of nvidia driver

    Quote Originally Posted by Chogan View Post
    How can i find if my graphic card of my laptop supports hardware acceleration or not?
    Any graphics card does...
    Anyway, use the proprietary driver if you want performance and OpenGL support of latest versions (3.3.0 or 4.3.0 depending on your hardware).
    Or, use the open source driver which respects standards more, but is much slower and uses more electricity.

    If you want better game performance you can try using Xfce instead of Unity, and disable the desktop effects.
    Code:
    sudo apt-get install xubuntu-desktop
    tip: if you want to buy a computer sooner or later, buy a desktop. They are much faster and last longer (less risks of overheat).

  2. #12
    Join Date
    Nov 2013
    Beans
    1

    Re: poor performance of nvidia driver

    Hi,

    I've been using Ubuntu for a couple of years on a PC that is not "the last state of the art" machine (aprox. +3y old). Since the Unity first appeared I've had problems with graphics rendering which resulted in a slow (and occasionally unresponsive) 3D GUI (switching to Unity 2D made things a lot better). My config is the following:

    MSI K9N6PGM2-V2 MBO
    AMD Athlon II X2 240 @ 2.8GHz
    2 GB TakeMS DDR2 @ 800MHz
    500GB Western Digital WD500AAKS HD
    NVidia Geforce 6150SE nForce 430

    I've tried instaling various NVidia drivers (via Ubuntu's drivers repo and manually from NVidia website), changing graphic settings and a lot of similar experiments but nothing helped - 3D Unity was simply slow and lagging. As you can see, my graphic card isn't something to be proud of, so the whole thing didn't actually bother me much (you can't race a F1 in a minicar with 60hp ).

    So, I've been using Unity 2D since a couple weeks ago, when I decided to give this issue a "one last try" to fix. I managed to get a fully functional 3D Unity (without the lags, slowness, etc.) by changing this feature in my BIOS: "VGA Share Memory". Since my graphic card is integrated on my MBO, earlier I configured it to use the max. shared memory available (256MB). When I reduced it to the minimum (32MB) the whole thing blossomed - Unity appeared to be fast and responsive. I've tried it with NVidia 173 drivers available via Ubuntu repos and with drivers that I downloaded directly from NVidia (v173.14.36), which I'm using right now, and everything looks ok ..

    Now, why is this option (obviously) important and why did it bring so much performance upgrade - beats me (I can't think of any tehnically "legal" answer, hopefully someone will eventually come up with some explanation) ..

    Anyway, I tought it was worth mentioning, maybe this'll be useful to someone ..

  3. #13
    Join Date
    Jul 2014
    Beans
    1

    Re: poor performance of nvidia driver

    Thanks have the same mobo and cpu thought all was lost till i read this!!

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •