Page 5 of 5 FirstFirst ... 345
Results 41 to 44 of 44

Thread: Configuring Samba

  1. #41
    Join Date
    Dec 2012
    Beans
    38

    Re: Configuring Samba

    If you had done the steps then this line is in fstab:
    Quote:
    UUID=2006fbe6-1993-4c74-b7d5-80197cafbdb0 /media/Data ext4 defaults,noatime 0 2
    Correct Checked

    And this is your share definition in /etc/samba/smb.conf:
    Quote:
    [share]
    comment = Big Drive
    path = /media/Data
    read only = No
    create mask = 0755
    guest ok = Yes
    [1]

    Correct Checked

    You have either run the "sudo mount -a" and "sudo service smbd restart " commands or in your case rebooted the box.
    Correct Checked
    There should be no /media/joe/1.2TB it's now /media/Data - See above. You either didn't do the steps above, didn't restart the services, or didn't reboot your box.
    Correct Checked
    Whether or not you or the samba client guest can actually write to the mounted partition is entirely dependant of what the Linux permissions are on the mounted partition. You can find that out by running the following command:
    Code:
    ls -dl /media/Data
    After entering the above code into terminal , I get the following output :
    drwxr-xr-x 3 joe root 4096 Jan 16 23:18 /media/Data

    Which means nothing to me unfortunately , apart from that I am the owner

    The screenshot shows you trying to share the partition using the sharing tab - you no longer have to do that it's already shared in smb.conf.
    This is odd , it seems the GUI doesn’t talk to samba , as the GUI simply doesn't allow me to change the permissions. More importantly however I am the owner

  2. #42
    Join Date
    Dec 2012
    Beans
    38

    Re: Configuring Samba

    Morbius - Thanks very much

    I am now able to network my Windows pc to my ubuntu pc , now I just need to get around the permissions issue , I can share my files and folders but cannot create folders or manipulate my ubuntu server from my windows PC . Ideally i'd like to save my windoze stuff onto my Ubuntu PC . However I get a permissions issue , which I do not mind entirely , however I cannot get past it as Im not even prompted for samba or Ubuntu security details

    How can I allow the Windows users to write and change folders on Ubuntu file server/desktop ? I would like users to use a password when doing so , for security measures


    Thanks

  3. #43
    Join Date
    Dec 2009
    Beans
    5,339

    Re: Configuring Samba

    This is your share definition:
    [share]
    comment = Big Drive
    path = /media/Data
    read only = No
    create mask = 0755
    guest ok = Yes
    These are the permissions:
    drwxr-xr-x 3 joe root 4096 Jan 16 23:18 /media/Data
    The last 3 characters ( r-x ) tell you what others ( which corresponds to a samba guest ) can do. They can read ( r ) and open the folder ( x ) but they cannot write ( - ).

    You have 2 options:

    [1] Change permissions on the target folder to allow others to write:
    Code:
    chmod 777 /media/Data
    [2] Change the share to make everyone on the network appear to be you - for that share anyway. This solves a number of permissions issues since all saved files will be owned by "joe":
    [share]
    comment = Big Drive
    path = /media/Data
    read only = No
    force user = joe
    guest ok = Yes
    Again, unfortunately every change to smb.conf requires a samba restart so your network will have a fit for a few minutes until you are able to connect again so be patient:
    Code:
    sudo service smbd restart

  4. #44
    Join Date
    Dec 2012
    Beans
    38

    Re: Configuring Samba

    I'm back , I eventually got the connection working, had been using it for allmost two months . However today for whatever reason I am unable to connect to my Ubuntu Desktop/Fileserver machine Any ideas?

Page 5 of 5 FirstFirst ... 345

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •