Results 1 to 3 of 3

Thread: Skype: No Audio & Jack won't start

  1. #1
    Join Date
    Dec 2012
    Beans
    1

    Skype: No Audio & Jack won't start

    Hi, I am new to Linux. I just upgraded my Ubuntu 12.10 setup to the Ubuntu-Studio version. Now I can't get Skype to work. Firefix audio works just fine, but Skype has absolutely no sound. It says when I try to do a Test Call it says "Problems with Audio-Playback".

    I think the problem lies with Jack. When I try to start it, I get this message:

    p, li { white-space: pre-wrap; } 12:31:06.845 Patchbay deactivated.
    12:31:06.848 Statistics reset.
    12:31:06.903 ALSA connection change.
    12:31:06.961 D-BUS: Service is available (org.jackaudio.service aka jackdbus).
    Cannot connect to server socket err = No such file or directory
    Cannot connect to server request channel
    jack server is not running or cannot be started
    12:31:06.969 ALSA connection graph change.
    (qjackctl.real:2902): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion `GTK_IS_WIDGET (widget)' failed
    (qjackctl.real:2902): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion `GTK_IS_WIDGET (widget)' failed
    (qjackctl.real:2902): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion `GTK_IS_WIDGET (widget)' failed
    (qjackctl.real:2902): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion `GTK_IS_WIDGET (widget)' failed
    12:31:08.691 D-BUS: JACK server could not be started. Sorry
    Cannot connect to server socket err = No such file or directory
    Cannot connect to server request channel
    jack server is not running or cannot be started
    (qjackctl.real:2902): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion `GTK_IS_WIDGET (widget)' failed
    (qjackctl.real:2902): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion `GTK_IS_WIDGET (widget)' failed
    Fri Dec 28 12:31:08 2012: Starting jack server...
    Fri Dec 28 12:31:08 2012: JACK server starting in realtime mode with priority 10
    Fri Dec 28 12:31:08 2012: control device hw:0
    Fri Dec 28 12:31:08 2012: control device hw:0
    Fri Dec 28 12:31:08 2012: Acquired audio card Audio0
    Fri Dec 28 12:31:08 2012: creating alsa driver ... hw:0|hw:0|1024|2|44100|0|0|nomon|swmeter|-|32bit
    Fri Dec 28 12:31:08 2012: control device hw:0
    Fri Dec 28 12:31:08 2012: ERROR: ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
    Fri Dec 28 12:31:08 2012: ERROR: Cannot initialize driver
    Fri Dec 28 12:31:08 2012: ERROR: JackServer::Open failed with -1
    Fri Dec 28 12:31:08 2012: ERROR: Failed to open server
    Fri Dec 28 12:31:09 2012: Saving settings to "/home/brian/.config/jack/conf.xml" ...
    12:31:12.219 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
    Cannot connect to server socket err = No such file or directory
    Cannot connect to server request channel
    jack server is not running or cannot be started
    (qjackctl.real:2902): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion `GTK_IS_WIDGET (widget)' failed
    (qjackctl.real:2902): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion `GTK_IS_WIDGET (widget)' failed
    Any help would be appreciated!

  2. #2
    Join Date
    Dec 2012
    Beans
    35

    Re: Skype: No Audio & Jack won't start

    I'm no expert with this stuff, but it looks like the server itself isn't being found by the GUI QjackCtl. I presume that this what you are using.

    In QjackCtl's setup dialogue (settings tab) there is an entry for server path, here's what mine looks like.

    Code:
    pasuspender --server=/usr/bin/jackd
    I'm using pasuspender here to suspend pulseaudio because I had them conflicting on a previous setup (11.10), you've probably got just the "/usr/bin/jackd" part. That file needs to exist and be accessible.

    What do you have set for server path?

  3. #3
    Join Date
    May 2012
    Beans
    64

    Re: Skype: No Audio & Jack won't start

    if a program is using the soundcard jack want be able to start,

    Also make sure your user is part of the audio group, i cant remember the commands but you should be able to find them by searching.

    When i installed ubuntu 12.10 i wasnt in the audio group and jack wouldnt start without root, also it wont start if say firefox is open or another web browser or other program that is using the sound card.

    I usually start jack first before any other program, once jack is started the pulse audio module should load and allow non jack aware programs to use sound through jack

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •