Page 1 of 11 123 ... LastLast
Results 1 to 10 of 109

Thread: No wireless after 12.10 installation

  1. #1
    Join Date
    Aug 2010
    Beans
    116
    Distro
    Ubuntu 13.10 Saucy Salamander

    Question No wireless after 12.10 installation

    Hey everybody,
    I just installed Ubuntu 12.10 on a toshiba satellite c850d that had Windows 8 pre-installed. For some reason there is no sign of the wireless in the top panel or in the network settings. I have been poking around but haven't found anything that works yet. Below is the output from lspci -nn | grep 0280. Any help would be great, Thanks.

    Code:
    colin@colin-Satellite-C850D:~$ lspci -nn | grep 0280
    02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:8723]

  2. #2
    Join Date
    Feb 2011
    Location
    /Earth/India/Patna
    Beans
    147
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: No wireless after 12.10 installation

    Hi colmeweb,
    Please look at the following similar thread
    http://ubuntuforums.org/showpost.php...50&postcount=6


    Regards,
    Abhinav

  3. #3
    ahallubuntu is offline Chocolate-Covered Ubuntu Beans
    Join Date
    Jul 2005
    Beans
    2,050

    Re: No wireless after 12.10 installation

    Your wireless card is a Realtek 8723.

    Check this out:

    http://askubuntu.com/questions/13963...not-recognized

  4. #4
    Join Date
    Aug 2010
    Beans
    116
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: No wireless after 12.10 installation

    Hey Abhinav I followed those steps but on the last one (sudo modprobe rtl8723e) I got

    Code:
    root@colin-Satellite-C850D:/home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012# sudo modprobe rtl8723e
    FATAL: Module rtl8723e not found.
    I tried it without the e and go the same response, any advice.

  5. #5
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,877
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: No wireless after 12.10 installation

    I believe in later versions of the driver it is renamed. Please try:
    Code:
    sudo modprobe rtl8723ae
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  6. #6
    Join Date
    Aug 2010
    Beans
    116
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: No wireless after 12.10 installation

    Nope rtl8723ae not the answer

    How long does this take? After I went through the sequence I tried to close the terminal and it said that it was still working. Also there is a # sign after the ~ that I haven't noticed before.
    Last edited by colmeweb; December 28th, 2012 at 02:00 AM.

  7. #7
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,877
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: No wireless after 12.10 installation

    How long does this take? After I went through the sequence I tried to close the terminal and it said that it was still working. Also there is a # sign after the ~ that I haven't noticed before.
    The little # means you are running as root. The terminal is complaining about closing because when you issued the command 'sudo su' you asked to run some commands as root, also known as super-user. The terminal wants to be sure you are done. You could and should tell it you are done with:
    Code:
    exit
    Then the terminal will close without complaint.
    Nope rtl8723ae not the answer
    Please go through the compile process again and see what module it builds at the end of 'make', like this:
    CC /home/chili/Desktop/Forum/compat-drivers-2012-12-04/drivers/net/wireless/rtlwifi/rtl8192c/rtl8192c-common.mod.o
    LD [M] /home/chili/Desktop/Forum/compat-drivers-2012-12-04/drivers/net/wireless/rtlwifi/rtl8192c/rtl8192c-common.ko
    CC /home/chili/Desktop/Forum/compat-drivers-2012-12-04/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.mod.o
    LD [M] /home/chili/Desktop/Forum/compat-drivers-2012-12-04/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko
    CC /home/chili/Desktop/Forum/compat-drivers-2012-12-04/drivers/net/wireless/rtlwifi/rtl8192cu/rtl8192cu.mod.o
    LD [M] /home/chili/Desktop/Forum/compat-drivers-2012-12-04/drivers/net/wireless/rtlwifi/rtl8192cu/rtl8192cu.ko
    CC /home/chili/Desktop/Forum/compat-drivers-2012-12-04/drivers/net/wireless/rtlwifi/rtl8192de/rtl8192de.mod.o
    LD [M] /home/chili/Desktop/Forum/compat-drivers-2012-12-04/drivers/net/wireless/rtlwifi/rtl8192de/rtl8192de.ko
    CC /home/chili/Desktop/Forum/compat-drivers-2012-12-04/drivers/net/wireless/rtlwifi/rtl8192se/rtl8192se.mod.o
    LD [M] /home/chili/Desktop/Forum/compat-drivers-2012-12-04/drivers/net/wireless/rtlwifi/rtl8192se/rtl8192se.ko
    CC /home/chili/Desktop/Forum/compat-drivers-2012-12-04/drivers/net/wireless/rtlwifi/rtl8723ae/rtl8723ae.mod.o
    LD [M] /home/chili/Desktop/Forum/compat-drivers-2012-12-04/drivers/net/wireless/rtlwifi/rtl8723ae/rtl8723ae.ko
    CC /home/chili/Desktop/Forum/compat-drivers-2012-12-04/drivers/net/wireless/rtlwifi/rtlwifi.mod.o
    LD [M] /home/chili/Desktop/Forum/compat-drivers-2012-12-04/drivers/net/wireless/rtlwifi/rtlwifi.ko
    CC /home/chili/Desktop/Forum/compat-drivers-2012-12-04/net/mac80211/mac80211.mod.o
    LD [M] /home/chili/Desktop/Forum/compat-drivers-2012-12-04/net/mac80211/mac80211.ko
    CC /home/chili/Desktop/Forum/compat-drivers-2012-12-04/net/rfkill/rfkill-regulator.mod.o
    LD [M] /home/chili/Desktop/Forum/compat-drivers-2012-12-04/net/rfkill/rfkill-regulator.ko
    CC /home/chili/Desktop/Forum/compat-drivers-2012-12-04/net/wireless/cfg80211.mod.o
    LD [M] /home/chili/Desktop/Forum/compat-drivers-2012-12-04/net/wireless/cfg80211.ko
    make[1]: Leaving directory `/usr/src/linux-headers-3.5.0-21-generic'
    It will be rtl87-something-.ko. Modprobe the module without the .ko extension. If 'make' ended in an error, the module never actually got built. Post the error(s) here and we'll troubleshoot.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  8. #8
    Join Date
    Aug 2010
    Beans
    116
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: No wireless after 12.10 installation

    Ah, I think I found the problem.

    Code:
    root@Satellite-C850D:/home/colin# cd rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012
    root@Satellite-C850D:/home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012# make
    make -C /lib/modules/3.5.0-21-generic/build M=/home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012 modules
    make[1]: Entering directory `/usr/src/linux-headers-3.5.0-21-generic'
      CC [M]  /home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.o
    /home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c: In function ‘_rtl_init_mac80211’:
    /home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:320:6: error: ‘IEEE80211_HW_BEACON_FILTER’ undeclared (first use in this function)
    /home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:320:6: note: each undeclared identifier is reported only once for each function it appears in
    make[2]: *** [/home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.o] Error 1
    make[1]: *** [_module_/home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-3.5.0-21-generic'
    make: *** [all] Error 2
    root@Satellite-C850D:/home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012# sudo make install
    make -C /lib/modules/3.5.0-21-generic/build M=/home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012 modules
    make[1]: Entering directory `/usr/src/linux-headers-3.5.0-21-generic'
      CC [M]  /home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.o
    /home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c: In function ‘_rtl_init_mac80211’:
    /home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:320:6: error: ‘IEEE80211_HW_BEACON_FILTER’ undeclared (first use in this function)
    /home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:320:6: note: each undeclared identifier is reported only once for each function it appears in
    make[2]: *** [/home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.o] Error 1
    make[1]: *** [_module_/home/colin/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-3.5.0-21-generic'
    make: *** [all] Error 2
    Not sure what is causing this. Could it be because it is the second attempt?
    I stopped before the sudo make install step.

  9. #9
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,877
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: No wireless after 12.10 installation

    Could it be because it is the second attempt?
    Nope.
    Not sure what is causing this.
    This is the problem:
    base.c:320:6: error: ‘IEEE80211_HW_BEACON_FILTER’ undeclared (first use in this function)
    I suggest you try this package instead: http://www.kernel.org/pub/linux/kern...2-12-04.tar.gz

    Let me hear from you if you get stuck.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #10
    Join Date
    Aug 2010
    Beans
    116
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: No wireless after 12.10 installation

    Yeah, I've never installed drivers from a tar. Could you give me a walk through?

Page 1 of 11 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •