Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 'Strange' message at end of using terminal

  1. #1
    Join Date
    Apr 2012
    Beans
    203

    'Strange' message at end of using terminal

    Hi!

    Whenever I install something through the terminal, once it is has completed this message appears
    Code:
    Error: "/var/tmp/kdecache-km" is owned by uid 1000 instead of uid 0.
    kbuildsycoca4(7694) KConfigGroup::readXdgListEntry: List entry text/html in "/home/km/.local/share/applications/mimeapps.list" is not compliant with XDG standard (missing trailing semicolon).
    It doesn't seem to affect anything I am installing, but am curious as to what it is.

    Thanks.

    K.m
    - In the Service of General Cuckoo -

  2. #2
    Join Date
    Oct 2007
    Beans
    1,813

    Re: 'Strange' message at end of using terminal

    Hard to say, since you don't put your input, but only your output. But probably you're doing a sudo konsole or something. Open your terminal normally, and then sudo the app, such as apt-get or whatever.

    In any case, you can probably ignore it.

  3. #3
    Join Date
    Apr 2012
    Beans
    203

    Re: 'Strange' message at end of using terminal

    Code:
    sudo apt-get install 
    sudo apt-get purge
    sudo aptitude
    sudo apt-get update
    sudo apt-get upgrade
    For now I've only noticed it with them commands. Once the terminal finishes updating/installing/etc.. the message appears.
    - In the Service of General Cuckoo -

  4. #4
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    9,098
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: 'Strange' message at end of using terminal

    kabukiM0n0; Hi !

    What results if you edit in that semi-colon in the referenced file ?
    And, I would take a look at the file permissions for the file :
    /var/tmp/kdecache-km
    maybe investigate why that file expects uid 0 to have access.
    hth <== BDQ

  5. #5
    Join Date
    Apr 2012
    Beans
    203

    Re: 'Strange' message at end of using terminal

    Is there a command see the file permissions?

    No idea what happens if I do add the semicolon - I don't know how to do it.
    - In the Service of General Cuckoo -

  6. #6
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    9,098
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: 'Strange' message at end of using terminal

    kabukiM0n0;

    To see the file permissions list the file with the "long" option:
    Code:
    ls -l /var/tmp/kdecache-km
    Probably pay to look at the permissions of the directories that hold the file too.
    This tutorial explains the concept:
    https://help.ubuntu.com/community/FilePermissions

    To look at and edit a file use the default editor gedit.
    First, though, make a back-up of the file - for whatever might happen.
    Code:
    cp /home/km/.local/share/applications/mimeapps.list  /home/km/.local/share/applications/mimeapps.list-bak
    Edit the file:
    Code:
     gedit  /home/km/.local/share/applications/mimeapps.list
    Looking to see that each line ends with the same character (a semicolon).
    clear(er) than mud ? <== BDQ
    Last edited by Bashing-om; January 6th, 2013 at 10:37 PM. Reason: I would have miss used "gksudo"(removed)

  7. #7
    iMac71 is offline Gee! These Aren't Roasted!
    Join Date
    Dec 2012
    Beans
    171

    Re: 'Strange' message at end of using terminal

    you might try to change the ownership of /var/tmp/kdecache-km by typing the following command in a Terminal window:
    Code:
    sudo chown 0 /var/tmp/kdecache-km

  8. #8
    Join Date
    Apr 2012
    Beans
    203

    Re: 'Strange' message at end of using terminal

    Quote Originally Posted by Bashing-om View Post
    kabukiM0n0;

    To see the file permissions list the file with the "long" option:
    Code:
    ls -l /var/tmp/kdecache-km
    Probably pay to look at the permissions of the directories that hold the file too.
    This tutorial explains the concept:
    https://help.ubuntu.com/community/FilePermissions

    To look at and edit a file use the default editor gedit.
    First, though, make a back-up of the file - for whatever might happen.
    Code:
    cp /home/km/.local/share/applications/mimeapps.list  /home/km/.local/share/applications/mimeapps.list-bak
    Edit the file:
    Code:
     gedit  /home/km/.local/share/applications/mimeapps.list
    Looking to see that each line ends with the same character (a semicolon).
    clear(er) than mud ? <== BDQ
    Code:
    km@km:~$ ls -l /var/tmp/kdecache-km
    total 588284
    drwx------ 3 km km     4096 Jan  5 05:10 akregator
    drwx------ 2 km km     4096 Jan  5 15:14 favicons
    drwx------ 2 km km     4096 Jan  5 07:53 help
    drwx------ 2 km km   151552 Jan  6 13:36 http
    -rw-rw-r-- 1 km km 10526816 Jan  7 11:40 icon-cache.kcache
    drwx------ 3 km km     4096 Jan  5 04:48 kio_help
    drwx------ 2 km km     4096 Jan  5 07:24 ksplashx
    -rw-rw-r-- 1 km km  1497069 Jan  7 01:19 ksycoca4
    -rw-rw-r-- 1 km km      504 Jan  7 01:19 ksycoca4stamp
    -rw------- 1 km km       48 Jan  5 03:59 Personal Calendarrc
    -rw------- 1 km km     2819 Jan  7 03:23 plasma-svgelements-DarkenCarbon
    -rw-rw-r-- 1 km km 84213856 Jan  5 16:19 plasma_theme_air-netbook.kcache
    -rw-rw-r-- 1 km km 84213856 Jan  7 11:40 plasma_theme_DarkenCarbon.kcache
    -rw-rw-r-- 1 km km 84213856 Jan  6 13:15 plasma_theme_Elegance.kcache
    -rw-rw-r-- 1 km km 84213856 Jan  6 13:11 plasma_theme_Ghost.kcache
    -rw-rw-r-- 1 km km 84213856 Jan  7 10:55 plasma_theme_internal-system-colors.kcache
    -rw-rw-r-- 1 km km 84213856 Jan  6 13:07 plasma_theme_oxygen.kcache
    -rw-rw-r-- 1 km km 84213856 Jan  6 13:15 plasma_theme_PerlaNegra.kcache
    drwx------ 4 km km     4096 Jan  5 05:38 plasma-wallpapers
    drwx------ 2 km km     4096 Jan  6 00:31 thumbs
    Quote Originally Posted by iMac71 View Post
    you might try to change the ownership of /var/tmp/kdecache-km by typing the following command in a Terminal window:
    Code:
    sudo chown 0 /var/tmp/kdecache-km
    Should the terminal answer in anyway?
    Code:
    km@km:~$ sudo chown 0 /var/tmp/kdecache-km
    [sudo] password for km: 
    km@km:~$
    - In the Service of General Cuckoo -

  9. #9
    Join Date
    May 2006
    Location
    Boston
    Beans
    1,909
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 'Strange' message at end of using terminal

    did you edite the file as suggested by Bashing-om by adding a ; at the end of the line?

    blog
    Donations BTC : 12FwoB7uAM5FnweykpR1AEEDVFaTLTYFkS
    DOUBLEPLUSGOOD!!

  10. #10
    iMac71 is offline Gee! These Aren't Roasted!
    Join Date
    Dec 2012
    Beans
    171

    Re: 'Strange' message at end of using terminal

    Quote Originally Posted by kabukiM0n0 View Post
    Should the terminal answer in anyway?
    Code:
    km@km:~$ sudo chown 0 /var/tmp/kdecache-km
    [sudo] password for km: 
    km@km:~$
    for a "verbose" output, modify the command as follows:
    Code:
    sudo chown -v 0 /var/tmp/kdecache-km

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •