Results 1 to 3 of 3

Thread: GnuPG impossible to use

  1. #1
    Join Date
    Oct 2006
    Location
    Belgrade, Serbia
    Beans
    22
    Distro
    Xubuntu 13.10 Saucy Salamander

    GnuPG impossible to use

    Hi guys, please try not to jump on my case on this one, tnx. I understand that the topic has been covered countless times, but bear with me if you would pls; also I can't ask for clarification in a old post, because of the wrath of the moderators (making indexing of old threads practically useless and no different than something like the Yahoo! questions, but never mind that ;) :))

    Ok, after generating and getting through the initial host of problems including Screwed up permissions on .gnupg folder - unable to fix with chown (and many more different scenarios, where other stuff happens), I get:

    Code:
    ~$ gpg --list-keys
    /home/kgbme/.gnupg/pubring.gpg
    ------------------------------
    pub   2048R/886DDD89 2009-09-04 [expires: 2016-08-28]
    uid                  deb.torproject.org archive signing key
    sub   2048R/219EC810 2009-09-04 [expires: 2014-08-29]
    
    pub   4096R/6DA04611 2012-12-25
    uid                  Vladimir Nostromov <kgbme@tormail.org>
    sub   4096R/10F3D8C8 2012-12-25
    Enigmail in Thunderbird says there's nothing and then after exporting my PUB key to file and importing it, it gives a cryptic message about the key 'not changed'. I am still left with nothing:





    Then there is gpa. Installed and when loading with my user, it either crashes and/or displays a couple of usually different errors. It can be run as root, but then it will just use the different .gnupg folder.

    Also, now there is:

    Code:
    ~$ whereis gpg
    gpg: /usr/bin/gpg /usr/bin/X11/gpg /usr/share/man/man1/gpg.1.gz
    kgbme@kgbme-MS-7750:~$ whereis gpg2
    gpg2: /usr/bin/gpg2 /usr/bin/X11/gpg2 /usr/share/man/man1/gpg2.1.gz
    && for sure I would prefer to use the 2.x version, but that's a whole different issue that's also impossible to manage between the OS and programs.

    Just once, I was actually able to get everything to read and then a messenger program Psi+ couldn't manage with the keys, even though Enigmail was working (seems like it happened in a different life, if you get what I mean; wiped the system clean to try again (and again) to make sure whatever errors aren't due to something that had been done before - which I know shouldn't even matter, but anyway).

    So for a relative Xubuntu noob like me, the situation is hopeless. I hope you can understand my angle - I am NOT posting for the hell of it - just trying to make *some* sense of the whole deal and learn how to manage this. So far, I'm just wasting days of time - at a time - and now I'm wasting yours. If there's any advice, or whatever you can think of, pls just post it, tnx. Err., that would be: constructive advice.

    Code:
    ~$ lsb_release -a
    No LSB modules are available.
    Distributor ID:	Ubuntu
    Description:	Ubuntu 12.10
    Release:	12.10
    Codename:	quantal
    PS. I am totally clueless, as to what the procedure would be and what I should be doing to get any kind of GnuPG functionality as you can probably tell. It's not just this particular example posted in my thread, it's the whole deal. I went through *all* of the URLs available online, on the forums and on the Ubuntu site(s) a good number of times. Grasping @ straws here, thanks for reading and pls help unless you think I should just unplug my PC from the wall (which I wouldn't blame you).

    Edit: If I use Enigmail to generate the keypair, the OS can't see it and vice-versa (Enigmail detects gpg and using gpg-agent for passphrases from options) . I suppose they are kept separate and I should just forget about it and use Enigmail for mail and gpg from terminal for whatever.. but it's just not making (much) sense to me at all. :f

    PPS. Never mind, lock it, delete it pls... I'll have to figure this out, tnx.
    Last edited by ka55o5; December 25th, 2012 at 09:50 PM. Reason: Added some Enigmail info
    Z68A-G43 (G3) - i7-3770 - Vengeance 2x4GB 2133MHz - GTX 650 Gainward - WD 1TB 64MB SATA - Win7 Pro/64 SP1 / Saucy Xfce AMD64

  2. #2
    Join Date
    Jun 2012
    Beans
    301

    Re: GnuPG impossible to use

    you probably have a pointer set wrong in there someplace

    check with the enigmail-users@enigmail.net

  3. #3
    Join Date
    Mar 2013
    Beans
    1

    Re: GnuPG impossible to use

    It's not just this particular example posted in my thread, it's the whole deal.
    ...lot's of problems noted. assume this is standard install of xubuntu, thunderbird, gpg (version 1 and 2), and enigmail. and the problem to fix is enigmail. if you've moved conf

    you indicate you've both gpg version 1 and 2 installed; and gpa. gpa (I think) default install is gpg version 2.

    gpg --keys and I assume gpa indicate keys and key rings in the default ~/.gnupg which would indicate your permission problem is fixed. make sure your enigmail is pointing at the desired key rings.

    • in thunderbird: openpgp>preferences>advanced check 'additional parameters' includes '--homedir ~/.gnupg/' . if it's blank, possibly your default enigmail path to keys is wrong.


    enigmail errors like "bad passphrase" may occur if the gpg2 is installed and enigmail is configured for gpg (version 1). fix by pointing enigmail explicitly to version 2 (gpg2).

    • in thunderbird: openpgp>preferences>basic>files and directories, check 'override with' and enter /usr/bin/gpg2' or browse to '/usr/bin/' select 'gpg2'

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •