Results 1 to 8 of 8

Thread: Eclipse: "Launch failed. Binary not found"

  1. #1
    Join Date
    Nov 2008
    Beans
    1

    Eclipse: "Launch failed. Binary not found"

    I am using Eclipse Ganymede. I am at the moment using it for development in C++ applications using Opengl. (Using this as apposed to other compilers because eclipse is very easy and small to transport on a pen drive). And i was half way through developing a program when I went to test it and go this error:

    "Launch failed. Binary not found."

    Now please do not say "Change the path of the MinGW compiler it doesn't like '/'s," because it was working until a random point in the development. I can get a new C++ project to work so I am a bit perplexed as how come it was working then suddenly stopped. Does anyone know what could be the cause of this problem?

    Cheers
    ~Qwertyuiop

  2. #2
    Join Date
    Jan 2009
    Beans
    1

    Wink Re: Eclipse: "Launch failed. Binary not found"

    I just had the same problem after installing Eclipse in Ubuntu. In fact, I installed Ubuntu and Eclipse together today (first time in my life) on my machine- Intel Xeon EMT64.

    I was disappointed after I saw the error message.
    "Launch failed Binary not found"

    However, I found a solution by installing g++ "compiler" which was not installed originally.

    Some website gave me a hint to install g++ by below command

    sudo apt-get install g++

    I hope this also solves your problem !

    -Brandon

  3. #3
    Join Date
    Sep 2009
    Beans
    1

    Re: Eclipse: "Launch failed. Binary not found"

    omg !! It really works. thx

  4. #4
    Join Date
    Jun 2010
    Location
    Montreal, Qc, Canada
    Beans
    1
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Eclipse: "Launch failed. Binary not found"

    I just tried it, and it helped me also! thanks a lot! ))

  5. #5
    Join Date
    Aug 2010
    Beans
    39

    Re: Eclipse: "Launch failed. Binary not found"

    Quote Originally Posted by fuabrandon View Post
    sudo apt-get install g++

    -Brandon
    one line, fixed all of my problems. THANK YOU!!!

  6. #6
    Join Date
    May 2009
    Location
    India
    Beans
    62
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Eclipse: "Launch failed. Binary not found"

    Quote Originally Posted by fuabrandon View Post
    Some website gave me a hint to install g++ by below command

    sudo apt-get install g++

    I hope this also solves your problem!
    And until now, I thought it was installed by the IDE itself (which now seems very unlikely on any IDE- stupid me!!)

    You're a savior! It works now.

  7. #7
    Join Date
    Dec 2012
    Beans
    6

    Re: Eclipse: "Launch failed. Binary not found"

    Quote Originally Posted by fuabrandon View Post
    I just had the same problem after installing Eclipse in Ubuntu. In fact, I installed Ubuntu and Eclipse together today (first time in my life) on my machine- Intel Xeon EMT64.

    I was disappointed after I saw the error message.
    "Launch failed Binary not found"

    However, I found a solution by installing g++ "compiler" which was not installed originally.

    Some website gave me a hint to install g++ by below command

    sudo apt-get install g++

    I hope this also solves your problem !

    -Brandon

    I also found error in "Launch failed Binary not found". So, as your experience, I type sudo apt-get install g++, it saids it has already installed. But, the error still occur. How to solve it. I use Ubuntu 12.10 with Eclipse Juno. Please kindly share some advice. Thanks in advance.

  8. #8
    Join Date
    Oct 2006
    Location
    U.K
    Beans
    41,380
    Distro
    Ubuntu Development Release

    Re: Eclipse: "Launch failed. Binary not found"

    Old thread closed.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •