Results 1 to 6 of 6

Thread: How do I disable "double click with touchpad" in Lubuntu 12.10

  1. #1
    Join Date
    Oct 2012
    Beans
    14

    How do I disable "double click with touchpad" in Lubuntu 12.10

    Is it possible to disable the "double click with touchpad facility", and also is it possible to disable the touchpad whilst typing in Lubuntu 12.10?
    Last edited by Delricko; December 23rd, 2012 at 07:08 PM. Reason: readability

  2. #2
    Join Date
    Feb 2009
    Location
    Sierra Vista, AZ
    Beans
    1,676
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: How do I disable "double click with touchpad" in Lubuntu 12.10

    I think what you are looking for can be found here:
    https://help.ubuntu.com/community/Lu...d_while_typing
    Rex
    ASUS EeePC 1000h with Lubuntu 14.04 and Lubuntu 15.04
    Dell Inspiron 1000 with Lubuntu 14.04

  3. #3
    Join Date
    Oct 2012
    Beans
    14

    Re: How do I disable "double click with touchpad" in Lubuntu 12.10

    Quote Originally Posted by Rex Bouwense View Post
    I think what you are looking for can be found here:
    https://help.ubuntu.com/community/Lu...d_while_typing

    Thanks for your reply.
    It seems that the feature that I most wish to do away with is "TapAndDragGesture". The instruction page that you directed me to in this respect is very helpful, but it seems that the best that I can manage is to turn the feature off for the current session only. After restart it's back on again.

  4. #4
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How do I disable "double click with touchpad" in Lubuntu 12.10

    Hi ,
    below is an example to disable TabButton .. if this is what you mean.. with "double click" , I'm not sure if I understood correctly.
    you can try from terminal ..
    Code:
    synclient
    read the list and locate the TapButton entries..
    for example
    Code:
    TapButton1=1
    means that is enabled..
    turn off the TapButton , with the command below
    Code:
    synclient TapButton1=0
    see if is ok , maybe it needs to turn off all the TapButton entries.. e.g :
    Code:
    synclient TapButton2=0
    synclient TapButton3=0
    depends , see which is 1 (enabled) and set it to 0 (disabled).

    Now when you find the correct command , that serves your needs , add it to startup with the command below ( I assume TapButton1=0 is the correct)

    Code:
    echo '@synclient TapButton1=0' | sudo tee -a /etc/xdg/lxsession/Lubuntu/autostart
    About the while typing ..
    Try syndaemon
    e.g
    Code:
    syndaemon -i 2 -d
    will disable touchpad while typing and will re-eanble it after 2 seconds after finish the typing.
    See
    Code:
    man syndaemon
    for more info.
    Add the command that serve your needs to startup , with the same procedure as above (for TapButton).

    Thank you.
    Last edited by NikTh; December 24th, 2012 at 12:51 AM.

  5. #5
    Join Date
    Oct 2012
    Beans
    14

    Re: How do I disable "double click with touchpad" in Lubuntu 12.10

    Quote Originally Posted by NikTh View Post
    Hi ,
    below is an example to disable TabButton .. if this is what you mean.. with "double click" , I'm not sure if I understood correctly......
    Thanks for your reply. "Double click" is an expression that I gleaned from a different operating system. I now realise that TapAndDrag was the facility that I wished to disable. Yours and Rex B's advice have helped me to do so.
    Thanks for that.

    However, the "disable the touchpad whilst typing" matter has been a disaster. I now find that the touchpad is permanently disabled after I type no more than a couple of characters. As a consequence I'm having to send this message from a different operating system.
    Any advice that you may offer will be much appreciated.

  6. #6
    Join Date
    Oct 2012
    Beans
    14

    Re: How do I disable "double click with touchpad" in Lubuntu 12.10

    Further to my most recent post I am pleased to report that I have now resolved the disabled touchpad problem by editing the /etc/xdg/lxsession/Lubuntu/autostart file from a USB based operating system.
    This looks like success.

    I'll mark this item as "Solved" if all works well for the next day or two.

    In the meantime I offer my thanks once more to Nik Th and Rex B for your help,
    and send seasons greetings to all readers of this thread.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •