Results 1 to 10 of 10

Thread: Insprion 14z - UEFI boot hangs at purple screen if NIC activated

  1. #1
    Join Date
    Apr 2006
    Beans
    21

    Insprion 14z - UEFI boot hangs at purple screen if NIC activated

    Here's my weird problem, with a UEFI Ubuntu 12.10 64 bits installation on an Inspiron 14z ultrabook with an integrated Atheros AR8162 ethernet card (NIC).

    If the AR8162 card is enabled in BIOS, Ubuntu won't load, as it will hang in a blank purple screen or, in recovery mode, at "loading initial ramdisk". If the AR8162 card is disabled, it will boot just fine. The problem is that I need an ethernet connection...

    What is strange is that I'm able to boot Ubuntu in legacy mode with the AR8162 enabled in BIOS and this card is working just fine with the alx module available in compat-wireless package (see: http://askubuntu.com/questions/15722.../231715#231715). The only thing is that I want to keep dual booting with Win8, so UEFI Grub installation is mandatory.

    Any idea someone on how to boot Ubuntu 12.10 in UEFI mode, with a working AR8162 card?

    Thanks.
    Last edited by mlaverdiere; December 23rd, 2012 at 06:59 PM.

  2. #2
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Insprion 14z - UEFI boot hangs at purple screen if NIC activated

    Oldfred on vacation. Back Sept 9. Will not have much if any Internet access.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  3. #3
    Join Date
    Apr 2006
    Beans
    21

    Re: Insprion 14z - UEFI boot hangs at purple screen if NIC activated

    Thanks oldfred, but the problem is not that I can't make the AR8162 work (again, it works pretty well with alx module when I boot in BIOS legacy mode). The problem is that I have to disable the card in BIOS if I want to boot in UEFI mode.

    I'm just wondering if there could be a Kernel boot parameter that I could use to tell the kernel not to probe for this card and/or not to activate it, as I may be able, if the boot completes successfully, to activate it later, just by modprobing the alx module...

  4. #4
    Join Date
    Apr 2006
    Beans
    21

    Re: Insprion 14z - UEFI boot hangs at purple screen if NIC activated

    Bump!

  5. #5
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Insprion 14z - UEFI boot hangs at purple screen if NIC activated

    Are there any settings in UEFI menu?

    I think both BIOS or UEFI write some info in RAM or drive for system to use when booting. Is it then UEFI not writing the correct or same info or Ubuntu cannot find it as it is somehow a bit different? Seems like a bug somewhere?

    Do you get the same info from these from both systems or is there some subtle differenece?

    lspci -v
    dmesg | grep eth
    # Plug in Ethernet cable and see if errors:
    dmesg | tail -n10
    # Check by chipset:ie e1000e
    sudo lsmod | grep e1000e
    Oldfred on vacation. Back Sept 9. Will not have much if any Internet access.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  6. #6
    Join Date
    Dec 2012
    Beans
    14

    Re: Insprion 14z - UEFI boot hangs at purple screen if NIC activated

    Try updating bios, dell doesn't always ship with latest version for some reason.

  7. #7
    Join Date
    Jul 2008
    Beans
    6

    Re: Insprion 14z - UEFI boot hangs at purple screen if NIC activated

    Any news on this issue?
    I have the last bios version (from 2 days ago), and this problem is still present.

    There's bug https://bugs.launchpad.net/ubuntu/+s...2/+bug/1093472 , but no hint to a possible solution (besides disabling secure boot) until now.

  8. #8
    Join Date
    Jul 2008
    Beans
    6

    Re: Insprion 14z - UEFI boot hangs at purple screen if NIC activated

    Sorry. Double post. I don't know how to delete it.
    Last edited by rktesser; May 8th, 2013 at 09:45 PM. Reason: Double post.

  9. #9
    Join Date
    Feb 2014
    Beans
    2

    Re: Insprion 14z - UEFI boot hangs at purple screen if NIC activated

    Hi, I have the same problem.


    I have an Inspiron 14z with windows 8 pre installed. I installed ubuntu 13.10, but I have to run it in the bios disabled the network card.


    Ahola, I have the same problem.


    I have an Inspiron 14z with windows 8 pre installed. I installed ubuntu 13.10, but I have to run it in the bios disabled the network card.


    Someone find the solution to this problem?

  10. #10
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Insprion 14z - UEFI boot hangs at purple screen if NIC activated

    This applies to many versions of Dell's not just precision models.
    Ubuntu on the Precision M3800 or XPS15 Nov 2013
    http://en.community.dell.com/techcen...ion-m3800.aspx
    https://wiki.ubuntu.com/HardwareSupp...s/Dell/XPS/15z


    Dell 14z & 17r with Intel SRT
    http://ubuntuforums.org/showthread.php?t=2038121

    Dell 14z used Dell Recovery and Refind
    http://ubuntuforums.org/showthread.php?t=2125397
    http://ubuntuforums.org/showthread.php?t=2179297
    Oldfred on vacation. Back Sept 9. Will not have much if any Internet access.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •