Results 1 to 9 of 9

Thread: Odd touchpad problem

  1. #1
    Join Date
    Dec 2012
    Beans
    6

    Odd touchpad problem

    Running Ubuntu 12.04 LTS
    ASUS netbook acquired in ~March 2010

    My touchpad doesn't work in my main administrator profile. It works in guest mode, it works in another account, and I created a new profile to see if it worked there (it does), it's just this one profile. A USB mouse works fine in the profile in question, just not the touchpad, which stopped working yesterday in the middle of using firefox.

  2. #2
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Odd touchpad problem

    Try this at a terminal window:

    Code:
    sudo modprobe -r psmouse
    sudo modprobe psmouse proto=imps

  3. #3
    Join Date
    Dec 2012
    Beans
    6

    Re: Odd touchpad problem

    That did it! Thanks! What happened there? Any way I can avoid this in the future?

  4. #4
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Odd touchpad problem

    There's a bug report that reports this:

    Touchpad stops working after login
    Ubuntu “xserver-xorg-input-synaptics” package Bugs Bug #549727


    One thing I forget to told you in my previous post is that to make it permanent include the last line of the code in /etc/modprobe.d/options

  5. #5
    Join Date
    Dec 2012
    Beans
    6

    Re: Odd touchpad problem

    I'm not seeing any files called "options" in /etc/modprobe.d/. Should I create one?

  6. #6
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Odd touchpad problem

    Apparently, that file has been judged obsolete and been removed. There's probably a file which does the same.

    I'm attaching an .sh file, and I changed 'sudo' to 'gksudo' so you'll get a graphical interface question for the root password instead of a commandline version. You can download it in your /home directory, and make it run every boot by going to System -> Preferences -> Startup Applications and click on 'Add'. Type anything in the name section, and type this command in the command section:
    Code:
    sh ~/workaround.sh
    I don't know whether this works though. I don't have this bug, so I can't test it... And again, I'm reporting to the workaround for the bug, in Launchpad, mentioned in my previous post.
    Attached Files Attached Files

  7. #7
    Join Date
    Dec 2012
    Beans
    6

    Re: Odd touchpad problem

    Thanks, I have since shut down the computer and rebooted it and run into the problem again, using the same fix you mentioned above. I'll let you know if this works next time I shut down and start up again.

  8. #8
    Join Date
    Dec 2012
    Beans
    6

    Re: Odd touchpad problem

    Doesn't seem to be working, oh well. The command line fix still works.

  9. #9
    Join Date
    Dec 2012
    Beans
    6

    Re: Odd touchpad problem

    Solved it!

    Found a fix on a Debian wiki that I figured I'd try, and it worked!

    Created file with the following command:

    options psmouse proto=imps

    (options instead of sudo)

    named it touchpad.conf and put it in /etc/modprobe.d/

    Just shut down and powered up the laptop again, touchpad worked great. Thanks again for your help!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •