Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Video bios not available - after install of NVIDIA drivers on 12.10

  1. #1
    Join Date
    May 2009
    Location
    In a house.
    Beans
    15
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Video bios not available - after install of NVIDIA drivers on 12.10

    Hello,

    I recently installed Ubuntu 12.10 (separately as an upgrade, and as a fresh install) and installed the NVIDIA proprietary drivers. I tried installing the drivers both from a download off nvidia.com, and through the "system settings" applet in the "additional drivers" tab. When I reboot the system, the standard BIOS POST tests occur as usual, and the screen goes blank and displays a message: xgifb: video bios not available. The system does not appear to boot any further after this. Has anyone seen this issue?

  2. #2
    Join Date
    May 2009
    Location
    In a house.
    Beans
    15
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Video bios not available - after install of NVIDIA drivers on 12.10

    Anyone?

    I'm still having trouble with this. There is some discussion about this issue on another thread I created about a different but related topic here: http://ubuntuforums.org/showthread.php?t=2105190

    Somewhat long story short: I am running Ubuntu 12.10, which came with the nouveau drivers. I attempted to install proprietary NVIDIA drivers from both "Additional Drivers" (I believe it's called Jockey?), and from nvidia.com for my two NVIDIA Quaddro NVS 290 cards. Regardless of which method I use to install, when I reboot, I get a "xgifb: video BIOS not available" error message right after grub loads and the OS will not boot at all.

    I can boot off a LiveCD, so I did that, chrooted into the installed OS, and made several attempts to disable nouveau and install the NVIDIA drivers manually. I can't seem to get rid of this error message.

    For now, I'm running off LiveCD, with a terminal opened and chrooted. Not the most ideal situation.

    Any ideas?

  3. #3
    Join Date
    Nov 2009
    Location
    Lake Wales Florida
    Beans
    607
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Video bios not available - after install of NVIDIA drivers on 12.10

    Quote Originally Posted by wshaffer79 View Post
    Anyone?

    I'm still having trouble with this. There is some discussion about this issue on another thread I created about a different but related topic here: http://ubuntuforums.org/showthread.php?t=2105190

    Somewhat long story short: I am running Ubuntu 12.10, which came with the nouveau drivers. I attempted to install proprietary NVIDIA drivers from both "Additional Drivers" (I believe it's called Jockey?), and from nvidia.com for my two NVIDIA Quaddro NVS 290 cards. Regardless of which method I use to install, when I reboot, I get a "xgifb: video BIOS not available" error message right after grub loads and the OS will not boot at all.

    I can boot off a LiveCD, so I did that, chrooted into the installed OS, and made several attempts to disable nouveau and install the NVIDIA drivers manually. I can't seem to get rid of this error message.

    For now, I'm running off LiveCD, with a terminal opened and chrooted. Not the most ideal situation.

    Any ideas?
    Read known bugs sticky under general help.
    AMD FX-6200 - MSI 4.1Ghz- Nvidia GTX550Ti -12/GIG - 60GB-SSD/500 Sata - 12.04 - Gnome 3

  4. #4
    Join Date
    Feb 2010
    Location
    Nr BrandsHatch, S'oaks UK
    Beans
    1,241
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: Video bios not available - after install of NVIDIA drivers on 12.10

    Hi!, Bobhuber,

    You Posted:
    Read known bugs sticky under general help.
    If you know of a relevant Post please give us a more detailed Link.

    I have just searched both the general help forum and the 'known bugs' thread and nothing of any use came up.

    @wschaffer79,

    Was : "xgifb: video bios not available." the whole of the error message ?? or did it indicate where the origin or backlist was?

    Edit: Does it make any difference if you press 'Shift' as the Bios Post test ends ??

    Chao!, bogan,
    Last edited by bogan; January 23rd, 2013 at 11:48 AM. Reason: query added
    "Better Solutions may bring Worsened Problems": After Lao Tse, b. circa 405BC. a contemporary of Confucius, who died circa 600BC.
    They did things differently in those days, apparently!!

  5. #5
    Join Date
    May 2009
    Location
    In a house.
    Beans
    15
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Video bios not available - after install of NVIDIA drivers on 12.10

    Read known bugs sticky under general help.
    That was helpful...

    bogan,

    The full error message is as follows:

    [ 9.613425] xgifb 0000:20:05.0: video BIOS not available

    Nothing else is displayed on the screen. The numbers in brackets at the beginning do change slightly at each reboot. At this point, the system is completely unresponsive to ctrl-alt-delete, ctrl-alt-F1, F2, F3.... anything.

    No need for 'SHIFT' because the grub boot menu displays automatically every time. The menu gives me the standard 'Ubuntu' option as well as 'advanced' with a choice of two kernels. Booting any of these selections results in the above error message.

    Out of curiousity, I rebooted with a LiveCD, chrooted to the installed OS, and uninstalled nouveau (sudo apt-get --purge remove xserver-xorg-video-nouveau) and rebooted. Still getting the above error.

  6. #6
    Join Date
    May 2009
    Location
    In a house.
    Beans
    15
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Video bios not available - after install of NVIDIA drivers on 12.10

    Bump. Anyone? I am wondering if this is an issue just related to Ubuntu, or if other distributions experience this as well. I had all four monitors working on this system on Ubuntu 11.x, but that version is no longer supported.

  7. #7
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Video bios not available - after install of NVIDIA drivers on 12.10

    Mixing installs often leads to issues, may be best to totally houseclean all nvidia and reinstall. I do not know if dual cards requires anything else or not. You may want the newest (experimental) version Ubuntu offers.

    http://ubuntuforums.org/showthread.php?t=2081649
    # You may need headers - meta package for current version:
    sudo apt-get install linux-headers-generic
    # only reason to purge is there are several versions, if you know you have different nVidia use that:
    #To see available versions:
    dpkg -l | grep -i nvidia*
    apt-cache search nvidia-sett*
    # I used nvidia-current-updates & nvidia-settings-updates, example below is just nvidia-current, use version you prefer
    sudo apt-get purge nvidia*
    sudo apt-get install nvidia-current
    sudo apt-get install nvidia-settings
    sudo dpkg-reconfigure nvidia-current
    sudo nvidia-xconfig
    sudo reboot

    If still issues run these to see if system is seeing your nVidia correctly.
    To see nVidia info:
    uname -ar
    lspci -nnk | grep -iA3 vga
    sudo apt-cache policy nvidia-current
    cat /sys/module/nvidia/version
    /usr/lib/nux/unity_support_test -p
    nvidia-settings --vv

    #To see video:
    sudo lshw -c display
    sudo lshw | grep -A 11 display
    lspci | grep VGA
    #Resolution:
    xwininfo -root
    Last edited by oldfred; January 31st, 2013 at 01:15 AM.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  8. #8
    Join Date
    Feb 2010
    Location
    Nr BrandsHatch, S'oaks UK
    Beans
    1,241
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: Video bios not available - after install of NVIDIA drivers on 12.10

    Hi!, oldfred,

    =1 for your comprehensive trouble-shooter list.

    A few minor points:
    (1)
    I have found that following nvidia driver problems that involve more than one version being installed, - especially if 'kernal mismatch' errors show, - it is better to run:
    Code:
    sudo apt-get remove --purge < nvidiadriverpackagename>
     # [ using the correct names] for each driver, before running: 
    sudo apt-get purge  nvidia*
    To ensure all old components are purged.

    This arose due to real bad trouble after using: nvidia-current 304.51-actually-304.43.

    The 304.43 components got left behind after purging 'nvidia*'.

    (2)
    Running 'xwinfo' gave me the following:
    Code:
    alan@alan-MS-7616:~$ xwinfo-root
    xwinfo-root: command not found
    alan@alan-MS-7616:~$ xwinfo -root
    No command 'xwinfo' found, did you mean:
     Command 'hwinfo' from package 'hwinfo' (universe)
     Command 'xvinfo' from package 'x11-utils' (main)
     Command 'xjinfo' from package 'xjadeo' (multiverse)
    xwinfo: command not found
    alan@alan-MS-7616:~$
    Edit: My error, - 'xwininfo -root', on the last line, gives:
    Code:
    "geometry 1920x1080=0+0"
    Chao!, bogan.
    "Better Solutions may bring Worsened Problems": After Lao Tse, b. circa 405BC. a contemporary of Confucius, who died circa 600BC.
    They did things differently in those days, apparently!!

  9. #9
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Video bios not available - after install of NVIDIA drivers on 12.10

    @bogan
    Thanks for the update.

    Over the years I have had more issues with nVidia's direct download and now just install the default from Ubuntu.
    Many, many versions ago I had to wait for nVidia to come up with a script to in-install its own version, so I stopped using any direct downloads. But now my video card is older and does not need all the bells & whistles of the very newest versions that some may need.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  10. #10
    Join Date
    Feb 2010
    Location
    Nr BrandsHatch, S'oaks UK
    Beans
    1,241
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: Video bios not available - after install of NVIDIA drivers on 12.10

    Hi!, oldfred,

    Strangely, my experience has been the exact reverse: almost no problems using nvidia,com downloads - apart from the bug-ridden 295.40, which also infected nvidia-current - other than having to reinstall it after most kernal updates, prior to 304.14.

    But lots of problems with nvidia-current, nvidia-updates & experimental-xxx, especially with low-res resolution after updates, and with those from x-swat ppa.

    Though I must admit there have been many fewer problems with any of those recently, apart from '304.51-actually-3.4.43', which was the worst of the lot.

    Edit: Moreover, that is the version currently offered by 12.10 Ubuntu Software Center, and, I believe, by Additional Drivers though it does not tell you what version it is until you install it,unless you run:
    apt-cache policy nvidia-current
    Chao!, bogan.
    Last edited by bogan; February 1st, 2013 at 07:09 PM. Reason: note added, spelling
    "Better Solutions may bring Worsened Problems": After Lao Tse, b. circa 405BC. a contemporary of Confucius, who died circa 600BC.
    They did things differently in those days, apparently!!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •