Results 1 to 5 of 5

Thread: How to setup debian/control to force updating a library?

  1. #1
    Join Date
    Jan 2008
    Location
    France
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Question How to setup debian/control to force updating a library?

    This question is aimed at PPA/packages maintainers.

    I have a PPA with 2 packages:

    • mypackage (currently version 1~ppa1~quantal)
    • mypackagelib (currently version 1~ppa1~quantal)


    Currently, the control file of mypackage has:

    Code:
    Depends: mypackagelib
    I want to update the 2 packages to version '2' (mypackage version 2 and mypackagelib version 2).

    How can I make sure that 'mypackagelib' will also be updated when the user updates 'mypackage' ?

    FYI, changing the 'Depends' field to:

    Code:
    Depends: mypackagelib (>= 2)
    does NOT work, and returns the following error:

    Code:
    mypackage : Depends: mypackagelib (>= 2) but mypackagelib-2~ppa1~quantal is to be installed


    Please see http://askubuntu.com/questions/22972...ting-a-library

  2. #2
    Join Date
    Jun 2007
    Beans
    13,014

    Re: How to setup debian/control to force updating a library?

    in the control file using
    Package: boot-repair
    Architecture: all
    Depends: boot-sav (>= ${binary:Version}),
    ${miscepends}
    ....ect
    seems to work fine (or Depends: boot-sav (= ${binary:Version}),

    Also don't know why not upping the version in /debian/changelog like
    3.198 or whatever
    Last edited by mc4man; December 17th, 2012 at 03:12 AM.

  3. #3
    Join Date
    Jan 2008
    Location
    France
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: How to setup debian/control to force updating a library?

    Thanks Mcman for having looked at this.

    The problem is the '~' of the ppa version.
    See http://askubuntu.com/questions/22972...ting-a-library

    Depends: boot-sav (>= ${binary:Version}) is a good workaround.

    [SOLVED]

  4. #4
    Join Date
    Nov 2005
    Location
    Bordeaux, France
    Beans
    11,297
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to setup debian/control to force updating a library?

    Just to clarify: the problem basically is that when comparing package verison numbers, X~Y is considered LOWER than X. This is why you get

    Code:
    mypackage : Depends: mypackagelib (>= 2) but mypackagelib-2~ppa1~quantal is to be installed
    because you want >= 2, but what you have is 2~something, which is < 2.
    「明後日の夕方には帰ってるからね。」


  5. #5
    Join Date
    Jun 2007
    Beans
    13,014

    Re: How to setup debian/control to force updating a library?

    Well good it's back - when i decide to set up my new laptop (lenovo 580y, win7, some interesting partitioning, hdd + a cache ssd) I figure I'll likely end up needing your app

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •