Results 1 to 10 of 10

Thread: Suspend only works once

  1. #1
    Join Date
    Feb 2006
    Beans
    59

    Suspend only works once

    Hi,

    I had this problem now since 10.10, and I was hoping it would go away in Natty, but it didn't.

    In short: Suspend only works once, the second attempt at a suspend results in the monitor going blank as it was entering suspend, but the computer still running, as evidenced by the hard drive and fans still running. The computer can then not be awaken anymore, only a hard reset and subsequent reboot returns the PC to working state.

    When I check for errors after the first suspend, I see the following errors in the log:
    Code:
    [ 8461.100062] ahci 0000:05:00.0: failed to stop engine (-5)
    [ 8461.600062] ahci 0000:05:00.0: failed to stop engine (-5)
    [ 8463.170076] ata9: failed to resume link (SControl FFFFFFFF)
    [ 8463.170109] ata10: failed to resume link (SControl FFFFFFFF)
    [ 8467.510109] ata9: failed to resume link (SControl FFFFFFFF)
    [ 8467.510163] ata10: failed to resume link (SControl FFFFFFFF)
    So it seems to me that it has something to do with AHCI. I searched for this error in the forum, but I could not find anything. I also tried various suggestions, such as using uswsusp and the hibernate scripts, and including ahci in the suspend module lust. But each of the result in the exact same behavior: First suspend works fine, second suspend fails and reset is necessary.

    My detailed HW information is attached to his post.

    In short, I got:
    - AMD Phenom II 965
    - GeForce GTX 460
    - GA-880GA-UD3H
    - 8 GB DDR RAM
    - SAMSUNG HD103SJ

    Thanks!
    Sascha
    Attached Files Attached Files

  2. #2
    Join Date
    Feb 2006
    Beans
    59

    Re: Suspend only works once

    FYI, I tried some more things to see if I can nail down the source of the problem. I turned of AHCI in the BIOS and set the controller to plain IDE mode. But that did not make any difference.

    I also tried to remove the Nvidia 3rd party driver and tried it just with the default driver. But with the default Ubuntu driver, the PC already fails to resume from the first suspend.

    So no progress really.

  3. #3
    Join Date
    Feb 2006
    Beans
    59

    Re: Suspend only works once

    Nobody has any ideas? Am I the only one with this problem, or do other people have it also, but just don't know what to do about it?

    Maybe I should open a bug report?

  4. #4
    Join Date
    Feb 2006
    Beans
    59

    Re: Suspend only works once


  5. #5
    Join Date
    Sep 2008
    Beans
    13
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Suspend only works once

    Have the same problem here...
    Suspend works only once, but Hibernate works fine.

    Ubuntu maverick
    Processor: AMD Athlon X2
    MB: Asus A8N-E

  6. #6
    Join Date
    Jul 2011
    Beans
    54

    Re: Suspend only works once

    Same problem.

  7. #7
    Join Date
    Oct 2009
    Location
    Rocky Mtns.
    Beans
    540
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Suspend only works once

    I posted some diagnostic commands to try at my post #21 here:

    http://ubuntuforums.org/showpost.php...3&postcount=21

    It would probably be best to split out the different graphics card manufacturers with Suspend problems onto different or new threads (I think I had the problem with the older NVIDIA 173 and 195? driver modules, and updating it to the newer NVIDIA 285.05.09 driver module seems to have fixed my suspend, I think).

    Of course, checking your Screen Saver and power settings and installed packages is a good idea too:

    Code:
     dpkg -l powe*
    dpkg -l acp*
    dpkg -l susp*
    dpkg -l hiber*

  8. #8
    Join Date
    Mar 2010
    Location
    USA
    Beans
    92
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Suspend only works once

    Precisely the same problem. Wish this could be fixed.

  9. #9
    Join Date
    Jan 2007
    Beans
    168

    Re: Suspend only works once

    Quote Originally Posted by gdea73 View Post
    Precisely the same problem. Wish this could be fixed.
    I worked around it disabling my ethernet. it was the device that was failing to suspend in my case. (you can disable the device in the bios*)

    Also, DO go to the bug reporter linked up in this thread and mark that the bug affects you! it's the least you can do


    * side not on my BIOS... i whish everyone at Asus involved in it's design to !*%&(@*#$&@(*#$&@^%@*(#&$@#&$(*@#&$(*@&$

    they call UEFI Legacy mode as simply:
    "CSM"
    ... which after searching the spec i learned stands for "Compatibility Support Module". and the help screen helpfully says "Enable CSM" with some 7 lines of unused space. ...did someone get paid to write those BIOS help messages?

    then instead of showing enable/disable for the onboard devices, they hid it into safeboot, and called it "locked/unlocked". I was pretty sure it was to restrict access to network booting like XPE or something. not to enable/disable the devices. of course, the help message said "lock or unlockd the device"... genius.

    man, those people are just a bunch of *&@*(@&(*@&#$(*@&#$ sadists!

  10. #10
    Join Date
    Mar 2013
    Beans
    1

    Re: Suspend only works once

    I solved this problem by adding kernel parametr to grub bootloader: acpi_sleep=old_ordering

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •