Page 1 of 8 123 ... LastLast
Results 1 to 10 of 74

Thread: Lenovo Ideapad Y500 LiveUSB Problem

  1. #1
    Join Date
    Dec 2012
    Beans
    5

    Lenovo Ideapad Y500 LiveUSB Problem

    I am trying to use the Ubuntu 12.10 Secure Remix to install Ubuntu on a Lenovo Ideapad Y500. My goal was to install a dual boot option alongside Windows 8. This was my first attempt at installing Ubuntu in a UEFI configuration.

    After creating the bootable USB stick, I disabled the Secure Boot option in the BIOS.

    I was able to boot from the USB stick and got the GRUB menu. Both the installation and boot w/o installation options resulted in a blank screen.

    During the next boot attempt I used the "e" option to edit the kernel boot parameters.

    Removing "quiet splash" and adding "text" I hoped to see text command line interface. Instead it seemed that the text output was compressed in the top 1/6th of the screen, rendering it unreadable.

    Unfortunately, without a command line interface I don't have many options. Anybody had similar results on a Lenovo Ideapad Y500?

  2. #2
    Join Date
    Dec 2012
    Beans
    8

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    I just recently set up Arch Linux in dual boot with Windows 8 on my y400 and installed using a CD.

    Being squeezed up in the top portion of the screen seemed to happen when I would choose to boot from the CD from the menu instead of automatically on reboot after moving the optical drive to the top of the boot order list in the BIOS.

    As for boot parameters, I had to add nomodeset or else the screen would freeze, although it would still boot up.

  3. #3
    Join Date
    Dec 2012
    Beans
    5

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    Quote Originally Posted by y400 View Post
    I just recently set up Arch Linux in dual boot with Windows 8 on my y400 and installed using a CD.

    Being squeezed up in the top portion of the screen seemed to happen when I would choose to boot from the CD from the menu instead of automatically on reboot after moving the optical drive to the top of the boot order list in the BIOS.

    As for boot parameters, I had to add nomodeset or else the screen would freeze, although it would still boot up.
    Thanks a lot for the feedback. Changing the boot order in the BIOS setup instead of the boot menu indeed restored the text mode. I don't think I would have made that connection, thank you.

    At least I can not experiment with display modes and try my luck. Did you have to through this or did the LiveCD / Live USB work for you right away?

    Additional info: When running the "nomodeset" kernel parameter the following error will appear:

    Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work.

    I am still researching, but not sure where to go from here, atm.
    Last edited by haspelbein; December 16th, 2012 at 01:29 PM.

  4. #4
    Join Date
    Dec 2012
    Beans
    8

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    With my Arch Linux install, it doesn't use a GUI and couldn't get X going until I installed the nvidia drivers. These laptops don't have Optimus so they only use the Nvidia GPU and don't access the integrated intel graphics. I'm thinking that would explain why you can get into Ubuntu's text mode but not to the GUI.

    You could try the boot parameter acpi=off but I'm thinking you'll probably have to do a non-GUI install.

  5. #5
    Join Date
    Dec 2012
    Beans
    5

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    Quote Originally Posted by y400 View Post
    With my Arch Linux install, it doesn't use a GUI and couldn't get X going until I installed the nvidia drivers. These laptops don't have Optimus so they only use the Nvidia GPU and don't access the integrated intel graphics. I'm thinking that would explain why you can get into Ubuntu's text mode but not to the GUI.

    You could try the boot parameter acpi=off but I'm thinking you'll probably have to do a non-GUI install.
    Yes, you may be right. I know that the Intel HD4000 is present, but it is not even visible as an option in the BIOS. So you are right, they are using the Nvidia by default. I think the problem is not so much that the Nvidia card is present, but that the Ubuntu install detects both GPUs. (I've been able to successfully install Ubuntu on Nvidia-only laptops in the past.)

    I haven't tried ArchLinux before, but I know that it is more of an expert Linux system. Yet the way things are, I may have to read up on text-based installs, as I don't see a work-around either.

    I will give acpi=off a try though, as one last effort.

    Thanks a lot for your feedback.

  6. #6
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    Some now older info on switchable graphics:
    http://ubuntuforums.org/showthread.php?t=1657660

    Optimus
    http://ubuntuforums.org/showthread.php?t=1657660
    Bumblebee:
    https://wiki.ubuntu.com/Bumblebee
    12.10 with bumblebee
    http://ubuntuforums.org/showthread.php?t=2077451
    NVIDIA Confirms It's Working On Optimus Linux Support - Aug 31, 2012
    http://www.phoronix.com/scan.php?pag...tem&px=MTE3MzY
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  7. #7
    Join Date
    Dec 2012
    Beans
    8

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    While the i7 does have the integrated intel graphics, it is disabled/bypassed on my y400 at least. I can only see the discrete Nvidia GT650M through lspci. I know there has been confusion about whether these laptops have Optimus or not and from what I can tell, there is no way to use or access the intel gpu.

    I'm not sure what options there are for installing Ubuntu outside of the GUI so I can't help you there. I hope this isn't frowned upon and feel free to mod edit if so, but if Ubuntu isn't feasible under this situation, here's the Arch beginners' guide:
    https://wiki.archlinux.org/index.php/Beginners'_Guide

  8. #8
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    I link to Arch regularly, but it is more technical.

    I have a nVidia discrete card, but have to use nomodeset to install and on first boot until I get proprietary driver installed. And with 12.10 I could not get driver installed until I installer kernel header first.

    http://ubuntuforums.org/showthread.php?t=2081649
    Fix for nVidia with 12.10 missing kernel dpkg reconfigure:
    http://ubuntuforums.org/showthread.php?t=2072862


    How to set NOMODESET and other kernel boot options in grub2 - both liveCD & first boot, but different
    http://ubuntuforums.org/showthread.php?t=1613132
    https://help.ubuntu.com/community/BootOptions
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  9. #9
    Join Date
    Dec 2012
    Beans
    5

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    Quote Originally Posted by y400 View Post
    While the i7 does have the integrated intel graphics, it is disabled/bypassed on my y400 at least. I can only see the discrete Nvidia GT650M through lspci. I know there has been confusion about whether these laptops have Optimus or not and from what I can tell, there is no way to use or access the intel gpu.

    I'm not sure what options there are for installing Ubuntu outside of the GUI so I can't help you there. I hope this isn't frowned upon and feel free to mod edit if so, but if Ubuntu isn't feasible under this situation, here's the Arch beginners' guide:
    https://wiki.archlinux.org/index.php/Beginners'_Guide
    Thanks a lot for the guide, I will look into it. And yes, I only see my NVidia card with this laptop. It does not appear to be an Optimus configuration. But somehow this configuration confuses Ubuntu upon install.

  10. #10
    Join Date
    Dec 2012
    Beans
    5

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    I'm getting a little closer. acpi=off got around the boot process hanging on the dual cards, however since I booted from a USB stick it turned off the USB port it was booting from, and was not able to mount the partitions to continue the installation.

    I have yet to get the Ubuntu 12.10 to boot on this particular machine. (It boots just fine on others, and my disk imaging CD boots on the Y500.)

    At this rate, I may eventually give ArchLinux a try.

    @oldfred
    Thanks a lot for your reference. Unfortunately I'm not far along enough in the install process to give them a try.

Page 1 of 8 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •