Page 1 of 2 12 LastLast
Results 1 to 10 of 74

Thread: Lenovo Ideapad Y500 LiveUSB Problem

Hybrid View

  1. #1
    Join Date
    Dec 2012
    Beans
    5

    Lenovo Ideapad Y500 LiveUSB Problem

    I am trying to use the Ubuntu 12.10 Secure Remix to install Ubuntu on a Lenovo Ideapad Y500. My goal was to install a dual boot option alongside Windows 8. This was my first attempt at installing Ubuntu in a UEFI configuration.

    After creating the bootable USB stick, I disabled the Secure Boot option in the BIOS.

    I was able to boot from the USB stick and got the GRUB menu. Both the installation and boot w/o installation options resulted in a blank screen.

    During the next boot attempt I used the "e" option to edit the kernel boot parameters.

    Removing "quiet splash" and adding "text" I hoped to see text command line interface. Instead it seemed that the text output was compressed in the top 1/6th of the screen, rendering it unreadable.

    Unfortunately, without a command line interface I don't have many options. Anybody had similar results on a Lenovo Ideapad Y500?

  2. #2
    Join Date
    Dec 2012
    Beans
    8

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    I just recently set up Arch Linux in dual boot with Windows 8 on my y400 and installed using a CD.

    Being squeezed up in the top portion of the screen seemed to happen when I would choose to boot from the CD from the menu instead of automatically on reboot after moving the optical drive to the top of the boot order list in the BIOS.

    As for boot parameters, I had to add nomodeset or else the screen would freeze, although it would still boot up.

  3. #3
    Join Date
    Dec 2012
    Beans
    5

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    Quote Originally Posted by y400 View Post
    I just recently set up Arch Linux in dual boot with Windows 8 on my y400 and installed using a CD.

    Being squeezed up in the top portion of the screen seemed to happen when I would choose to boot from the CD from the menu instead of automatically on reboot after moving the optical drive to the top of the boot order list in the BIOS.

    As for boot parameters, I had to add nomodeset or else the screen would freeze, although it would still boot up.
    Thanks a lot for the feedback. Changing the boot order in the BIOS setup instead of the boot menu indeed restored the text mode. I don't think I would have made that connection, thank you.

    At least I can not experiment with display modes and try my luck. Did you have to through this or did the LiveCD / Live USB work for you right away?

    Additional info: When running the "nomodeset" kernel parameter the following error will appear:

    Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work.

    I am still researching, but not sure where to go from here, atm.
    Last edited by haspelbein; December 16th, 2012 at 01:29 PM.

  4. #4
    Join Date
    Dec 2012
    Beans
    8

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    With my Arch Linux install, it doesn't use a GUI and couldn't get X going until I installed the nvidia drivers. These laptops don't have Optimus so they only use the Nvidia GPU and don't access the integrated intel graphics. I'm thinking that would explain why you can get into Ubuntu's text mode but not to the GUI.

    You could try the boot parameter acpi=off but I'm thinking you'll probably have to do a non-GUI install.

  5. #5
    Join Date
    Dec 2012
    Beans
    5

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    Quote Originally Posted by y400 View Post
    With my Arch Linux install, it doesn't use a GUI and couldn't get X going until I installed the nvidia drivers. These laptops don't have Optimus so they only use the Nvidia GPU and don't access the integrated intel graphics. I'm thinking that would explain why you can get into Ubuntu's text mode but not to the GUI.

    You could try the boot parameter acpi=off but I'm thinking you'll probably have to do a non-GUI install.
    Yes, you may be right. I know that the Intel HD4000 is present, but it is not even visible as an option in the BIOS. So you are right, they are using the Nvidia by default. I think the problem is not so much that the Nvidia card is present, but that the Ubuntu install detects both GPUs. (I've been able to successfully install Ubuntu on Nvidia-only laptops in the past.)

    I haven't tried ArchLinux before, but I know that it is more of an expert Linux system. Yet the way things are, I may have to read up on text-based installs, as I don't see a work-around either.

    I will give acpi=off a try though, as one last effort.

    Thanks a lot for your feedback.

  6. #6
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    Some now older info on switchable graphics:
    http://ubuntuforums.org/showthread.php?t=1657660

    Optimus
    http://ubuntuforums.org/showthread.php?t=1657660
    Bumblebee:
    https://wiki.ubuntu.com/Bumblebee
    12.10 with bumblebee
    http://ubuntuforums.org/showthread.php?t=2077451
    NVIDIA Confirms It's Working On Optimus Linux Support - Aug 31, 2012
    http://www.phoronix.com/scan.php?pag...tem&px=MTE3MzY
    Oldfred on vacation. Back Sept 9. Will not have much if any Internet access.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  7. #7
    Join Date
    Dec 2012
    Beans
    8

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    Quote Originally Posted by haspelbein View Post
    I am trying to use the Ubuntu 12.10 Secure Remix to install Ubuntu on a Lenovo Ideapad Y500. My goal was to install a dual boot option alongside Windows 8. This was my first attempt at installing Ubuntu in a UEFI configuration.

    After creating the bootable USB stick, I disabled the Secure Boot option in the BIOS.

    I was able to boot from the USB stick and got the GRUB menu. Both the installation and boot w/o installation options resulted in a blank screen.

    During the next boot attempt I used the "e" option to edit the kernel boot parameters.

    Removing "quiet splash" and adding "text" I hoped to see text command line interface. Instead it seemed that the text output was compressed in the top 1/6th of the screen, rendering it unreadable.

    Unfortunately, without a command line interface I don't have many options. Anybody had similar results on a Lenovo Ideapad Y500?
    I have been able to successfully dual boot with Ubuntu 12.1 and Win 8. I had the blank screen issue that you mentioned when trying to install/boot from a liveUSB but getting into the BIOS and modifying the bios to have "Legacy Support" instead of UEFI did the trick. With that change, I was able to gui install from the USB. However, GRUB was not loading the correct UEFI bootloader for win 8 but was able to boot ubuntu OK. Installing and running the boot-repair tool with the default settings resolved the issue.
    https://help.ubuntu.com/community/Boot-Repair

    Installing the nVidia drivers (which had dependencies on linux-generic..sigh) was the next step. I'm yet to be able to control backlight or use the webcam but hope to get there...

  8. #8
    Join Date
    Feb 2013
    Beans
    1

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    Hi, did you get Ubuntu on your Lenovo Y500?. I'm trying whith mine but without luck the problem is the same as yours, the blank screen after hit on "try ubuntu" in the GRUB menu. how did you fix it?

  9. #9
    Join Date
    Dec 2011
    Beans
    2

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    Even I am facing the same problem. Did you find a solution.

  10. #10
    Join Date
    May 2010
    Beans
    5

    Re: Lenovo Ideapad Y500 LiveUSB Problem

    Thanks for the brightness fixes guys! For those that can't get the Ubuntu to install via USB (original topic), here is what I did:

    Edit the boot/grub/grub.conf:

    1) Change where it says "set gfxmode=auto" to "set gfxmode=1920x1080"
    2) Under "Install Ubuntu", change "quiet splash" to "nomodeset=1"

    Use UEFI, but disable secure boot, and hold F12 while booting to choose the USB disk. Ubuntu should show up at the proper size. (If your display is lower resolution adjust the "1920x1080" to something more appropriate.)

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •