Results 1 to 5 of 5

Thread: [Help]Can't locate thread/shareds.pm in @INC

  1. #1
    Join Date
    Dec 2012
    Beans
    2

    [Help]Can't locate thread/shareds.pm in @INC

    I'm using a older version of ubuntu on my dedicated server, before had running perl 5.8.8 and i THINK i've installed correctly ActivePerl 5.14 after comparing many tutorials so I'm sure I dont make mistakes. My hunch is that I need to do some manual configuration of wich I dont know. I'm trying to use a programs that requires 'shared::threads'. If anyone here would be willing to help me with this issue i'm willing even to pay as this thing costs me money and time. Thank you and I'm awaiting your answers.

  2. #2
    Join Date
    Feb 2008
    Location
    Pelican Bay Correctional
    Beans
    Hidden!

    Re: [Help]Can't locate thread/shareds.pm in @INC

    terminal >
    Code:
    sudo su -
    cpan
    install shared::thread
    should do it.
    What's a landing but a take off in reverse?

  3. #3
    Join Date
    Dec 2012
    Beans
    2

    Re: [Help]Can't locate thread/shareds.pm in @INC

    root@noc:~# sudo su -
    root@noc:~# cpan
    Terminal does not support AddHistory.

    cpan shell -- CPAN exploration and modules installation (v1.9402)
    Enter 'h' for help.

    cpan[1]> install shared::thread
    CPAN: Storable loaded ok (v2.20)
    Going to read '/root/.cpan/Metadata'
    Database was generated on Wed, 12 Dec 2012 01:07:04 GMT
    CPAN: Time::HiRes loaded ok (v1.9719)
    Warning: no success downloading '/root/.cpan/sources/authors/01mailrc.txt.gz.tmp22514'. Giving up on it. at /usr/lib/perl5/5.10.1/CPAN/Index.pm line 225
    LWP not available

    Trying with "/usr/bin/curl -L -f -s -S --netrc-optional" to get
    "http://www.perl.org/CPAN/authors/01mailrc.txt.gz"
    CPAN: Compress::Zlib loaded ok (v2.02)
    CPAN: YAML loaded ok (v0.84)
    Going to read '/root/.cpan/sources/authors/01mailrc.txt.gz'
    .................................................. ..........................DONE
    Warning: no success downloading '/root/.cpan/sources/modules/02packages.details.txt.gz.tmp22514'. Giving up on it. at /usr/lib/perl5/5.10.1/CPAN/Index.pm line 225

    Trying with "/usr/bin/curl -L -f -s -S --netrc-optional" to get
    "http://www.perl.org/CPAN/modules/02packages.details.txt.gz"
    Going to read '/root/.cpan/sources/modules/02packages.details.txt.gz'
    Database was generated on Fri, 14 Dec 2012 01:07:03 GMT
    HTTP:ate not available
    ..............
    New CPAN.pm version (v1.9800) available.
    [Currently running version is v1.9402]
    You might want to try
    install CPAN
    reload cpan
    to both upgrade CPAN.pm and run the new version without leaving
    the current session.


    .................................................. ............DONE
    Warning: no success downloading '/root/.cpan/sources/modules/03modlist.data.gz.tmp22514'. Giving up on it. at /usr/lib/perl5/5.10.1/CPAN/Index.pm line 225

    Trying with "/usr/bin/curl -L -f -s -S --netrc-optional" to get
    "http://www.perl.org/CPAN/modules/03modlist.data.gz"
    Going to read '/root/.cpan/sources/modules/03modlist.data.gz'
    .................................................. ..........................DONE
    Going to write /root/.cpan/Metadata
    Warning: Cannot install shared::thread, don't know what it is.
    Try the command

    i /shared::thread/

    to find objects with matching identifiers.

    cpan[2]>
    I've tried and that's what I got. What's the issue there? Not even my old buddy google could get me any info to solve that..

  4. #4
    Join Date
    Feb 2008
    Location
    Pelican Bay Correctional
    Beans
    Hidden!

    Re: [Help]Can't locate thread/shareds.pm in @INC

    my bad:
    Code:
    sudo 
    cpan
    install threads::shared
    Sorry about that.
    What's a landing but a take off in reverse?

  5. #5
    Join Date
    Sep 2006
    Beans
    7,689
    Distro
    Lubuntu Development Release

    libthreads-shared-perl

    You are likely to break things if you go outside the package management system. At the very best it will be extra work. Does the package "libthreads-shared-perl" not give you what you need?

    Code:
    sudo apt-get update
    sudo apt-get install libthreads-shared-perl

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •