Results 1 to 5 of 5

Thread: "failed to enumerate device in port..." issue when plugging SD cards

  1. #1
    Join Date
    Sep 2012
    Beans
    22

    "failed to enumerate device in port..." issue when plugging SD cards

    Hi


    I've been having this issue since I installed Ubuntu 12.04 (32bit) in my new laptop (an HP envy4 1050ca) a few months ago. It doesnot read SD cards, even when plugged to a an external reader, or directly to the built-in reader.
    dmesg command gives the following message

    "failed to enumerate device in port #" (# is the port where I had connected my sd cards)

    I have tryed a few possible solutions, like installing usbmount, but none worked

    Does anybody have any idea on this?

    Thank for the help!

  2. #2
    Join Date
    Sep 2012
    Beans
    22

    Re: "failed to enumerate device in port..." issue when plugging SD cards

    Hi


    I've researched more into the issue, it happens that it is a problem concerning xhci_hcd.
    The output to
    Code:
    tail -f /var/log/syslog
    was

    Code:
    usb 3-1: new full-speed USB device number 4 using xhci_hcd
    usb 3-1: Device not responding to set address.
    usb 3-1: Device not responding to set address.
    usb 3-1: device not accepting address 4, error -71
    hub 3-0:1.0: unable to enumerate USB device on port 1
    any idea? hope anybdy has any clue about this

    thanks

  3. #3
    Join Date
    Oct 2009
    Location
    Elgin, IL USA
    Beans
    2,531
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: "failed to enumerate device in port..." issue when plugging SD cards

    Are you attempting to connect SDHC or SDXC on a card reader not capable of that? Does the card reader work for those cards on any other computer or OS?
    i5 650 3.2 GHz, 8 GB, nvidia GTX 550 Ti 32" 1080p | i7-4700, 8 GB, Intel HD 4600/nvidia GTX 765M 15.6" 1080p | etc.

  4. #4
    Join Date
    Sep 2012
    Beans
    22

    Re: "failed to enumerate device in port..." issue when plugging SD cards

    All my cards can be read (both using an external reader or the built-in one) under my windows partition

    Cheers

  5. #5
    Join Date
    Sep 2012
    Beans
    22

    Re: "failed to enumerate"... SD card reading and unsuported built in reader

    So finally I kinda got on top of this. So I still have the problem with the external reader (although now it only happens sometimes), but I made the built in card reader work just perfect. So

    -my external reader works SOMETIMES. I upgraded to linux mint 14 (12.10 based) so I guess the upgrade fixed this partially

    -however, the built-in reader continued not to work. When typing lspci in a terminal, the output was


    Code:
      Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)
    This is the sdcard built in reader. If you have this same one you can solve this by:


    a)download this package
    https://bugs.launchpad.net/bugs/9718...ts_bpp.tar.bz2

    b) follow these instructions

    * In Dolphin (or equivalent) right click and "Extract > Extract Archive here"
    * Open a terminal window
    * Navigate to Downloads / rts_bpp
    * At the command prompt enter
    su root
    * Enter root password
    * Type the following commands:
    make
    make install
    depmod -a
    * To get the driver working instantly type the following or reboot

    (see original thread here http://www.pclinuxos.com/forum/index.php?topic=109447.0)

    And voilá! The card reader works perfectly! I dont know if it will work with other card readers, with mine works just perfect

    Hope this helps
    Cheers

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •