Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: No headphone sound on Toshiba Satellite A135

  1. #1
    Join Date
    Dec 2006
    Location
    Hornbeck, La
    Beans
    426
    Distro
    Ubuntu 12.04 Precise Pangolin

    No headphone sound on Toshiba Satellite A135

    My son just came over from the dark side a couple weeks ago and so far no problems with his Hardy install other than no headphones. The sound works fine with the laptop's built in speakers, but no sound with the headphones or any external speakers (worked ok with XP). lspcv -l shows Intel Corp 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

    Any help would be appreciated.
    HP Pavilion -- 4 Gig RAM -- 750 GIG HD -- Zorin 7.0 // Still Rockin' 13.10 -- Testing 14.04 -- Nuttin' but LINUX !

  2. #2
    Join Date
    Nov 2008
    Location
    Lleida, Spain
    Beans
    1,157
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: No headphone sound on Toshiba Satellite A135

    search in sound options for jack sense

    double click in the speaker icon
    the mixer will appear
    then click preferences
    search for Line Jack Sense, enable it

    now a new tab will appear in the mixer
    search for headphone jack sense and select it

  3. #3
    Join Date
    Dec 2006
    Location
    Hornbeck, La
    Beans
    426
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: No headphone sound on Toshiba Satellite A135

    Ok double clicked the speaker icon and no selection for Line Jack Sense. There is one for headphones and it is already checked. Still no joy.
    HP Pavilion -- 4 Gig RAM -- 750 GIG HD -- Zorin 7.0 // Still Rockin' 13.10 -- Testing 14.04 -- Nuttin' but LINUX !

  4. #4
    Join Date
    Apr 2005
    Beans
    111

    Re: No headphone sound on Toshiba Satellite A135

    Same laptop, same problem. It's had this difficulty for since Hardy, which is annoying since it worked before that. Now I've got to re-figure out how to fix it, since the gutsy fix no longer works.

    It's a stock vanilla Intel chipset, you'd think it would be easy.

  5. #5
    Join Date
    Apr 2008
    Beans
    5

    Re: No headphone sound on Toshiba Satellite A135

    There is a solution to this.. there is a similar fix to Sony laptop owners. I have gotten it to work in the past. It also makes the side buttons work [Play, Stop, Track Advance]. Unfortunately, I will need to figure out how to do it again. I will see if I can find it and post the solution.

  6. #6
    Join Date
    Nov 2007
    Beans
    10

    Re: No headphone sound on Toshiba Satellite A135

    I am using a a135-s7403 and have the same issue. There is no sound at all from the headphone jack. The internal speakers dont mute, and I have enabled and changed all the sound options availibe. I havent found anything close to a fix newer that Hardy releases and that fix was recompiling the alsa drivers. I actually cant remember if the headphones worked with Intrepid. Right now I need this laptop to play music out of the headphones for use in my business. It would be a shame to have to change OS.

  7. #7
    Join Date
    Sep 2007
    Location
    norfolk va
    Beans
    14
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: No headphone sound on Toshiba Satellite A135

    I forget where I originally saw this but I have to input this every time I do a fresh install. I have a toshiba A135-S4467 and this completely fixes the headphone issue.

    1) open terminal:

    Applications > Accessories > Terminal

    2) in terminal enter command:

    sudo gedit /etc/modprobe.d/alsa-base.conf

    enter password when prompted.

    3) this will open a file, scroll to the end of the file and paste in:

    options snd-hda-intel model=lenovo

    save and close this file

    4) Restart computer, sound should work through the headphones now.

    Hope this helps.

  8. #8
    Join Date
    Oct 2006
    Location
    Richmond, VA USA
    Beans
    121
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: No headphone sound on Toshiba Satellite A135

    Quote Originally Posted by wford002 View Post
    I have a toshiba A135-S4467 and this completely fixes the headphone issue.
    ---
    options snd-hda-intel model=lenovo
    OMG! Thank you. I have the same model laptop and never was able before to get the speakers to mute when the headphone was plugged in. Can't believe even the media keys work.

  9. #9
    Join Date
    Aug 2009
    Location
    Serbia
    Beans
    1
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: No headphone sound on Toshiba Satellite A135

    Quote Originally Posted by DonnieP View Post
    to get the speakers to mute when the headphone was plugged in
    I can't get the built in speakers to mute on FSC Amilo Pro, I get sound from both external and internal speakers. Is there any way to solve this? Thanks

  10. #10
    Join Date
    Oct 2006
    Location
    Richmond, VA USA
    Beans
    121
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: No headphone sound on Toshiba Satellite A135

    Quote Originally Posted by DRankovic View Post
    I can't get the built in speakers to mute on FSC Amilo Pro, I get sound from both external and internal speakers. Is there any way to solve this? Thanks
    Check out this thread at LinuxQuestions:
    http://www.linuxquestions.org/questi...dphone-599930/
    It's basically a crap shoot. Try some of the tweaks toward the end of that thread for your /etc/modprobe.d/alsa-base.conf.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •