Results 1 to 3 of 3

Thread: apparmor mount rule help

  1. #1
    Join Date
    Dec 2012
    Beans
    5

    apparmor mount rule help

    I don't want firefox mount some sda partition.
    I add "deny mount /dev/sda7" to /etc/apparmor.d/local/user.bin.firefox, but it doesn't work.
    sda7 is a fat32 partition.

  2. #2
    Join Date
    Feb 2010
    Location
    UK
    Beans
    133
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: apparmor mount rule help

    1. Do you have your firefox profile enabled in apparmor?
    2. Read here about editing apparmor profiles
    Code:
    http://ubuntuforums.org/showthread.php?t=1008906
    Maybe you should just try denying the access?
    then it would be
    Code:
    deny /whatever/the/place/is r,

  3. #3
    Join Date
    Dec 2012
    Beans
    5

    Re: apparmor mount rule help

    Firefox profile is already enforced.
    Dening the access is not a good choice, because you can mount a partition at any place.
    I think mount rule is needed.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •