Results 1 to 10 of 10

Thread: ugly notifications

  1. #1
    Join Date
    Sep 2009
    Beans
    62
    Distro
    Ubuntu 13.04 Raring Ringtail

    ugly notifications

    Hi,

    The system notifications in my ubuntu are quite ugly.
    (please see attached screenshot: black borders, gray background, big ugly fonts)

    Another issues is they span across both monitors.
    (I've marked with a red line the common border for my monitors)
    This is a problem since I usually keep the second monitor off to save energy.

    I have ubuntu 12.10, lightdm, gnome-no effects.
    I've tried to change the themes in gnome-tweak-tool but the notifications stay the same.

    How can I change the notification schema?
    Also how can I force the notifications to appear only on my primary monitor?

    Code:
    $> gnome-session --version
    gnome-session 3.6.0
    
    $> uname -a
    Linux ubuntu 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:32:08 UTC 2012 i686 i686 i686 GNU/Linux


    Please help,
    PM

  2. #2
    Join Date
    Feb 2010
    Location
    WI USA
    Beans
    9,988
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: ugly notifications

    You may want to look at application at the link. I don't think it will help with the dual monitor issue though . With a single monitor the notification color is dependent on theme at least for my system. Make sure the app is 12.10 compatible at Launchpad. http://www.webupd8.org/2012/06/closa...notifyosd.html
    Infinite diversity in infinite combination.

    Ubuntu Documentation Search: Popular Pages
    Ubuntu: Security Basics
    Ubuntu: Manual

  3. #3
    Join Date
    Sep 2009
    Beans
    62
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: ugly notifications

    Hi,

    Thanks for advise. Followed the instructions, but the ugly notifications are still there.
    I've tried to change the background (to red, see below) but nothing changes.
    Actually anything I change it has no effect whatsoever.

    Also please notice the "no process found" message in the terminal:



  4. #4
    Join Date
    Sep 2009
    Beans
    62
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: ugly notifications

    I see the notify-osd is not running, but I also cannot start it:

    Code:
    $> ps -ef | grep notify-osd
    
    $> /usr/lib/notify-osd/notify-osd 
    reading settings from '/home/user/.notify-osd'
    
    ** (notify-osd:4518): WARNING **: Another instance has already registered org.freedesktop.Notifications
    
    ** (notify-osd:4518): WARNING **: Could not register instance
    Please help,
    PM

  5. #5
    Join Date
    Dec 2010
    Beans
    2

    Re: EXTREMELY ugly notifications

    I'm also experiencing this problem.

    I've also been getting this ugly bastard in the middle of the screen for contrast and volume for almost a year now and it's pissing me off:



    10.04 had them working just fine!


    I use gnome classic 2d no compiz standard etc etc etc whatever. The one where the traditional setup is a bar both at the top and bottom of the screen

    Is there any fix known or forthcoming?

    edit:

    I've managed to make them a bit neater by removing notification-daemon package. This has pushed them all back into the corner where they belong. But they're still ugly buggers. Check this out:

    The colour seems to be off and the borders are solid black. very ugly. what I wanted is more like these shots from the notify-osd documentation on the wiki:


    edit:
    I can get back this behaviour by turning to compiz.
    I do not want compiz. I want metacity.
    Is there any way to get these working under gnome classic (No 3d effects)?
    Last edited by TheIronKnuckle; February 5th, 2013 at 10:40 AM.

  6. #6
    Join Date
    Dec 2005
    Location
    Western Australia
    Beans
    11,478
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: EXTREMELY ugly notifications

    Quote Originally Posted by TheIronKnuckle View Post
    edit:
    I can get back this behaviour by turning to compiz.
    I do not want compiz. I want metacity.
    Is there any way to get these working under gnome classic (No 3d effects)?
    The transparency between notifications, and the semi-transparency in the notifications themselves, are 3D effects in themselves.

    If you turn on compositing in Metacity (it's a gconf key, or a dconf key, from what I remember) you might get the transparency, but then that kinda defeats the "no effects" thing.
    I try to treat the cause, not the symptom. I avoid the terminal in instructions, unless it's easier or necessary. My instructions will work within the Ubuntu system, instead of breaking or subverting it. Those are the three guarantees to the helpee.

  7. #7
    Join Date
    Dec 2010
    Beans
    2

    Re: EXTREMELY ugly notifications

    Thanks for the quick reply!

    Yeah, I realised transparency isn't the issue/what I'm looking for. I just want the colours to be correct and the black box to bugger off. I've managed to get an only-just-working solution happening by using some notify-osd configuration system. I just made the inner bubble the same black as the outer box. Still not that pretty, but I can live with it. Only issue now is that the notification bubbles disappear way too fast (a second or less). Again. I can live with that, but it's kind of annoying

  8. #8
    Join Date
    Sep 2009
    Beans
    62
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: ugly notifications

    The ugly notifications and notify-osd not running are still there.
    Any idea how this can be fixed?

    Thanks,
    PM

  9. #9
    Join Date
    May 2012
    Location
    UK
    Beans
    613

    Re: ugly notifications

    have you tried replacing the notify osd or whichever ubuntu is using, with the xfce version? its called xfce4-notifyd. here is some info
    The package name is xfce4-notifyd and it will only remove notify-osd (as they cannot co-exist) and the ubuntu-desktop metapackage. Latter one won't harm your system, but it has some downsides, see: What are the downsides of removing ubuntu-desktop metapackage?
    ...trying it won't hurt your system, as you can always go back by re-installing the ubuntu-desktop metapackage.
    source http://www.answeredubuntu.com/49796/...e_xfce_version

    there is also a tweak tool for it, you will find in /usr/share/applications. with root privileges of the file manager, you can right-click the notifications file, open in a text editor, then edit something about not show in... so it shows in the menu.
    Last edited by black veils; March 6th, 2013 at 01:43 PM.

  10. #10
    Join Date
    Sep 2009
    Beans
    62
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: ugly notifications

    Ok, found out:
    - you first have to uninstall notification-daemon (use synaptic)
    - then you kill the notification-daemon running processes
    - make sure you have notify-osd installed (synaptic)

    Code:
    $> notify-send "hello"
    More info here:
    http://askubuntu.com/questions/15652...lassic-session

    Regards,
    PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •