Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: 12.04 keeps wanting to upgrade to 12.10?

  1. #11
    Join Date
    Apr 2007
    Location
    Hamden, CT
    Beans
    649
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 keeps wanting to upgrade to 12.10?

    Quote Originally Posted by TheGuyWithTheFace View Post
    Arpanaut, Here's the output from sudo apt-get dist upgrade:

    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Calculating upgrade... Done
    The following packages will be REMOVED:
      libgwibber-gtk2 libgwibber2
    The following NEW packages will be installed:
      account-plugin-facebook account-plugin-twitter gir1.2-accounts-1.0
      gir1.2-signon-1.0 libaccount-plugin-1.0-0 libaccounts-glib0 libaccounts-qt1
      libgwibber-gtk3 libgwibber3 libqjson0 libsignon-extension1 libsignon-glib1
      libsignon-plugins-common1 libsignon-qt1 libunity-webapps0
      linux-headers-3.2.0-34 linux-headers-3.2.0-34-generic
      linux-image-3.2.0-34-generic signon-keyring-extension signon-plugin-oauth2
      signon-ui signond skype-bin:i386 unity-webapps-service
    The following packages will be upgraded:
      bamfdaemon gwibber gwibber-service gwibber-service-facebook
      gwibber-service-twitter indicator-appmenu libbamf0 libbamf3-0 linux-generic
      linux-headers-generic linux-image-generic shotwell skype:i386
    13 upgraded, 24 newly installed, 2 to remove and 0 not upgraded.
    Need to get 86.9 MB of archives.
    After this operation, 223 MB of additional disk space will be used.
    Do you want to continue [Y/n]? n
    Abort.
    As you said, I aborted because it wanted to remove packages.

    LuisGMarine, I tried those commands, but I still got that partial upgrade message...
    I think you are okay to hit [Y], considering it only wants to remove 2 non system essential package's...

    NOTE: Pressing [Y] will upgrade the kernel, which should be normal considering the command that you are running.
    Last edited by LuisGMarine; December 9th, 2012 at 02:59 AM. Reason: NOTE

  2. #12
    Join Date
    Oct 2005
    Location
    INDY
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: 12.04 keeps wanting to upgrade to 12.10?

    Okay, since the removed packages will be replaced by their newer version,
    libgwibber-gtk3 libgwibber3, then it will be okay to let the operation complete.

    That would seem to be the roadblock with update-manager.
    The dist-upgrade command is sometimes needed to get upgrades to new versions of packages. It is strange, as update manager should take this into account with the version changes and go through normally. Might have been a matter of timing of when the updates reached the repositories, don't know.

    Hopefully redoing the dist-upgrade command and allowing it to execute will solve the issue. Post back if not.
    Last edited by arpanaut; December 9th, 2012 at 03:14 AM. Reason: typo
    Castles Made of Sand,
    Fall in the Sea,
    Eventually!

  3. #13
    Join Date
    Apr 2012
    Location
    Somewhere in Nevada...
    Beans
    141
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 keeps wanting to upgrade to 12.10?

    It worked! Thank you all for your quick responses and bright ideas.
    The main difference between Windows forums and the Ubuntu forums is that the Ubuntu forums has hundreds of questions and thousands of answers, but Windows forums just have hundreds of questions.
    As for the OS X forums, I wouldn't know, I'm too poor.

  4. #14
    Join Date
    Dec 2012
    Location
    Cambridge, Massachusetts
    Beans
    31
    Distro
    Ubuntu Development Release

    Re: 12.04 keeps wanting to upgrade to 12.10?

    try
    sudo apt-get update && sudo apt-get upgrade

    then
    sudo apt-get dist-upgrade
    sudo apt-get install -f

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •