Results 1 to 8 of 8

Thread: Bug in wpa 1.0-3ubuntu1

  1. #1
    Join Date
    Jul 2010
    Location
    Finland
    Beans
    2,455
    Distro
    Ubuntu

    Bug in wpa 1.0-3ubuntu1

    The newest wpa (1.0-3ubuntu1) contains a bug.
    The package wpasupplicant (which is a dependency of network-manager) depends on libreadline5.
    Well we have had libreadline6 in use already with Precise Pangolin.

    So updating wpasupplicant pulls in libreadline5 too.

  2. #2
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Bug in wpa 1.0-3ubuntu1

    libreadline5 is also already used by some other packages. I suppose that wpa is using 5 for a good reason (but dont ask me which one )

  3. #3
    Join Date
    Aug 2012
    Location
    Hong Kong
    Beans
    160
    Distro
    Ubuntu Development Release

    Re: Bug in wpa 1.0-3ubuntu1

    Quote Originally Posted by Harry33 View Post
    The newest wpa (1.0-3ubuntu1) contains a bug.
    The package wpasupplicant (which is a dependency of network-manager) depends on libreadline5.
    Well we have had libreadline6 in use already with Precise Pangolin.

    So updating wpasupplicant pulls in libreadline5 too.
    Well the developers don't read here. Why don't you report a bug in Launchpad against this package?
    As the Ubuntu Studio release manager and a Kubuntu developer, I do a lot of ISO testing and packaging.
    Make Ubuntu 13.10 awesome~!

  4. #4
    Join Date
    Oct 2008
    Location
    Exodus Hair<- Čubura
    Beans
    3,693
    Distro
    Ubuntu Development Release

    Re: Bug in wpa 1.0-3ubuntu1

    Quote Originally Posted by smartboyhw View Post
    Well the developers don't read here
    That's a myth...

  5. #5
    Join Date
    Jun 2007
    Beans
    12,724

    Re: Bug in wpa 1.0-3ubuntu1

    changelog (debian
    * revert to GNU readline for wpa_cli, instead of using the internal readline
    implementation added in wpa 1~. Prefer libreadline-gplv2-dev, because libnl
    is GPL-2 (only) - switching back to the internal readline implementation is
    targeted for wheezy+1 (Closes: #677993, #678077).
    libreadline-gplv2-dev uses libreadline5

  6. #6
    Join Date
    Sep 2010
    Location
    Beta Testing in Canada
    Beans
    5,198
    Distro
    Ubuntu Development Release

    Re: Bug in wpa 1.0-3ubuntu1

    Quote Originally Posted by mc4man View Post
    changelog (debian


    libreadline-gplv2-dev uses libreadline5

    libreadline5 just installed itself today in updates ?

    I just let it roll in.

    No show stoppers.
    This is Rolling Release
    Warnings for New Beta Testers& Helpful Terminal Commands:
    Running Trusty /devel/@ 5.120GHz32bit/ Please put [ prefix] on New Threads!

  7. #7
    Join Date
    Jul 2010
    Location
    Finland
    Beans
    2,455
    Distro
    Ubuntu

    Re: Bug in wpa 1.0-3ubuntu1

    Quote Originally Posted by ventrical View Post
    libreadline5 just installed itself today in updates ?

    I just let it roll in.

    No show stoppers.
    True it does not behave like a show stopper.
    But I just do not like having both libreadline5 and libreadline6 installed.
    Libreadline6 is definitely newer, hence ABI bumb on naming too.

  8. #8
    Join Date
    Jun 2007
    Beans
    12,724

    Re: Bug in wpa 1.0-3ubuntu1

    Quote Originally Posted by Harry33 View Post
    But I just do not like having both libreadline5 and libreadline6 installed.
    Libreadline6 is definitely newer, hence ABI bumb on naming too.
    wpa didn't/does not use libreadline6, re-quoting snipped
    instead of using the internal readline implementation added in wpa 1~.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •