Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Wine: The following packages have unmet dependencies

  1. #1
    Join Date
    Dec 2012
    Beans
    6

    Wine: The following packages have unmet dependencies

    Hello,
    I am very new to ubuntu and Linux in general... I am an IT student and have only taken an introductory class on UNIX/Linux, but I really liked it so I decided to install it as my OS. The problem is that I need to install wine (for using MS programs for school) and have run into problems doing installing via the terminal, I receive the following message:
    The following packages have unmet dependencies:
    wine1.5 : Depends: wine1.5-i386 (= 1.5.18-0ubuntu1) but it is not installable
    Recommends: gnome-exe-thumbnailer but it is not going to be installed or
    kde-runtime but it is not going to be installed
    Recommends: ttf-droid
    Recommends: ttf-umefont but it is not going to be installed
    Recommends: ttf-unfonts-core but it is not going to be installed
    Recommends: winbind but it is not going to be installed
    Recommends: winetricks but it is not going to be installed
    Any help would be appreciated.
    Thanks,
    Matt

  2. #2
    Join Date
    Dec 2012
    Location
    UK, Lancaster
    Beans
    39

    Re: Wine help!!!

    Use the Update Manager and use the command below.

    Code:
    sudo apt-get install update

  3. #3

    Re: Wine help!!!

    first use the command below to update

    Code:
    sudo apt-get install update
    then write:
    Code:
    sudo apt-get install PlayOnLinux
    the command above is the best for MS program it will be installed with wine Enjoy!!

  4. #4
    Join Date
    Jul 2007
    Location
    UK
    Beans
    16,864
    Distro
    Ubuntu Development Release

    Re: Wine: The following packages have unmet dependencies

    Moved to Wine forum.

    The command above is wrong. It should be.

    Code:
    sudo apt-get update

  5. #5
    Join Date
    Dec 2012
    Beans
    6

    Re: Wine: The following packages have unmet dependencies

    These are the commands, in order, that I used in the command line terminal.
    sudo add-apt-repository ppa:ubuntu-wine/ppa
    sudo apt-get update
    sudo apt-get install wine1.5


    That's when I received the unmet dependencies error... I tried installing PlayOnLinux as suggested, this is the message I got: E: Unable to locate package PlayOnLinux. A little frustrating but I am enjoying the learning experience. I'll keep hammering away at it, but any more suggestions would be appreciated.
    Thanks,
    Matt

  6. #6
    Join Date
    Jan 2008
    Beans
    7,749

    Re: Wine: The following packages have unmet dependencies

    Welcome to the forums!

    Why don't you use the stable, trusted, and tested Wine 1.4 from the Ubuntu repositories? It can be installed with 1 mouse click in the Ubuntu Software Center and is guaranteed not to have unmet dependencies.

  7. #7
    Join Date
    Dec 2012
    Beans
    6

    Re: Wine: The following packages have unmet dependencies

    I tried that and the software center gave me the following message:
    The following packages have unmet dependencies:

    wine1.4: PreDepends: dpkg (>= 1.15.7.2~) but 1.16.7ubuntu6 is to be installed
    Depends: libc6 (>= 2.14) but 2.15-0ubuntu20 is to be installed
    Depends: wine1.4-amd64 (= 1.4.1-0ubuntu1) but 1.4.1-0ubuntu1 is to be installed
    Depends: wine1.4-i386 (= 1.4.1-0ubuntu1) but it is not going to be installed
    I'm sure I'm missing something really simple that would not be missed by a more experienced user.

  8. #8
    Join Date
    Jan 2008
    Beans
    7,749

    Re: Wine: The following packages have unmet dependencies

    Quote Originally Posted by mrc1503 View Post
    I tried that and the software center gave me the following message:
    The following packages have unmet dependencies:

    wine1.4: PreDepends: dpkg (>= 1.15.7.2~) but 1.16.7ubuntu6 is to be installed
    Depends: libc6 (>= 2.14) but 2.15-0ubuntu20 is to be installed
    Depends: wine1.4-amd64 (= 1.4.1-0ubuntu1) but 1.4.1-0ubuntu1 is to be installed
    Depends: wine1.4-i386 (= 1.4.1-0ubuntu1) but it is not going to be installed
    I'm sure I'm missing something really simple that would not be missed by a more experienced user.
    Did you remember to remove the ubuntu-wine PPA that you added earlier from your your software sources?

  9. #9
    Join Date
    Dec 2012
    Beans
    6

    Re: Wine: The following packages have unmet dependencies

    I removed everything that I had downloaded from the terminal and have searched for anything that I could think of. I still received the same error as before in the software center... Do I need to change any of the add ons below, or include some?

  10. #10
    Join Date
    Feb 2008
    Location
    Los Angeles
    Beans
    339
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wine: The following packages have unmet dependencies

    I've lately seen a few users report unmet dependencies / broken packages problems trying to install wine. I'm just speculating but there possibly could be a problem with 12.10 and mutiarch with respects to wine.

    What version of Ubuntu are you using and what arch (i386 or amd64)?

    If you don't mind the trouble reinstalling, try out 12.04 LTS (i386) release to see if wine installs correctly. Personally I haven't upgraded to 12.10 since the clean test installs using release images locked up at boot or during setup.
    Dell Latitude D630 - 4GB RAM - 128GB SSD - Nvidia Quadro NVS 135M - Intel 4965 wireless - DVD/CDRW - bluetooth - fingerprint reader

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •