Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Fresh Linux Mint 14, No GRUB.

  1. #1
    Join Date
    Sep 2009
    Beans
    16

    Fresh Linux Mint 14, No GRUB.

    Hi All, I hope this is not a redundant post or common issue, but I couldn't solve my issue myself or by searching other threads and google.

    Yesterday I installed Windows 8 on a small partition, followed by Linux Mint 14 MATE on another small partition with plans to make the rest of the space shared. However, I never got a GRUB menu at startup! I tried following the instructions on the GRUB info page from google by doing something like:

    # grub-install /dev/sda

    but I don't really know my way around GRUB, and when I rebooted I just got the grub prompt that looked like

    grub>

    and I couldn't get out. I used the install USB I used to run Mint from USB, from which I did something like:

    install -d /mnt/mount !!to create a mount point
    mount /dev/sda1 /mnt/mount !!sda1 is the Mint partition
    grub-install --root-directory=/mnt/mount sda

    This got me back where I started, and I don't want to risk losing computer access again, so I came for help! any advice would be appreciated.

    Thanks!!!
    -John

  2. #2
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,152
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Fresh Linux Mint 14, No GRUB!

    might i suggest downloading and using a program called "boot repair". i haven't used it but I see many who have success with it in fixing grub issues and such. https://help.ubuntu.com/community/Boot-Repair
    Check out my Blog about my life and computer software and hardware. http://ubuntuaddicted.blogspot.com/
    My YouTube channel:
    http://www.youtube.com/ubuntuaddicted

  3. #3
    Join Date
    Sep 2009
    Beans
    16

    Re: Fresh Linux Mint 14, No GRUB!

    Thanks for the tip dannyboy!

    That got me a GRUB menu, though unfortunately it only includes Mint, there is no Windows 8. Is there another quick fix to this too?


    EDIT: Nevermind, this looks pretty easy. I'll give it a go!

    -John
    Last edited by jamedfor; December 6th, 2012 at 05:31 PM. Reason: www.google.com

  4. #4
    Join Date
    Oct 2006
    Beans
    233
    Distro
    Ubuntu Gnome

    Re: Fresh Linux Mint 14, No GRUB!

    From your usb disk after it boots to desktop

    Go to a terminal

    do sudo fdisk -l

    so you can determine the linux partition you want to create grub in.

    Then from the command line

    Code:
    $ sudo mount /dev/sda5 /mnt
    Mine is sda5. yours is likely different

    Code:
     sudo mount --bind /dev /mnt/dev
    sudo mount --bind /proc /mnt/proc
    sudo mount --bind /sys /mnt/sys
    sudo chroot /mnt
    Now you are in the partition you need to create a grub in.

    Code:
    #grub-install /dev/sda               **mine is sda. yours may be different
    #update-grub
    After you update grub you should get a list. It should include Windows

    You are not done.

    Code:
    #exit
    $sudo umount /mnt/sys
    $sudo umount /mnt/proc
    $sudo umount /mnt/dev
    $sudo umount /mnt
    Then reboot, remove the USB device. You should see a grub menu with Linux Mint & Windows.
    Last edited by ubume2; December 6th, 2012 at 05:38 PM.

  5. #5
    Join Date
    Sep 2009
    Beans
    16

    Re: Fresh Linux Mint 14, No GRUB!

    ubume, I tried your method and I just installed the grub on /dev/sda. after updating the grub the list returned looks like:

    Found linux image: /boot/vmlinuz-3.5.0-17-generic
    Found initrd image: /boot/initrd.img-3.5.0-17-generic

    the initrd item doesn't look like windows... any suggestions? I haven't done the unmounting part yet.

  6. #6
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Fresh Linux Mint 14, No GRUB.

    Moved to Other OS.

    Post link to BootInfo report that Boot-Repair creates.

    ubume2's grub reinstall is the full chroot method which can be used when the two line mount & install method does not work.

    But usually Boot-Repair just fixes things.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  7. #7
    Join Date
    Sep 2009
    Beans
    16

    Re: Fresh Linux Mint 14, No GRUB.

    oldfred, thanks for reminding me to post the log from boot-repair:

    http://paste2.org/p/2569606

    there's an error about a cat something that may be the problem, I've seen errors about cat before.

    Also, the ~22000 lines of invalid argument errors may indicate somethings wrong

    -John

  8. #8
    Join Date
    Jul 2012
    Beans
    228

    Re: Fresh Linux Mint 14, No GRUB.

    Try with Quantal and check whether Grub would see Win 8.

    With Mint 14; go to /etc/apt/sources.list and block the Nadia repo, by adding # in front of it and,
    add
    and then update.

    Install grub-pc or reinstall it
    and check whether your win8 is seen.

    if not,
    sudo apt-get install boot-repair
    and run boot-repair as root. While working, it'd see your win8.

  9. #9
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Fresh Linux Mint 14, No GRUB.

    I do not know what the broken pipe error is that generated all the error lines.

    But you have Windows in sda5 which cannot be.

    Windows only boots from a primary partition with the boot flag or sda1 thru sda4. So if you moved it from sda1 its boot.ini is wrong. Or if it was a second install some or most of its boot files were in the first install. Also PBR will be wrong.

    Since it did not post boot.ini which script normally does it may be other issues in the XP NTFS partition?

    Only with XP there are work arounds to make it work in a logical partition, but it would be better to move it back to a primary. Based on your partition table it looks like you just just use fixparts to convert to primary. Probably still would need repairs to boot.ini and PBR. NTFS partition have to have the same start and size info in the PBR - partition boot sector as the partition table. Normally chkdsk from XP will fix that, but you need boot flag and XP in a primary partition for chkdsk to work well.

    To convert a partition from primary to logical, at least one free (unallocated) sector must exist between the partition and the one that precedes it.
    Fixparts - Repair broken partition tables (not overlapping issues) & delete Stray gpt data from MBR drives
    http://ubuntuforums.org/showthread.php?t=1705325
    http://www.rodsbooks.com/fixparts/
    First backup partition table, use your drive for sdX or sda, sdb etc.
    sudo sfdisk -d /dev/sdX > parts.txt


    Then use gparted to move boot flag to new XP primary partition and use a XP disk to run chkdsk. And edit boot.ini with correct partition.
    Last edited by oldfred; December 6th, 2012 at 08:12 PM.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  10. #10
    Join Date
    Oct 2006
    Beans
    233
    Distro
    Ubuntu Gnome

    Re: Fresh Linux Mint 14, No GRUB!

    Quote Originally Posted by jamedfor View Post
    ubume, I tried your method and I just installed the grub on /dev/sda. after updating the grub the list returned looks like:

    Found linux image: /boot/vmlinuz-3.5.0-17-generic
    Found initrd image: /boot/initrd.img-3.5.0-17-generic

    the initrd item doesn't look like windows... any suggestions? I haven't done the unmounting part yet.
    Well, could be something about Windows 8.

    From command line sudo chmod +x /etc/grub.d/30_os-prober.

    Then sudo update-grub.


    If you don't see Windows generated after you press the update-grub command, there is a problem. I haven't had any problem with Win 7 grub item being generated. I've used the method described in post 4 with Linux Mint, and have had no problems.
    Last edited by ubume2; December 6th, 2012 at 09:55 PM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •