Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: error: invalid efi path

  1. #1
    Join Date
    Apr 2007
    Beans
    8

    error: invalid efi path

    Yet another of the same error I've seen on this forum many times. All other solutions have not worked for me.

    I initially had Windows 7 installed on a SSD. Then I installed a separate drive, put 12.10 on it, and suddenly I cannot boot into Windows and get this error: invalid efi path.

    My motherboard is an Asus P9X79 with the most current bios.

    As of right now I've tried the latest version of boot-repair (recommended repair) and it hasn't helped.

    Here is my boot info (newest first):
    http://paste.ubuntu.com/1411687
    http://paste.ubuntu.com/1411620
    http://paste.ubuntu.com/1393550

    I've been to launchpad and marked myself as affected by bug #1024383.

    Please, anyone... I miss my games. I'm open to any suggestion.

    Thank you!

  2. #2
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: error: invalid efi path

    I do not think you can mix BIOS and UEFI.

    You have Windows in BIOS boot mode in sda and Ubuntu in UEFI boot mode in sdb. I think BIOS or UEFI do write some info that when booting is expected in certain places on hard drive. So trying to chain from an efi Ubuntu install to a BIOS Windows install, then Windows cannot find the BIOS data.

    From BIOS/UEFI you should be able to boot Windows in BIOS mode or from UEFI boot Ubuntu but you have to switch from UEFI to legacy/BIOS/AHCI or whatevery your system calls it every time.

    At this point probably easiest just to reinstall Ubuntu in BIOS mode. You can use gpt with Ubuntu in BIOS mode but it will need (and I think it creates) a bios_grub partition. To install in BIOS mode you have to boot installer in BIOS mode. Windows only boots from gpt drives with UEFI, but Ubuntu works either way.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  3. #3
    Join Date
    Jan 2008
    Location
    France
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Arrow Re: error: invalid efi path

    Quote Originally Posted by oldfred View Post
    At this point probably easiest just to reinstall Ubuntu in BIOS mode.
    +1
    IMHO the easiest way here is to:
    1) via Gparted, format the sdb1 partition. In the free space, create a BIOS-Boot partition ( see https://help.ubuntu.com/community/Di...n_GPT_disks.29 )
    2) Use Boot-Repair's Recommended Repair. (It should convert your Ubuntu into Legacy mode.) Indicate us the new URL that will appear.
    3) reboot the computer and tell us what you observe.

  4. #4
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: error: invalid efi path

    Thanks Yann, I knew Boot-Repair could convert a BIOS install to UEFI, but did not know it could do the reverse.

    I use the bios_grub partition as I only have BIOS but use gpt. I only needs to be 1MB and has to be unformatted. Then grub-pc will install correctly.

    In UEFI mode you use grub-efi and in BIOS mode you use grub-pc but the Ubuntu install is identical.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  5. #5
    Join Date
    Apr 2007
    Beans
    8

    Re: error: invalid efi path

    Awesome, thanks Yann & oldfred for both of your replies.

    I'm gonna attack this in about an hour and I'll be sure to reply with the results. Fingers crossed!

  6. #6
    Join Date
    Apr 2007
    Beans
    8

    Re: error: invalid efi path

    Well... it worked!

    I pretty much followed the instructions given and they were spot on. I can now boot into both Windows 7 and Ubuntu.

    One small annoyance is when booting into Ubuntu I get this message:

    "The disk drive for /boot/efi is not ready yet or not present.
    Press S to skip or M for manual recovery"

    Pressing S works fine and Ubuntu continues to load. But I'd rather not have to do this each time.

    Here is my updated boot info: paste.ubuntu.com/1416156

    Thanks so much guys, you saved me hours!

  7. #7
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: error: invalid efi path

    It may be related to this:
    /dev/sda1 ends after the last sector of /dev/sda
    Now that is from the protective MBR of sda, not the gpt table which is ok. So the protective MBR is only used to show tools like fdisk that are not updated to gpt to see that the drive is used.

    Download from repository and run gdisk. Sometimes it auto repairs things.

    sudo apt-get install gdisk

    sudo gdisk -l /dev/sda

    repair gpt:
    http://www.rodsbooks.com/gdisk/repairing.html


    Not sure if gdisk will update protective MBR or not?
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  8. #8
    Join Date
    Jan 2008
    Location
    France
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Arrow Re: error: invalid efi path

    Hi
    Quote Originally Posted by acidreign View Post
    "The disk drive for /boot/efi is not ready yet or not present.
    That is because Boot-Repair didn't manage to comment the /boot/efi line in your fstab.
    I just uploaded a fix in the PPA (boot-sav 3.195~ppa27).
    You can fix this issue manually, or by updating Boot-Repair then use Recommended Repair.

  9. #9
    Join Date
    Apr 2007
    Beans
    8

    Re: error: invalid efi path

    Cool, you guys are infinitely helpful. I'll comment that line later tonight when I have time.


    I should probably also mention for anyone reading this who might have the same issue: I had to disable "quick boot" in my bios for the initial fix to work. Even now, if I re-enable it - nothing works!

  10. #10
    Join Date
    Jan 2008
    Location
    France
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: error: invalid efi path

    Quote Originally Posted by acidreign View Post
    I had to disable "quick boot" in my bios for the initial fix to work. Even now, if I re-enable it - nothing works!
    Thanks for the feedback!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •