Results 1 to 3 of 3

Thread: BIND9 EDNS issues

  1. #1
    Join Date
    Dec 2012
    Beans
    11

    BIND9 EDNS issues

    Just setup Ubuntu server 12.10 and am getting a constant stream of the below:

    Dec 3 20:49:33 professorx named[6068]: DNS format error from 192.5.5.241#53 resolving ./NS: non-improving referral
    Dec 3 20:49:41 professorx named[6068]: success resolving './NS' (in '.'?) after disabling EDNS


    I've noticed quite a few timeouts that I suspect are related. When I add edns no; to my named.conf things seem to start working much better. Thoughts?

  2. #2
    Join Date
    Aug 2007
    Location
    Canada
    Beans
    420
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: BIND9 EDNS issues

    Give a look to this post, it may help

    http://www.linuxquestions.org/questi...-error-938406/
    Best, Gnusci

    "Never make a calculation until you know the answer." -- Wheeler, Spacetime Physics, pg 60.

  3. #3
    Join Date
    Dec 2012
    Beans
    11

    Re: BIND9 EDNS issues

    Quote Originally Posted by gnusci View Post
    Give a look to this post, it may help

    http://www.linuxquestions.org/questi...-error-938406/
    Not much in the way of fixes or explanations in that post (had run across it prior to posting here. It also didn't mention the failed queries due to that. If I go to google.com, once in a while it times out prior to resolving unless i disable edns.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •