Results 1 to 2 of 2

Thread: No Internet on Virtual Machine

  1. #1
    Join Date
    Nov 2012
    Beans
    1

    No Internet on Virtual Machine

    Hello everyone, I'm -fairly- new to Ubuntu and the Linux distro's themselves, and I recently swapped over because of a faulty Windows HDD (don't ask). When I try to run Windows 7 on VirtualBox, I can get logged in and everything, everything works except for the Internet. It only shows me a LAN connection that has network access but no Internet access. Can anyone help me? Would be greatly appreciated. Thanks!

  2. #2
    Join Date
    Oct 2009
    Location
    Elgin, IL USA
    Beans
    2,534
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: No Internet on Virtual Machine

    Does groups typed in an Ubuntu terminal show you being a member of vboxusers group? If not, maybe you need to add yourself to that group for networking to work from a guest OS.

    Code:
    sudo gpasswd -a your_ubuntu_username vboxusers
    Use your normal password (no characters will appear) when sudo asks for it. You may have to log out of X and back in for the added group to take effect.

    If it is not that, not sure why internet would not be working. Normally virtualbox does NAT for your guest OS, so any networking outside would appear to come from your Ubuntu host IP. Can you ping anything on your LAN (like your router) from the Windows guest?
    i5 650 3.2 GHz, 8 GB, nvidia GTX 550 Ti 32" 1080p | i7-4700, 8 GB, Intel HD 4600/nvidia GTX 765M 15.6" 1080p | etc.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •