I would like to compile Ekiga 4.0 in Ubuntu 12.04. A dependency is opal >= 3.10.9.

I tried to compile this version of opal but received the following error messages:

make[3]: Entering directory `/home/volker/Downloads/opal-3.10.9/plugins/video/H.263-1998'
[CC] h263-1998.cxx
h263-1998.cxx: In member function ‘virtual void H263_Base_EncoderContext::SetOption(const char*, const char*)’:
h263-1998.cxx:320:27: error: ‘CODEC_FLAG_H263P_UMV’ was not declared in this scope
h263-1998.cxx:322:28: error: ‘CODEC_FLAG_H263P_UMV’ was not declared in this scope
h263-1998.cxx:363:27: error: ‘CODEC_FLAG_H263P_SLICE_STRUCT’ was not declared in this scope
h263-1998.cxx:365:28: error: ‘CODEC_FLAG_H263P_SLICE_STRUCT’ was not declared in this scope
h263-1998.cxx:373:27: error: ‘CODEC_FLAG_H263P_AIV’ was not declared in this scope
h263-1998.cxx:375:28: error: ‘CODEC_FLAG_H263P_AIV’ was not declared in this scope
h263-1998.cxx: In member function ‘bool H263_Base_EncoderContext::OpenCodec()’:
h263-1998.cxx:455:3: error: ‘CODEC_FLAG_H263P_UMV’ was not declared in this scope
h263-1998.cxx:456:3: error: ‘CODEC_FLAG_OBMC’ was not declared in this scope
h263-1998.cxx:458:3: error: ‘CODEC_FLAG_H263P_SLICE_STRUCT’ was not declared in this scope
h263-1998.cxx:460:3: error: ‘CODEC_FLAG_H263P_AIV’ was not declared in this scope
h263-1998.cxx: In member function ‘virtual bool H263_Base_EncoderContext::EncodeFrames(const BYTE*, unsigned int&, BYTE*, unsigned int&, unsigned int&)’:
h263-1998.cxx:524:72: error: ‘FF_I_TYPE’ was not declared in this scope
h263-1998.cxx: In member function ‘virtual bool H263_RFC2190_EncoderContext::Init()’:
h263-1998.cxx:606:24: error: ‘CODEC_FLAG_H263P_UMV’ was not declared in this scope
h263-1998.cxx:611:24: error: ‘CODEC_FLAG_H263P_AIV’ was not declared in this scope
h263-1998.cxx:612:24: error: ‘CODEC_FLAG_H263P_SLICE_STRUCT’ was not declared in this scope
make[3]: *** [/home/volker/Downloads/opal-3.10.9/plugins/../lib_linux_x86_64/plugins/h263_ffmpeg/h263-1998.o] Error 1
make[3]: Leaving directory `/home/volker/Downloads/opal-3.10.9/plugins/video/H.263-1998'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/volker/Downloads/opal-3.10.9/plugins'
make[1]: *** [subdirs] Error 2
make[1]: Leaving directory `/home/volker/Downloads/opal-3.10.9'
make: *** [opt] Error 2

Is there a solution for this?