Results 1 to 8 of 8

Thread: having problems connecting to network folders

  1. #1
    Join Date
    Feb 2011
    Beans
    5

    having problems connecting to network folders

    hi all, having problems signing in to network folders from windows 7 and from this machine itself, i have been playing with smb.conf and am pretty sure my troubles lie in there, i am running 12.10 ubuntu and have included a pastebin of my smb.conf.

    thanks for any help RD

    http://pastebin.com/VGR30RaU

  2. #2
    Join Date
    Aug 2012
    Beans
    3

    Re: having problems connecting to network folders

    So I notice that you have security = user
    have you setup any samba users?

    A quick and dirty test would be to set that option to security = share and restart the service...

  3. #3
    Join Date
    Feb 2011
    Beans
    5

    Re: having problems connecting to network folders

    just tried with user = share still no luck accessing the shares with anything but my account.

    not sure what you mean by setup samba users, i installed the samba gui to change settings and added a user from there, but still cant access anything under that account.

  4. #4
    Join Date
    Aug 2012
    Beans
    3

    Re: having problems connecting to network folders

    Ahh ok, so the gui should have created users for you.

    The users in Samba are seperate to the users which you login to Linux with.

    So you can browse the share if you enter your username but not your other users?

  5. #5
    Join Date
    Dec 2009
    Beans
    5,563

    Re: having problems connecting to network folders

    Quote Originally Posted by JonArcher View Post
    So I notice that you have security = user
    have you setup any samba users?

    A quick and dirty test would be to set that option to security = share and restart the service...
    That's just not true.

    security = user is the default for a reason please don't change it. "map to guest = Bad User" will convert anonymous remote users to the default user ( nobody ) automatically.

    @RD2112, I'm confused by your post. Are you trying to access a share on your Linux box from Windows or the other way around?

    If you are trying to access a Linux share what are the permissions of the shared entity:
    Code:
    ls -dl "/media/rd/nptmtls/Newport Metals"

  6. #6
    Join Date
    Dec 2009
    Beans
    5,563

    Re: having problems connecting to network folders

    Missed something from your original post if you are trying to access a Linux share from Windows:
    i am running 12.10 ubuntu
    You shared a folder on /media/rd/nptmtls/Newport Metals and unless this is just a coincidence it's a partition that you are mounting when you need it as opposed to having it automount.

    12.10 changed how this is done as it mount it to /media/$USER with access allowed only to $USER. THe remote users are not rd ( at least not all of them ) so in your case kelly has no access. The easiest way out of this is to modify your share definition in my opinion.

    Edit smb.conf as root:
    Code:
    gksu gedit /etc/samba/smb.conf
    Change this:
    [Newport Metals]
    comment = newport documents
    path = /media/rd/nptmtls/Newport Metals
    writeable = yes
    browseable = yes
    valid users = kelly, rd
    To this:
    [Newport Metals]
    comment = newport documents
    path = /media/rd/nptmtls/Newport Metals
    writeable = yes
    browseable = yes
    valid users = kelly, rd
    force user = rd
    Then restart samba:
    Code:
    sudo service smbd restart
    The "valid users" line will restrict access to kelly and rd and the "force user" will convert them both to rd after samba allows access.

  7. #7
    Join Date
    Aug 2012
    Beans
    3

    Re: having problems connecting to network folders

    Quote Originally Posted by Morbius1 View Post
    That's just not true.

    security = user is the default for a reason please don't change it.
    Yes but changing to share will allow a connection test without authentication and can rule out any initial connection problems, and it can easily be changed back afterwards!
    Last edited by JonArcher; November 27th, 2012 at 06:29 PM.

  8. #8
    Join Date
    Feb 2011
    Beans
    5

    Re: having problems connecting to network folders

    changing the smb.conf file to add this made it work.

    To this:
    Quote:
    [Newport Metals]
    comment = newport documents
    path = /media/rd/nptmtls/Newport Metals
    writeable = yes
    browseable = yes
    valid users = kelly, rd
    force user = rd

    thank you Morbius1 for your help was going to ask how to change mount points, but after changing that spot inthe config file it worked, then after i found that changing sharing options outsde of the samba gui adds a second entry to the server so i had duplicat entries. so have spent the last hour on clean up..

    thanks to everyone who jumped to help, you guys are what makes Ubuntu as awesome as it is : )

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •