Results 1 to 8 of 8

Thread: XFCE sanp to window wont disable.

  1. #1
    Join Date
    Jan 2011
    Beans
    22

    XFCE sanp to window wont disable.

    How can I stop the Snap to windows it wont disable at all.

  2. #2
    Join Date
    Oct 2008
    Location
    Ottawa, Canada
    Beans
    806
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: XFCE sanp to window wont disable.

    You should provide a bit more details about what you are running and what you tried already.

    On Xubuntu 12.10/Xfce 4.10, you can disable Window snapping in Settings Manager -> Window Manager -> Advanced -> Snap windows to other windows. Works perfectly here.

    Cheers!
    husband@wife$ make sandwich
    Permission denied
    husband@wife$ sudo make sandwich

  3. #3
    Join Date
    Oct 2006
    Location
    Austin, TX
    Beans
    199
    Distro
    Kubuntu

    Re: XFCE sanp to window wont disable.

    I'm going to bump this because this is my exact problem. I use two monitors, set up with an xandr script that runs on startup (shown below for reference, in case this has anything to do with it). My problem is that I cannot move a window from one workspace to another because as soon as it gets close to the screen edge, it "snaps" and resizes itself. A very annoying feature I don't want. I have window snap disabled in the Window Manager Advanced settings but it doesn't make any difference, they still insist on snapping.

    By the way, this also happens on the laptop, using only it's one monitor. I can however move a window from one workspace to another but it still insists on snapping the window for me on top and bottom screen edges even though I have the feature turned off.

    The script:

    xrandr --newmode "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync
    sleep 1
    xrandr --addmode VGA-0 1280x1024_60.00
    sleep 1
    xrandr --output VGA-0 --mode 1280x1024_60.00 --pos 1920x312 --rotate normal --output DVI-0 --mode 1920x1080 --pos 0x0 --rotate normal --output HDMI-0 --off
    Last edited by scottbomb; March 10th, 2013 at 11:09 PM.

  4. #4
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: XFCE sanp to window wont disable.

    Depending on the version of Xubuntu/Xfce that you are running, you may also have to disable "Window Manager Tweaks -> Accessibility -> Automatically tile windows when moving toward the screen edge".

  5. #5
    Join Date
    Oct 2006
    Location
    Austin, TX
    Beans
    199
    Distro
    Kubuntu

    Re: XFCE sanp to window wont disable.

    Thank you Toz! That was it! This has been bothering me for about two years now and it's finally solved. It never occurred to me that there would be another setting that does basically the same thing. I changed that setting on the laptop and it's no longer "snapping". I can't try it on the big PC right now but I'll consider it fixed there too. Otherwise, I'll post back here tomorrow.

  6. #6
    Join Date
    Oct 2006
    Location
    Austin, TX
    Beans
    199
    Distro
    Kubuntu

    Re: XFCE sanp to window wont disable.

    Well it fixed the problem on the laptop and it's no longer snapping on the desktop, however the desktop still won't let me move a window between workspace. I can right-click the title bar and select "move to another workspace" but I can't drag the window. I googled this problem and found answers related to compiz and unity but I'm not using either, just xfce.

  7. #7
    Join Date
    Oct 2008
    Location
    Ottawa, Canada
    Beans
    806
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: XFCE sanp to window wont disable.

    To drag windows across workspaces, you have to enable it.
    Check: Settings -> Window Manager -> Advanced -> Wrap workspaces when dragging a window off the screen.
    Note that this automatically disables the aforementioned automatic tiling (although it doesn't uncheck it). So you can't have both.
    husband@wife$ make sandwich
    Permission denied
    husband@wife$ sudo make sandwich

  8. #8
    Join Date
    Jun 2011
    Beans
    1

    Re: XFCE sanp to window wont disable.

    Thank you so much for this. Although a year old thank god for these forums. I have hated the window snapping action on the fvwm window manager with such a passion. Figures its in one of the settings apps... but where?? I understand this is linux but we all could take a few ui lessons from Windows. Their UI stuff does work...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •