Results 1 to 4 of 4

Thread: HP Photosmart C310 - scanner not working after upgrade

  1. #1
    Join Date
    Jun 2006
    Beans
    53

    Angry HP Photosmart C310 - scanner not working after upgrade

    I have a HP Photosmart C310 network printer and scanner.

    I had been using both the scanner and the printer successfully over wifi network using my laptop with Ubuntu 12.04 (64) after installing HPLIP toolbox through the software centre.

    However, after an upgrade to 12.10 (64) I now get the following error when trying to scan using xsane:
    Failed to open device 'hpaio:/net/photosmart_Prem_C310_series?zc=HPCEB!CD':Error during device I/O

    Printing still works fine.

    Help appreciated, I have googled and can't find a solution. I have seen that the HPLIB in the software centre is not the most up to date but it looks like I'd have to manual build the most up to date version which sounds a bit scary.

  2. #2
    Join Date
    Nov 2009
    Beans
    5

    Re: HP Photosmart C310 - scanner not working after upgrade

    I'm having the same problem

  3. #3
    Join Date
    Nov 2009
    Beans
    5

    Re: HP Photosmart C310 - scanner not working after upgrade

    I've upgraded to hplip 3.12.11 and it now works

    http://hplipopensource.com/hplip-web/downloads.html

  4. #4
    Join Date
    Jun 2006
    Beans
    53

    Talking Re: HP Photosmart C310 - scanner not working after upgrade

    yeay fixed

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •