Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: Client Pc to NFS Server

  1. #1
    Join Date
    Aug 2011
    Beans
    95
    Distro
    Ubuntu 12.04 Precise Pangolin

    Question Client Pc to NFS Server

    Hey guys, I just exported a file directory from my sever to be shared to my personal laptop. I used the single host option and entered in my ip address and I think I did everything correct on the export side via webmin.
    The code I am using on my side via shell is
    sudo mount 192.168.1.7: /home/bstrizzy/music /home/bstrawt/Music

    and i keep getting this
    Code:
    Usage: mount -V                 : print version
           mount -h                 : print this help
           mount                    : list mounted filesystems
           mount -l                 : idem, including volume labels
    So far the informational part. Next the mounting.
    The command is `mount [-t fstype] something somewhere'.
    Details found in /etc/fstab may be omitted.
           mount -a [-t|-O] ...     : mount all stuff from /etc/fstab
           mount device             : mo
    and pretty much the whole help text

    what is going on?
    Last edited by lisati; December 2nd, 2012 at 08:07 AM. Reason: added [code] and [/code] tags, removed [size] and [/size], to aid readability

  2. #2
    Join Date
    Dec 2009
    Location
    germany
    Beans
    1,020
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Client Pc to NFS Server Help

    Quote Originally Posted by BStrizzy View Post
    Hey guys, I just exported a file directory from my sever to be shared to my personal laptop. I used the single host option and entered in my ip address and I think I did everything correct on the export side via webmin.
    The code I am using on my side via shell is
    sudo mount 192.168.1.7: /home/bstrizzy/music /home/bstrawt/Music

    and i keep getting this

    Code:
    Usage: mount -V                 : print version
           mount -h                 : print this help
           mount                    : list mounted filesystems
           mount -l                 : idem, including volume labels
    So far the informational part. Next the mounting.
    The command is `mount [-t fstype] something somewhere'.
    Details found in /etc/fstab may be omitted.
           mount -a [-t|-O] ...     : mount all stuff from /etc/fstab
           mount device             : mo
    and pretty much the whole help text

    what is going on?
    mount -t nfs .......... ..........
    Last edited by lisati; December 2nd, 2012 at 08:08 AM. Reason: edited quote
    "What is the robbing of a bank compared to the FOUNDING of a bank?" Berthold Brecht

  3. #3
    Join Date
    Aug 2011
    Beans
    95
    Distro
    Ubuntu 12.04 Precise Pangolin

    Exclamation Re: Client Pc to NFS Server Help

    Quote Originally Posted by rnerwein View Post
    mount -t nfs .......... ..........

    Mounts


    Check to see if everything works

    You should try and mount it now. The basic template you will use is:
    sudo mount ServerIP:/folder/already/setup/to/be/shared /home/username/folder/in/your/local/computerso for example:

    sudo mount 192.168.1.42:/home/music /home/poningru/music


    from ubuntu thread https://help.ubuntu.com/community/SettingUpNFSHowTo

    might need to update this!

  4. #4
    Join Date
    Aug 2011
    Beans
    95
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Client Pc to NFS Server Help

    Quote Originally Posted by rnerwein View Post
    mount -t nfs .......... ..........

    this does not work help!! I am trying to mount my home music folder on ubuntu desktop to my music on my server. i keep getting the index when i use this too. i try this in both my shell on desktop and on my ssh

  5. #5
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    8,995
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Client Pc to NFS Server Help

    sudo mount 192.168.1.7: /home/bstrizzy/music /home/bstrawt/Music
    It appears you have a space between the colon and /home. Remove it.

    And you do not need to specify the filesystem type with -t for NFS mounts. The mount command deduces it is an NFS mount when it encounters the "server:/share" syntax.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  6. #6
    Join Date
    Aug 2011
    Beans
    95
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Client Pc to NFS Server Help

    Quote Originally Posted by SeijiSensei View Post
    It appears you have a space between the colon and /home. Remove it.

    And you do not need to specify the filesystem type with -t for NFS mounts. The mount command deduces it is an NFS mount when it encounters the "server:/share" syntax.
    by file system you mean?

  7. #7
    Join Date
    Dec 2009
    Location
    germany
    Beans
    1,020
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Client Pc to NFS Server Help

    Quote Originally Posted by BStrizzy View Post
    by file system you mean?
    good morning
    i just looked at your weblink and saw the "-t" option has changed from "nfs" to "nfs4".
    try: mount -t nfs4 ...... ......
    good luck

    P.S. man pages told me: nfs4 is deprecated. -t nfs must be ok
    Last edited by rnerwein; December 2nd, 2012 at 09:03 AM. Reason: just installed nfs-client on my 10.4 ubuntu and saw nfs4 is deprecated
    "What is the robbing of a bank compared to the FOUNDING of a bank?" Berthold Brecht

  8. #8
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    8,995
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Client Pc to NFS Server Help

    Quote Originally Posted by BStrizzy View Post
    by file system you mean?
    Things like ext4, ntfs, nfs, smbfs, etc., etc. All the different types of, well, "filesystems" that Linux supports. From the manual page for mount ("man mount"):

    -t, --types vfstype
    The argument following the -t is used to indicate the filesystem type. The filesystem types which are currently supported include: adfs, affs, autofs, cifs, coda, coherent, cramfs, debugfs, devpts, efs, ext, ext2, ext3, ext4, hfs, hfsplus, hpfs, iso9660, jfs, minix, msdos, ncpfs, nfs, nfs4, ntfs, proc, qnx4, ramfs, reiserfs, romfs, squashfs, smbfs, sysv, tmpfs, ubifs, udf, ufs, umsdos, usbfs, vfat, xenix, xfs, xiafs.
    Did removing the space fix your problem?
    Last edited by SeijiSensei; December 2nd, 2012 at 03:46 PM.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  9. #9
    Join Date
    Aug 2011
    Beans
    95
    Distro
    Ubuntu 12.04 Precise Pangolin

    Exclamation Re: Client Pc to NFS Server Help

    Quote Originally Posted by SeijiSensei View Post
    Things like ext4, ntfs, nfs, smbfs, etc., etc. All the different types of, well, "filesystems" that Linux supports. From the manual page for mount ("man mount"):



    Did removing the space fix your problem?
    it did not fix my problem, but when i added the 4 after nfs4, it seemed to work a little better.

    bstrawt@panama:~$ sudo mount -t nfs4 192.168.1.7:/home/bstrizzy/music /home/bstrawt/music
    mount.nfs4: mounting 192.168.1.7:/home/bstrizzy/music failed, reason given by server:
    No such file or directory

    the file I am trying to link is the file on my server with a music file on my home directory, do i need to put my desktop ipaddress before the destination mount? I tried that and it still didnt work. I will copy and paste my set up via webmin.

    is my ipv4 network suppose to be 192.168.1.0 or 192.168.1.1 or 192.168.1.0/8 ? maybe this is the issue? see pic attached
    Attached Images Attached Images

  10. #10
    Join Date
    Aug 2011
    Beans
    95
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Client Pc to NFS Server Help

    Quote Originally Posted by rnerwein View Post
    good morning
    i just looked at your weblink and saw the "-t" option has changed from "nfs" to "nfs4".
    try: mount -t nfs4 ...... ......
    good luck

    P.S. man pages told me: nfs4 is deprecated. -t nfs must be ok

    it did not fix my problem, but when i added the 4 after nfs4, it seemed to work a little better.

    bstrawt@panama:~$ sudo mount -t nfs4 192.168.1.7:/home/bstrizzy/music /home/bstrawt/music
    mount.nfs4: mounting 192.168.1.7:/home/bstrizzy/music failed, reason given by server:
    No such file or directory

    the file I am trying to link is the file on my server with a music file on my home directory, do i need to put my desktop ipaddress before the destination mount? I tried that and it still didnt work. I will copy and paste my set up via webmin.

    is my ipv4 network suppose to be 192.168.1.0 or 192.168.1.1 or 192.168.1.0/8 ? maybe this is the issue?
    Attached Images Attached Images

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •