Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: What if I don't upgrade...

  1. #1
    Join Date
    Dec 2009
    Beans
    72
    Distro
    Ubuntu 10.04 Lucid Lynx

    What if I don't upgrade...

    I am using Lucid Lynx. What if I don't upgrade by this coming April. How will it hurt me if the version is no longer supported?

  2. #2
    Join Date
    Nov 2012
    Beans
    23

    Re: What if I don't upgrade...

    If you no longer receive security upgrades, wouldn't that put your OS at risk?

  3. #3
    Join Date
    Jul 2006
    Location
    Castrum, Germania Secunda
    Beans
    1,071

    Re: What if I don't upgrade...

    It would *indeed* put your operating system at risk. Expect being hacked and/or being taken over by a botnet. And so forth and so forth...

    In short: upgrade in time to (for example) the excellent 12.04 LTS. If you don't like Unity, consider Xubuntu 12.04:
    https://sites.google.com/site/easyli...roject/xubuntu

  4. #4
    Join Date
    Dec 2009
    Beans
    72
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: What if I don't upgrade...

    Quote Originally Posted by DukeOfMixture View Post
    If you no longer receive security upgrades, wouldn't that put your OS at risk?
    Would it really or is this an empty threat?
    Software I use often.. Blender 3d graphics .. works well on Lucid, and I have had problems in the past.
    I don't want Unity, and and am so disgusted by the idea of the Amazon suggestions crap that I might look for another flavor of linux.
    I will go back to Gnome as fast as I can run, if I do upgrade.

  5. #5
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    10,960
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: What if I don't upgrade...

    I too had reservations about 12.04; I installed it a few months back just to see what all the foo-fer-all was about. Never went back to 10.04.

    12.04 is faster and cleaner, just takes a readjustment of mind set. And remember, this is ubuntu, all things are configurable (can opt out on the Amazon thing).

    Unity is the wave of the future, not only in ubuntu but numerous devices; May as well start developing that mind set now !

    just my humble opinion < == BDQ

  6. #6
    Join Date
    Jan 2008
    Beans
    7,749

    Re: What if I don't upgrade...

    Gnome runs fine in 12.04 (you don't have to use Unity if you don't want to) and they've actually changed the desktop LTS support policy from 3 years to 5 years (thru April 2017 for 12.04).

    Lots of people run obsolete end-of-life operating systems, browsers, and other applications, and most of them don't have their security/data/identities compromised. It is your decision whether you can live with the risk. (Possibly taking steps to mitigate the risk such as manually keeping your browser up to date.)

    Keep in mind "end of life" means not only "no more security updates from Canonical" but also "continued support from PPA's and 3rd-party developers is unlikely, and you will get less support on UbuntuForums as the majority of users will move on to supported releases."

  7. #7
    Join Date
    Nov 2012
    Beans
    23

    Re: What if I don't upgrade...

    Quote Originally Posted by confubar View Post
    Would it really or is this an empty threat?
    What? Do you think I was threatening you?

  8. #8
    Join Date
    Sep 2011
    Location
    Pennsylvania, U.S.A.
    Beans
    2,272
    Distro
    Ubuntu Development Release

    Re: What if I don't upgrade...

    Quote Originally Posted by snowpine View Post
    Gnome runs fine in 12.04 (you don't have to use Unity if you don't want to) and they've actually changed the desktop LTS support policy from 3 years to 5 years (thru April 2017 for 12.04).

    Lots of people run obsolete end-of-life operating systems, browsers, and other applications, and most of them don't have their security/data/identities compromised. It is your decision whether you can live with the risk. (Possibly taking steps to mitigate the risk such as manually keeping your browser up to date.)

    Keep in mind "end of life" means not only "no more security updates from Canonical" but also "continued support from PPA's and 3rd-party developers is unlikely, and you will get less support on UbuntuForums as the majority of users will move on to supported releases."
    I'm running 12.04 with gnome shell and 12.10 gnome remix/Unity-free. Xubuntu 12.04 seems to work very well as does Lubuntu12.04 though I don't know about the support duration for Xubuntu & Lubuntu. Remember that Unity is really just a compiz plugin, there's a lot more to Ubuntu than Unity. There's also MATE desktop and Cinnamon. Cinnamon seems like a nice option, didn't care for MATE. Lotsa non-Unity choices.

  9. #9
    Join Date
    Feb 2010
    Location
    Land of Confusion
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: What if I don't upgrade...

    Quote Originally Posted by confubar View Post
    Would it really or is this an empty threat?
    I think it depends on your browsing habits. If you don't mind installing Firefox manually, then you can have a secure system for years to come. Close all listening ports and keep all internet facing applications up to date.
    Last edited by uRock; December 14th, 2012 at 02:15 PM.
    Thank you for your contributions. "So long and thanks for the fish!"

  10. #10
    Join Date
    Dec 2007
    Location
    California
    Beans
    4,912
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: What if I don't upgrade...

    Quote Originally Posted by confubar View Post
    I am using Lucid Lynx. What if I don't upgrade by this coming April. How will it hurt me if the version is no longer supported?
    Is there any compelling reason to not upgrade?

    As mentioned, if it's gnome3 (gnome-shell or unity) you don't want, then just use XFCE, or one of the gnome2 forks (mate, cinnamon).

    12.04 LTS doesn't have the unity-shopping lens installed by default, even if it was you can always remove it or disable it via privacy settings if you have privacy issues with it.
    "You can't expect to hold supreme executive power just because some watery tart lobbed a sword at you"

    "Don't let your mind wander -- it's too little to be let out alone."

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •