Page 1 of 8 123 ... LastLast
Results 1 to 10 of 76

Thread: Could not connect to JACK server as client. - Overall operation failed. - Unable ...

  1. #1
    Join Date
    Jul 2010
    Beans
    20

    Could not connect to JACK server as client. - Overall operation failed. - Unable ...

    p, li { white-space: pre-wrap; } Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info. (this is the messages window)



    Hm... now what?



    This is what it said in the window:

    p, li { white-space: pre-wrap; }
    09:47:06.691 Patchbay deactivated.
    09:47:07.979 Statistics reset.
    09:47:08.290 ALSA connection graph change.
    09:47:10.636 ALSA connection change.
    09:47:56.975 ALSA connection graph change.
    09:47:57.232 ALSA connection change.
    09:48:18.546 ALSA connection change.
    09:53:49.220 ALSA connection change.
    09:53:51.629 ALSA connection change.
    09:56:33.090 Startup script...
    09:56:33.094 artsshell -q terminate
    sh: artsshell: not found
    09:56:33.576 Startup script terminated with exit status=32512.
    09:56:33.579 JACK is starting...
    09:56:33.580 /usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n2
    09:56:33.618 JACK was started with PID=1904.
    jackd 0.118.0
    Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
    jackd comes with ABSOLUTELY NO WARRANTY
    This is free software, and you are welcome to redistribute it
    under certain conditions; see the file COPYING for details
    JACK is running in realtime mode, but you are not allowed to use realtime scheduling.
    Your system has an audio group, but you are not a member of it.
    Please add yourself to the audio group by executing (as root):
    usermod -a -G audio (null)
    After applying these changes, please re-login in order for them to take effect.
    You don't appear to have a sane system configuration. It is very likely that you
    encounter xruns. Please apply all the above mentioned changes and start jack again!
    09:56:33.727 JACK was stopped with exit status=255.
    09:56:33.729 Post-shutdown script...
    09:56:33.736 killall jackd
    jackd: no process found
    09:56:34.248 Post-shutdown script terminated with exit status=256.
    09:56:36.265 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.


    So...? Any ideas? Thank you.

  2. #2
    Join Date
    Aug 2010
    Beans
    1

    Red face Re: Could not connect to JACK server as client. - Overall operation failed. - Unable

    I.m having the same issue could use some suggestions i have tried to reconfigure but it does not seem to change AHHHHHHHHHHHH!!!!!!!!!!!!!!!!!!!!!!!!!

  3. #3
    Join Date
    Jan 2009
    Location
    The Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Could not connect to JACK server as client. - Overall operation failed. - Unable

    Code:
    JACK is running in realtime mode, but you are not allowed to use realtime scheduling.
    Your system has an audio group, but you are not a member of it.
    Please add yourself to the audio group by executing (as root):
    usermod -a -G audio (null)
    After applying these changes, please re-login in order for them to take effect.
    You don't appear to have a sane system configuration. It is very likely that you
    encounter xruns. Please apply all the above mentioned changes and start jack again!
    So either untick the realtime option in the setup window of QjackCtl or add your account to the audio group and make sure your /etc/security/limits.d/audio.conf file is there and has the following lines in it:
    Code:
    @audio   -  rtprio     99
    @audio   -  memlock    unlimited
    You could also run dpkg-reconfigure -p high jackd in a terminal and select Yes to enable realtime process priority.

  4. #4
    Join Date
    Jul 2010
    Beans
    20

    Re: Could not connect to JACK server as client. - Overall operation failed. - Unable

    Okay, I went the file and this is what it said in the article? Do I need to change anything?

    # generated by jackd's postinst.
    #
    # Do not edit this file by hand, use
    #
    # dpkg-reconfigure -p high jackd
    #
    # instead.
    @audio - rtprio 99
    @audio - memlock unlimited
    #@audio - nice -19

  5. #5
    Join Date
    Jan 2009
    Location
    The Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Could not connect to JACK server as client. - Overall operation failed. - Unable

    Looks good. But you're probably not a member of the 'audio' group so could you add yourself to it? System - Administration - Users and Groups then unlock the application and select Manage Groups. Then select the audio group, click Properties and tick your username. If you want to prevent RSI you could also open a terminal and enter sudo usermod -a -G audio yourusername

  6. #6
    Join Date
    Jul 2010
    Beans
    20

    Re: Could not connect to JACK server as client. - Overall operation failed. - Unable

    Okay. I added myself to the audio group. Then went back into JACK.

    This is what it said:

    p, li { white-space: pre-wrap; } 15:33:39.205 Startup script...
    15:33:39.208 artsshell -q terminate
    sh: artsshell: not found
    15:33:39.610 Startup script terminated with exit status=32512.
    15:33:39.610 JACK is starting...
    15:33:39.611 /usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n2
    jackd 0.118.0
    Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
    jackd comes with ABSOLUTELY NO WARRANTY
    This is free software, and you are welcome to redistribute it
    under certain conditions; see the file COPYING for details
    JACK is running in realtime mode, but you are not allowed to use realtime scheduling.
    15:33:39.632 JACK was started with PID=2606.
    Please check your /etc/security/limits.conf for the following lines
    and correct/add them:
    @audio - rtprio 100
    @audio - nice -10
    After applying these changes, please re-login in order for them to take effect.
    You don't appear to have a sane system configuration. It is very likely that you
    encounter xruns. Please apply all the above mentioned changes and start jack again!
    15:33:39.650 JACK was stopped with exit status=255.
    15:33:39.651 Post-shutdown script...
    15:33:39.651 killall jackd
    jackd: no process found
    15:33:40.063 Post-shutdown script terminated with exit status=256.
    15:33:41.701 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.

  7. #7
    Join Date
    Nov 2009
    Beans
    1,879
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: Could not connect to JACK server as client. - Overall operation failed. - Unable

    If you are using 9.10 or earlier, then you need to edit /etc/security/limits.conf and not the one mentioned earlier.

  8. #8
    Join Date
    Jan 2009
    Location
    The Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Could not connect to JACK server as client. - Overall operation failed. - Unable

    9.10 doesn't ship with jackd 0.118.0

    timtincher, could you post the output of the groups command in a terminal and the content of both /etc/security/limits.conf and /etc/security/limits.d/audio.conf files?

  9. #9
    Join Date
    Jun 2008
    Location
    Gipuzkoa, Spain
    Beans
    732
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: Could not connect to JACK server as client. - Overall operation failed. - Unable

    Could you post the output of the following commands, in addition to what Auto suggested?

    ulimit -r

    ulimit -l

    I wonder because some users have problems with jack in realtime, even if they belong to the audio group and have the security limits OK. This happens at least, if they use the SLIM login manager which apparently does not load the pam limits module. If this is the case, it seems that rtprio and memlock can't be configured from /etc/security/limits.conf (or limits.d/audio.conf).

    Cheers! Pablo

  10. #10
    Join Date
    Jan 2009
    Location
    The Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Could not connect to JACK server as client. - Overall operation failed. - Unable

    Afaik the versions of slim that are available for Karmic and Lucid do support PAM.

Page 1 of 8 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •