Results 1 to 8 of 8

Thread: no sound (not a noob)

  1. #1
    Join Date
    Dec 2010
    Location
    Ohio Pickerington
    Beans
    45
    Distro
    Ubuntu

    no sound (not a noob)

    I just installed Ubuntu 12.04 and I am unable to get my sound to work. my first thought was to go into the sound options in system settings but when I click on it nothing happens. sometimes it even freezes when I click on it, making it so that I can not even close that window. I even tried opening it through the dash but nothing works. should I install another program and delete the one that comes with Ubuntu?

  2. #2
    Join Date
    Jan 2012
    Location
    Wisconsin
    Beans
    Hidden!
    Distro
    Lubuntu

    Re: no sound (not a noob)

    I had a similar problem after installing certain programs... What I did to fix it was reinstalled the restricted extra's.
    Give yourself 6 months and you will love Ubuntu too!

  3. #3
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: no sound (not a noob)

    Hi ,
    1st attempt

    Open a terminal and write
    Code:
    alsamixer
    see there if something is muted [MM] , if yes then unmute with M key on your keyboard. You can navigate with arrow keys (left-right) , you can increase - decrease volume with arrow keys (up-down). [ESC] to exit.

    2nd attempt
    Open a terminal and do
    Code:
    killall pulseaudio 
    rm -r .pulse/
    sudo apt-get install --reinstall  pavucontrol linux-sound-base alsa-base alsa-utils ubuntu-desktop  linux-image-`uname -r` libasound2
    sudo alsa force-reload
    Open pavucontrol and try to select your speakers from there.

    3rd attempt - debugging
    If none of above works , then open a terminal and do
    Code:
    wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && chmod +x ./alsa-info.sh && ./alsa-info.sh
    at the question
    Automatically upload ALSA information to www.alsa-project.org? [y/N]
    answer y(es) and give here the link.

    Thanks
    # How to mark the Thread as [SOLVED] when done.
    # Ubuntu Greek Community
    # Gain 20GB of space on copy.com when sign up with my referral link.

  4. #4
    Join Date
    Oct 2009
    Location
    Elgin, IL USA
    Beans
    2,533
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: no sound (not a noob)

    While I have never had any problem with analog stereo sound in Ubuntu (other than default sometimes muted on fresh install) digital or HDMI audio may require additional configuration depending upon what hardware you have. In a terminal, besides trying alsamixer, see what, if any, output you get from aplay -l (small L) and aplay -L (capital L). The former should list the default audio device and latter all available audio devices. You might also post what sudo lspci -v shows about your audio device.

    Note that to make things easier to follow that have indents or columns, wrap that output in code tags by highlighting it and clicking # in the message window.

    I did have a problem with no sound in Lubuntu on a tablet PC. In that case alsamixer did not show any PCM device. The only way I could get it to work was to install pulseaudio and pavucontrol (but the latter is not installed in Ubuntu 12.04 and it looks like it uses indicator-sound instead). After installing pulseaudio, alsamixer showed a PCM device and sound worked.

    Although, I have regular Debian sound working fine in a virtualbox using just alsa related audio.
    i5 650 3.2 GHz, 8 GB, nvidia GTX 550 Ti 32" 1080p | i7-4700, 8 GB, Intel HD 4600/nvidia GTX 765M 15.6" 1080p | etc.

  5. #5
    Join Date
    Dec 2010
    Location
    Ohio Pickerington
    Beans
    45
    Distro
    Ubuntu

    Re: no sound (not a noob)

    I tryed the first two of NikTh's post.

    first the one of the mixer settings was muted, but the problem still not fixed.

    the second thing. for some reason this made some windows that I had tried to open earlier but was unable to open pop up which is weird. I am now able to open sound under the system settings but nothing works. I closed the window and now it wont pop up again.

    the volume menu button also will not drop down.

  6. #6
    Join Date
    Dec 2010
    Location
    Ohio Pickerington
    Beans
    45
    Distro
    Ubuntu

    Re: no sound (not a noob)

    bump

  7. #7
    Join Date
    Dec 2010
    Location
    Ohio Pickerington
    Beans
    45
    Distro
    Ubuntu

    Re: no sound (not a noob)

    NikTh

    dmesg │
    │ lspci │
    │ lsmod │
    │ aplay │
    │ amixer │
    │ alsactl │
    │ /proc/asound/ │
    │ /sys/class/sound/ │
    │ ~/.asoundrc (etc.)

    See './alsa-info.sh --help' for command line options.

  8. #8
    Join Date
    Dec 2010
    Location
    Ohio Pickerington
    Beans
    45
    Distro
    Ubuntu

    Re: no sound (not a noob)

    Bump

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •