Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: 11.04 Upgrade - Canon MF4350d does not work anymore

  1. #1
    Join Date
    Jul 2008
    Beans
    13

    11.04 Upgrade - Canon MF4350d does not work anymore

    Hi,

    I upgraded from 10.10 to 11.04 32 bits and my Canon MF4350D does not work anymore. I used to install the drivers using Debian packages provided by Canon support (UFR_II_Printer_Driver_for_Linux_V220_uk_EN).

    I tried to re-install them and I cannot because gs-esp is missing (I think it is now obsolete). Then I tried to provide the PPD file from the Deb package, but still no luck as it complains that the pstoufr2cpca cups filter is missing. I finally tried to manually compile / install this filter from the Canon source archive, still no luck (does not compile, missing cups.h).

    Help!

  2. #2
    Join Date
    Apr 2009
    Location
    Papakura, NEW ZEALAND
    Beans
    42
    Distro
    Ubuntu Development Release

    Smile Re: 11.04 Upgrade - Canon MF4350d does not work anymore

    Try the attached file, extract the DEB from it, double click it and install it. It does nothing, except it tells your system that "gs-esp" is PROVIDED by the package "fake-gs-esp"

    It then allows me to install cndrvcups-common_2.20.deb

    Let me know how it works out.

    extra thoughts:
    if I was you I would not trust this file, to verify that it is not dangerous, right click on it and choose open with Archive Manager, in it you'll find one folder called "DEBIAN" in it you will only find 2 files:

    1. one is a "control", that says how to install it. It's contents are:

    Code:
    Package: fake-gs-esp
    Version: 1.0
    Architecture: all
    Depends: ghostscript-x
    Provides: gs-esp
    Installed-Size: 1
    Description: Provides a fake package for gs-esp so that Canon printer drivers will work. Specifically, it meets the dependency ofgs-esp for cndrvscups-common
    1. And another called "debian-binary" that has the contents of:

    Code:
    2.0\n
    Please do let me know if this works. Thanks
    Attached Files Attached Files
    Last edited by dionblundell; May 2nd, 2011 at 09:26 AM. Reason: extra thoughts
    Ubuntu 10.04 NBR on Asus EeePC 1005PE

    If you don't hear back from me, I forgot to subscribe to the thread, sorry... send me a message, to give me a poke and wake me up.

  3. #3
    Join Date
    Jul 2008
    Beans
    13

    Re: 11.04 Upgrade - Canon MF4350d does not work anymore

    Hi,

    It worked great! I installed the fake package after verifying its content and re-installed the drivers. I think simply restarting cups could have done it but I did not take any chances. Now my printer is back online.

    Thank you very much for your help, this was a major problem for me!

  4. #4
    Join Date
    May 2011
    Beans
    1

    Re: 11.04 Upgrade - Canon MF4350d does not work anymore

    Ditto. This technique also allowed me to get my Canon MF4270 printer working in Ubuntu 11.04. Thank you!

    Bob Pok

  5. #5
    Join Date
    May 2011
    Beans
    1

    Re: 11.04 Upgrade - Canon MF4350d does not work anymore

    Hi,
    Thanks, It worked great with my MF4010 .

  6. #6
    Join Date
    May 2011
    Beans
    1

    Re: 11.04 Upgrade - Canon MF4350d does not work anymore

    Hi guys: I did upgrade recently to ubuntu 11.04 and my canon MF4150 printer was working fine with version 10.04. Now I have a message that reads "missing filter for MF4150" I read your posts and I think that this is the way to follow. However, I am not an experienced user (I am merely a user that likes ubuntu) and I will appreciate if you write detailed instructions for the installation procces (uninstalling drivers, reinstalling, installing the zip file etc.) thank you.

  7. #7
    Join Date
    Jul 2008
    Beans
    13

    Re: 11.04 Upgrade - Canon MF4350d does not work anymore

    Hi,

    The first step is to install the package provide above. Download it and extract the Debian pacakge on your disk. Then right click on it and open it with the archive archive manager. Inside the archive manager, ensure the content is as described. Then close the archive manager.

    Right click on the fake package again and install it with the GDebi package installer.

    Download the driver archive from the Canon website here.

    Extract it. Navigate in the extracted folder, either in 32 bits or 64 bits driver folder depending on your Ubuntu installation. Then go in the Debian folder. In the 32 bits version, right click on the common package and install it with GDebi. Then right click on the other package and install it with GDebi.

    If you have the 64 bit version, you will need to install the RPM. I found this info but did not try it myself. From the console, install Alien:

    Code:
    sudo apt-get install alien
    Still in the terminal, navigate to the folder where you extracted the RPM and install them:
    Code:
    sudo alien -k cndrvcups-common-2.20-1.x86_64.rpm 
    sudo alien -k cndrvcups-ufr2-uk-2.20-1.x86_64.rpm
    Hope this helps!

  8. #8
    Join Date
    Aug 2010
    Beans
    50

    Re: 11.04 Upgrade - Canon MF4350d does not work anymore

    Hi,
    I just read this thread, followed the instructions and successfully installed the driver from Canon, but now I can't get 11.04 to find the driver. How do I actually tell the operating system to use the newly installed driver. I'm sure this is a stupid question but I'm a total beginner.
    Thanks

    Ed

  9. #9
    Join Date
    Apr 2009
    Location
    Papakura, NEW ZEALAND
    Beans
    42
    Distro
    Ubuntu Development Release

    Re: 11.04 Upgrade - Canon MF4350d does not work anymore

    My prefered method is not the alien RPM method above, but rather to install the fake-gs-esp method:
    1. install fake-gs-esp
    2. install cndrv common
    3. install canon driver specific to the printer
    This will work for any Canon Printer, I use it to get a Canon iRC2550i working.
    Here are some specific commands for both the MFC4350d
    1. sudo dpkg -i fake-gs-esp_1.0_all.deb
    2. sudo dpkg -i cndrvcups-common_2.20-1_i386.deb
    3. sudo dpkg -i cndrvcups-ufr2-uk_2.20-1_i386.deb
    and the iRC2550i
    1. sudo dpkg -i fake-gs-esp_1.0_all.deb
    2. sudo dpkg -i cndrvcups-common_2.20-1_i386.deb
    3. sudo dpkg -i cndrvcups-ps3-uk_2.20-1_i386.deb
    Hope this helps.
    Ubuntu 10.04 NBR on Asus EeePC 1005PE

    If you don't hear back from me, I forgot to subscribe to the thread, sorry... send me a message, to give me a poke and wake me up.

  10. #10
    Join Date
    Aug 2010
    Beans
    50

    Re: 11.04 Upgrade - Canon MF4350d does not work anymore

    Yessss!! Worked perfectly. I can now print to my Canon. Thanks so much. Appreciate your assistance.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •